NXFree keyboard layout

I have a problem with NX Free, when I connect to shadow session I have different keyboard layout in it (I can’t use arrow keys etc.)
I can fix this by adding this to ServerFlags in xorg.conf →

Option "AutoAddDevices" "false"

but then I don’t have polish characters on my laptop :
When I add:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "pl"

to xorg.conf X server won’t run.
What ca I do?