Nxclient won't connect to local desktops

A freshly installed Suse 11 i386 with freenx and NoMachine’s nxclient installed

When I try to login with the client it fails on downloading the session information, this is the message I’m getting:

NX> 707 SSL tunneling: 1
NX> 1009 Session status: starting
NX> 105 /usr/bin/nxserver: line 1368: 8430 Terminated sleep $AGENT_STARTUP_TIMEOUT
NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1.

It then suggests running this command to ‘test basic functionality’

ssh -X myserver; /usr/bin/nxnode --agent

Successfully logs in:

Last login: Sun Jan 4 16:41:01 2009 from console
Have a lot of fun…

Goes on to say this:

Can’t open /var/lib/nxserver/db/running/sessionId{8E79E68B1245A3285063246CF85E296F}: No such file or directory.
mv: cannot stat `/var/lib/nxserver/db/running/sessionId{8E79E68B1245A3285063246CF85E296F}’: No such file or directory
NX> 1006 Session status: closed
NX> 280 Exiting on signal: 15

This error occurs only when logging in to accounts on the machine the nx server is running on

Logging in to any accounts on any of the other machines on my lan works fine (I have 2 other machines on suse 11 running an nxserver, no problem with those)

The folder /var/lib/nxserver/db/running is owned by the nx user and the root group with full write permissions to the nx user

I tried changing it so everyone has full permissions temporarily, made no difference at all

Anyone have any ideas or suggestions?

I did a thread on this in Applications but over a period of several days, no-one replied, hope I haven’t done wrong by creating a thread on the same subject here

Hi there,

I had almost identical problems with Nxmachine under 10.3 and tried everything. Eventually they updated the packages and I installed them using the 3 RPMs from NoMachine NX - Download: NX Free Edition for Linux which worked perfectly. You might want to try those rather than the ones in Yast. I too spent several hours going around in circles on these very issues. Though I have not tried in 11 / 11.1, I would start there.

Pete Eby

Hey there,

I had been meaning to reinstall this anyway - so I just grabbed the client, node and server RPMs from the official site as above. They installed and the nxserver service started automatically post install with no problems. I was then able to connect from my Windows box running the Windows NXclient with no issues. Looks like these latest versions work fine with Suse 11.0 - I would definitely recommend using them.


I’ve always used freenx in conjunction with nomachine’s client and never came across this problem before

It is by the way suse 11 not 11.1, and I did try the nomachine packages after first encountering this problem but took them back off as I had the same problem with those and the free nomachine server does have a limitation on the number of simultaneous connections

My memory could be letting me down here but I think it allows two at any given time

Starting to look like I may have to file this one away under ‘Unanswerable’ :frowning:

Hey there,

Yea, for some reason this can just tend to be a pain. I do recall digging through some logs on both client and server side when I had this issue, but in truth it did not help much. Eventually the updated the packages and in my case that resolved the issue. Sorry I don’t have any magic solution for you.


I am not sure as to whether anybody got any further with this but I have run into the same issues. Interestingly enough, uninstall/purge and install/setup-nomachine-key did not clear the error. I was still getting a “file not found” message.

However, it seems that in logging onto the NX server (as in through the command line - ssh’ing on) and then running a “nxnode --agent” on the box resulted in an error message seeming to point to the presence of X being locked and if you wanted to continue to remove the “/tmp/.X0-lock” file. I removed the file, restarted nxserver and then was able to connect up again. I should add that I am not logged into the console of the machine in question (no one is, hence the use of NX).

Perhaps the FreeNX scripts aren’t clearing up this lock file?

I should also add that this is under OpenSuSE 11.1 (the thread started off concerning 11.0). Using NX under 11.0 I did not run into any such problems (KDE3.5 desktop). This problem has only started under 11.1 using KDE 4.1 (fully updated with OpenSuSE repositories - as in alternate repository, not the plain OpenSuSE updates) and using the new FreeNX repository (since FreeNX has been spun off from the main OpenSuSE 11.1 distribution - it was included in 11.0).

Another thing, I am using the latest 64 bit NoMachine client (3.3.0-6) under OpenSuSE 11.1 (so 11.1 box talking to a 11.1 box).

Another thing I should add is that I have also tried the NoMachine client/node/server combination on the same machines with exactly the same results. Therefore, perhaps there could be something under KDE4 or X that is not cleaning itself up properly?

In total it is a weird error that I have tried to track down further but have not had much success with it. :\

Well, an update on the above. It looks like the /tmp/.X0-lock file doesn’t seem to be the culprit. I have had the problem yet again and removing hasn’t resolved the issue.

In checking once more it seems that I get the following sets of errors:

xxxx@xxxx:~> nxnode --agent
NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.2.0)
NX> 716 Starting NX Agent …
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/xxxx:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
_XSERVTransSocketUNIXCreateListener: …SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Error: Aborting session with ‘Cannot establish any listening sockets - Make sure an X server isn’t already running’.
Session: Aborting session at ‘Thu Feb 26 22:21:06 2009’.
Session: Session aborted at ‘Thu Feb 26 22:21:06 2009’.
NX> 716 NX Agent exited with status: 1
NX> 1001 Bye.

Well, I have disabled IPv6 on the box (through the Network Settings in YaST). The reason for this is that it seems that there is some sort of name lookup bug with 11.1 whereby the OS seems to prefer IPv6 lookups over IPv4. The simple resolution to this problem is to disable IPv6. However, it seems that this has leaked into other things in the OS judging by the output above.

I do know that setting “AddressFamily inet” in /etc/ssh/sshd_config forces the ssh server to use IPv4 instead of both or just IPv6 (and I am using FreeNX - setting this sort of thing under nxssh (from NoMachine “free Linux server”) is not possible since it is a binary and I am not sure as to where it gets its configuration from).

So, it looks like for the moment I am back to re-running the nxsetup routines until some sort of IPv6 issue can be resolved. Oh well… :disapointed:

An update on this. It seems that I have got things working using the following routine:

  1. Fire up nxclient on the client box and hit the server. It will error out with the message mentioned above. After this shutdown the nxclient process.
  2. Log on as root onto the server to be accessed (through ssh). Delete the “/tmp/.X0-lock file”.
  3. Performing a “nxserver stop; nxserver start” on the remote box.
  4. Run the nxclient on the client box once more to the remote server. It should log in correctly.

So, admittedly this is a bit of a PITA but it does work. However, it is not the sort of thing that I would recommend for a “production” setup whereby you have a user community to support. This is a pity since I have FreeNX and nxclient supporting a bunch of users under OpenSuSE 11.0 and I would really like to upgrade the box!

Is anybody encountering these sort of issues under 11.1 or am I the only one running bleeding edge stable stuff? :nerd:

i think there’s more than one problem here (cannot create socket and also a lock file).

anyway, with 11.1 i eventually got things working by using client and server software from the opensuse build service Index of /repositories/NX/openSUSE_11.1


An update on this. It seems that if I keep on using the NoMachine client against the server, after repeated attempts (and failures on each) the connection goes through. It is usually around the third attempt that the connection gets established. So, no more having to re-run the nxsetup routine.

The workaround I have at the moment is to repeatedly run a login connection on the NoMachine client. I don’t need to re-start the client - just press Cancel to cancel out of the failed connection to acknowledge the message and then the Login button to retry the connection. After several goes the display connection becomes established.

Andrew, yes, I am using the Build Services version of FreeNX on the server side since FreeNX is no longer part of the OpenSuSE 11.1 distribution (there are other posts covering this). On the client side I am using the latest NoMachine Linux NX client.