NX Failed authentication NXSsh exit status 255

Hi,

Recently I get the error Authencation failure for user and therefore some messages in /var/log/messages:



Oct 14 16:48:31 server sshd[28204]: Accepted publickey for nx from 84.62.15.147 port 49820 ssh2
Oct 14 16:48:32 server NXSERVER-3.4.0-17[28212]: ERROR: Failed authentication. NXSsh exit status is:255 'NXNssUserManager::auth'
Oct 14 16:48:32 server NXSERVER-3.4.0-17[28212]: Failed SSHd authentication for user 'username', to '127.0.0.1', port '666': ' ssh_exchange_identification: read: Transport endpoint is not connected#015
' 'NXNssUserManager::auth'
Oct 14 16:48:32 server NXSERVER-3.4.0-17[28212]: ERROR: Error while trying to authenticate user:username. NXNssUserManager::auth returned 255 'NXShell::handler_login'
Oct 14 16:48:32 server NXSERVER-3.4.0-17[28212]: ERROR: failed 'sshd authentication' for user 'username' from '84.62.15.147'. NXShell::handler_login NXShell 373


I don’t know why they are coming^^

How can I fix that?

thanks

On 10/14/2011 04:56 PM, Thorus wrote:
> I don’t know why they are coming^^

i’m not a networking guru, so this might not be helpful:

did you edit the log replacing something else for ‘username’, or is it
what you actually logged ?

do you know someone at 84.62.15.147 (somewhere in Germany) who might be
trying to interact with the No Machine Desktop Virtualization and Remote
Access server you are running?

did you not assign them a user name and password?

btw, why are you running the remote access server?


DD
openSUSE®, the “German Automobiles” of operating systems

I replaced my username with username!
Yes this was myself trying to connect via NX, my username and password is correct, via ssh I can login!

Im running the remote access server to have remote access xD, mostly I’m using ssh but sometimes I need X-Server and therefor I use NX, which was working well…

I think I know where the problem is, but I don’t know how to solve it…

I changed the Port of my ssd from 666 to 665 because of our buggy router(doesn’t forward 666 but 665-.-), where I have to change it to 665?

Ok I got it, hat to change sshd_port AND sshd_auth_port in /etc/NX/etc/server.cfg

Thanks!

On 10/14/2011 09:06 PM, Thorus wrote:
>
> Ok I got it

i’m very happy you stuck with it until you got it sorted out!! congrats!


DD
openSUSE®, the “German Automobiles” of operating systems