NVS4200M + 13.1 results in X11 no devices detected


some time ago I read that the ‘new’ kernel 3.12 should support NVIDIA optimus and therefore I decided to give it a try. On my Thinkpad T420S I switch from the integrated graphics only mode to Nvidia Optimus which infact allows the NVS4200M and the internal Intel graphics to be used.
Then in booted in 13.1 and installed a 3.12 kernel from the repository and successfully booted into it. Then, I added the Nvidia repository ( ftp://download.nvidia.com/opensuse/13.1/ ) and installed the automatically suggested Nvidia drivers. Now, after rebooting, my X11 seems to be ‘broken’ and I get the following error:

10.913] (EE) No devices detected.
10.913] (EE) Fatal server error:
10.913] (EE) no screens found(EE) 

Unfortunately, I dont know how to open the console, because the only thing I see is the boot log. The linked log files I extracted from my windows which is installed on another partition. Is there any way to fix this problem? Thank you very much in advance!

Please see for the complete Xorg.log here: 10.832] This is a pre-release version of the X server from The X.Org Foun - Pastebin.com](http://pastebin.com/p7xQmxqL)
and here the boot log: dracut-initqueue[233]: ln: failed to create symbolic link ‘/dev/resume’: File ex - Pastebin.com

Choose “Recovery Mode” in the boot menu (under “Advanced Options”). Your system should boot then without using the nvidia driver.
Then uninstall the 3 nvidia packages.

The proprietary nvidia driver doesn’t support Optimus systems. You need Bumblebee if you want to use it:
SDB:NVIDIA Bumblebee - openSUSE

Thanks for your reply!
I booted into recovery mode and deinstalled the 3 nvidia components. Then I rebooted, but again there is a problem. Then, I switched again into the integrated graphics only mode and got the same problem (please see log here 8.436] This is a pre-release version of the X server from The X.Org Foun - Pastebin.com](http://pastebin.com/EsYuMfXV) ).
It seems that its still trying to load the nvidia module. How to tell him that it should load the intel module instead?

thank you!

Remove /etc/X11/xorg.conf, that was either created by the nvidia driver installation or by you…
If no driver is specified, X chooses the best one automatically.

You can’t use the NVIDIA driver as is. You need Bumblebee + modified NVIDIA packages.

This should help you https://forums.opensuse.org/blogs/knurpht/bumblebee-dkms-nvidia-331-20-opensuse-153/
Read the entire post. Make sure that you remove all traces of the nvidia driver, that you add your user to the bumblebee group after the install, and to enable and start the bumblebeed.service (can be done through Yast - System - Services). Then reboot.