nvidia with xen

Again a thread dealing with nvidia and xen … but this one´s different :wink:

I tried to install nvidia driver on opensuse 11.4 as described here Nvidia support for Xen - nV News Forums.
Unfortunately it doesn´t work. I´m able to compile the driver with standard kernel as well as with xen kernel.
With the standard kernel the desktop effects in KDE work beautifully. When I boot with xen kernel and start KDE (after recompile the driver
and loading the nvidia module) kwin tells me, that the desktop effects were disabled because compositing is to slow…

log entries form standard and xen kernel are the same when nvidia driver is loaded:

.....
[17754.047605] nvidia 0000:01:00.0: PCI INT A disabled
[17765.372650] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[17765.372662] nvidia 0000:01:00.0: setting latency timer to 64
[17765.372667] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=io+mem
[17765.372854] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  270.41.06  Mon Apr 18 14:53:56 PDT 2011
.....

The Xorg.0.log file is identical for both kernels.

I tried to play around with several options in xorg.conf:

Section "Screen"
    Option         "RenderAccel" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"
    Option         "TwinView" "0"
    Option         "UseEvents" "false"
    Option         "TripleBuffer" "1" 
    Option         "BackingStore" "1"
    Option         "PixmapCacheSize" "70000"                                                                                         
    Option         "OnDemandVBlankInterrupts" "true"
...
...
EndSection

None of these options are necessary to make desktop effects work with the standard kernel. With xen nothing helped.

The only “alarming” message I could find is in .xsession-errors :

OpenGL vendor string:                   NVIDIA Corporation
OpenGL renderer string:                 GeForce GT 430/PCI/SSE2
OpenGL version string:                  4.1.0 NVIDIA 270.41.06
OpenGL shading language version string: 4.10 NVIDIA via Cg compiler
Driver:                                 NVIDIA
Driver version:                         270.41.6
GPU class:                              GF100
OpenGL version:                         4.1
GLSL version:                           4.10
X server version:                       1.9.3
Linux kernel version:                   2.6.37
Direct rendering:                       yes
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
kwin(10858): Invalid framebuffer status:  "GL_FRAMEBUFFER_UNSUPPORTED" 

Dr. Google doesn´t give any help on “GL_FRAMEBUFFER_UNSUPPORTED”. I don´t even know, if this message
is the cause of my problem.

This is driving me nuts… :’( … help!!!

ok … a little update…

I tried different nvidia driver versions:
270.41.06 - result as described
275.43 same result
290.10 kwin crashes when I try to enable desktop effects

I found some old bug reports describing, that nvidia driver version > 260 cause kwin to crash with kde > 4.6.0 on 64-bit systems

So I tried it with a 32-bit system. Unfortunatelly I am not able to compile the driver for the xen kernel.
I get this message:

ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

   If you are using a Linux 2.6 kernel, please make sure
   you have configured kernel sources matching your kernel
   installed on your system. If you specified a separate
   output directory using either the "KBUILD_OUTPUT" or
   the "O" KBUILD parameter, make sure to specify this
   directory with the SYSOUT environment variable or with
   the equivalent nvidia-installer command line option.
   
   Depending on where and how the kernel sources (or the
   kernel headers) were installed, you may need to specify
   their location with the SYSSRC environment variable or
   the equivalent nvidia-installer command line option.

Kernel source and devel packages are installed for the running kernel (2.6.37.6-0.11-xen)
I also ran

make oldconfig & make prepare

I also tried to specify source and output directory by:

export SYSSRC=/usr/src/linux-2.6.37.6-0.11
export SYSOUT=/usr/src/linux-2.6.37.6-0.11-obj/i386/xen/

and of course as always


export IGNORE_XEN_PRESENCE=1

but I always get the same error message. I didn´t encounter this problem on
the 64-bit system. Configuring the kernel sources was not necessary.

Next step I tried to update to kernel 3.2 - result stays the same >:(

What am I doing wrong ???