Nvidia will not reinstall after kernel downgrade

Today I ran zypper dup with the following repos enabled:

 5 | Tumbleweed                       | Tumbleweed                       | Yes     | Yes    
 6 | TumbleweedPackman                | TumbleweedPackman                | Yes     | Yes    
 8 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes    
10 | download.opensuse.org-standard   | Main Repository (Contrib)        | Yes     | Yes    
12 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes    
13 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes

These are the Tumbleweed repos and the standard openSUSE 11.4 repos.

In the process the kernel was downgraded to 2.6.37, here’s the vendor change memorandum:

 kernel-desktop                  obs://build.opensuse.org/openSUSE:Tumbleweed -> openSUSE

As usual, after a kernel change I ran the Nvidia installer “the hard way”. It failed to complete, with this error/warning message:

ERROR: The kernel header file ‘/usr/src/linux/include/linux/version.h’ does not
exist. The most likely reason for this is that the kernel source files
in ‘/usr/src/linux’ have not been configured.

How do I fix this missing kernel header file etc.


PS: lucky for me I made a copy of the root partition before the event, when I saw (in zypper’s preamble) that the dup would be a big one. If you guys can’t tell me how to fix this, I can restore Tumbleweed to pre-dup status.

It reads like the kernel-source is not the same version as your kernel. Can you check that ?

rpm -qa '*kernel*'

Thanks oldcpu. Between my post and your reply I had more serious trouble with the Tumbleweed-upgraded. I restored nouveau and was able to boot into it but it was really kinky in there. Recall I told you the upgrade required just plain “zypper dup” with all 11.4 repos attached. Apparently it actually downgraded large portions to 11.4 (including the kernel) and other portions were upgraded to the TW repo. The result didn’t work. I wonder if this mailing-list entry explains the strange behaviour:

Title: [opensuse-factory] Problem updating to KDE 4.6.3 on a x86_64 system with Tumbleweed

Hi All,

since May 9th KDE 4.6.3 has been added to tumbleweed.
It seems that the tumbleweed repo data for x86_64 is pointing to the
i586 repo.

When I try to update to KDE 4.6.3 on my x86_64 system with zypper I get
the following output:

zypper dup --from Tumbleweed
Loading repository data…
Reading installed packages…
Computing distribution upgrade…
120 Problems:
Taking a peek into the repo at

Index of /repositories/openSUSE:/Tumbleweed/standard/x86_64

shows that no kde 4.6.3 packages are present.



So I junked the root partition and wrote back the copy I made before doing the upgrade.

I think I’ll wait until I see gregkh’s reply to The Mailing List query, before trying this again.

ouch! That is a huge error.

Glad I have not been updating (for a number of days), and so I missed ALL of this fun.

I’m just so relieved that I made a backup. Restoration took just 10 minutes.


When your kernel tree gets messed-up like this, I recommend the following procedure:

cd /usr/src/linux
make mrproper
make cloneconfig

This assures that the kernel source is configured exactly the same as the currently running kernel.

Neil Darlow

Thanks Neil