Nvidia Video Problem after DVD update 11.3x64 to 11.4 x64

Spent last couple of hours trying to get suse running again, am stuck.
Prior to updating suse was running slow. The desktop would act “weird” . It started after an update on 11.3. thought updating to 11.4 would fix everything.
Last night Dled a copy of Suse 11.4 burned, checked for errors and did an update. Everything worked fine and booted to desktop. Nice shiny and new, was very happy for about a minute

Currently I get a terminal login screen when trying to boot Desktop, or failsafe ( network doesn’t work on either of these 2). Xen will boot to desktop but toolbar is gone. Hit alt f2 to launch apps ( terminal, firefox, yast) and none show on screen. If I hit alt tab they show up in list.

With zen I hit CTRL+ALT+f2 and did zypper up thinking that would fix the problem. Updated successfully but same problem.
Have a Nvidia 7950GTX so I selected zen, did ctrl-alt-f2 again. Launched yast, added the nvidia.com 11.4 repo and installed the 68xx newer driver. ran nvidia-xconfig and still it wouldn’t boot to GUI. loaded zen again c-a-f2 - > yast found a second nvidia 68xxnewer driver, installed and now have 6 options to select at startup. 2 desktop, 2 failsafe, 2 xen.

Picked the first one and suse loaded. Yay. Ran nvidia settings to fix resolution, saved. Weird thing was only 2 of the desktops backgrounds would change, other 2 were white.
Audio didn’t work, usually a reboot fixes the problem so I rebooted and am back to none working except the xen login that gives me a crippled desktop ( can launch programs but none show up).

At first startup after update to 11.4 desktop backgrounds were changing really fast. Right clicked desktop went to click on desktop settings and that’s when the tool bar down below disappeared ( it was working prior to that). That is when the desktop became crippled.
Second tool bar at top from previous install is still there and can launch folders to open but none show on screen but show in alt - tab.

I can follow directions and use google. Tried everything I can think of and need some help.

Hi. I also tried an update from 11.3 to 11.4 and could not get into KDE. In the end I did a clean install and have seen posts which recommend that as the safest thing to do. After a backup that is!!

Never had to do that before. Hoping there is a simple answer that one of the Suse Gurus might know about before having to spend another four hours getting this resolved.

I too had a failed upgrade from 11.3 to 11.4. I upgraded many times previously without trouble, but not this time. I booted to a live CD, browsed to the web page and downloaded the DVD iso, and did a fresh install without formatting my /home partition. The download took more time than the install, and everything is working fine now, although I had to reinstall some additional software.

Well thought I would give it another go. Since the first time it installed it worked for a bit. Reinstalled ( only thing different was keeping nvidia repo and packman).
On first start got the crippled gui ( no task bar at bottom and open winows/apps were not showing but can be selected via alt/tab)
did CTRL-ALT F2 login in as root.
Did a nvidia-xconfig rewriting the old xorg.
rebooted same thing. Did C-a-f2 again. did startx and now it works if logged in as root.
Screen resolution is working again as well.
At least I can see all my documents and files.

Is it settings in KDE that are causing the problem? or is it something in my xorg cfg/ nvidia settings ?
There has to be a way to reset my user account so It will boot correctly.

Other option is would reinstalling 11.3 ( still have the dvd here somewhere) ?

Reinstalling software is what takes me the most time. I’m still new at this and it will take me hours to configure everything. If I have to I have to but I think this has to have an answer somewhere.


I’m at a loss as on your status. Are you getting into either the Default or Desktop openSUSE 11.4 as a normal user?
Are your desktops correctly displayed?
What was your last install of of 11.4 x64? Clean or update install? To / (root) partition?

Not sure if nVidia drivers work with Xen so, I’m surprised you see a desktop using “nvidia” drivers, was a 11.3 issue.
Can you post output from your /var/log/boot.msg, /var/log/Xorg.0.log and /var/log/warn?

If you have a GUI you can use “System Log Viewer” to select these logs and to cut and paste from these logs as many lines as need.
If you don’t have a GUI screen, you only have the command line screens

tail  -n 100  /var/log/warn   >  /home/userid/varlogwarn.txt  
dmesg  |  tail  -n 100 >  /home/userid/dmessages.txt 
tail -n 100   /var/log/boot.msg     >   /home/userid/bootmsg.txt  
tail -n 100   /var/log/Xorg.0.log    >  /home/userid/xorg0log.txt 

Please use SUSE Paste to paste your results and paste the URLs in your reply.

Am going to try the reinstall in a few days. Looking through the logs now. Wow there is a lot in var/log/warn. Will post tomorrow going to turn in.
I tossed in my old 11.3 dvd after 5 hours and got it running. Only to have GUI problems when installing the nvidia driver. Second attempt worked and running smooth as of now. I’m going to read up some more on configuring the nvidia driver. 11.3 is working better( an happy about that) not as laggy as before. Able to set the correct resolution of my new monitor. I did have a conflict when doing the 11.3 x64 upgrade install with nvidia go1 and go2 ( left the FTP nvidia.com suse 11.3 repo active when installing).

What I learned is that an update install ( in my case) didn’t fix the problems I was having with 11.3. and that its best to resolve the problems first rather than hoping that they will just go away with a upgrade install.

I appreciate all the help. Know it has to be something simple. Will be happy when I can figure this stuff out better in the future. Live n’ Learn

You should always try a second user since the problem my be in the configuration files.

Got it, you did get a GUI as ordinary user but you couldn’t see any programs?

Now I wonder if it wasn’t a problem of clicking you clicking hide the desktop on the toolbar? Looks like a folder icon on my OS 11.4 Gnome taskbar. Took me awhile to figure that out. Still it could be a bad 11.4 upgrade or old user configuration versus new configuration.