nvidia updates time out / kernel panic

Using zypper dup My system fails to complete the nvidia driver update. I was forced to kill the zypper process and later, to force the system off. Now my newest snapshot boots into a kernel panic. I’m able to boot from the last snapshot but the update process continues to hang.

I had some issues updating the nVidia driver a few weeks ago and could not remove the driver. Eventually I was able to move past it and update the rest of the system.

How can I manually remove the nvidia driver or repair the system?


zypper dup

on Leap?


zypper up

Can you start with an older Kernel?

Can you start with an btrfs snapshot?

Load into command prompt with kernel parameter “3” and delete drivers with zypper.

That’s what I’ve always used since I started with Tumbleweed. I’ll switch to “up”, thanks.

Can you start with an older Kernel? Can you start with an btrfs snapshot?

Yes to both. I was able to boot from the previous kernel a few times, now that is also experiencing a kernel panic on boot. I’m now running on the second oldest kernel. I’ve tried to rollback to an older snapshot (“sudo snapper rollback 2175”) and upgrade from there but I’m getting blocked by the following error:

Cannot detect ambit since default subvolume is unknown.
This can happen if the system was not set up for rollback.
The ambit can be specified manually using the --ambit option.

Thanks, I was eventually able to boot like this – I first tried booting ‘into command prompt’ from the grub menu, then realized you meant something else.

Attempting to remove the nvidia driver with zypper stalls at 50% from the terminal just the same as using yast.

Since I can’t rollback to an earlier snapshot (the single biggest reason I use SUSE!), it looks like I have to reinstall.

You have set this Thread to Leap 15.3, therefore I asked for zypper dup vs zypper up.

>That’s what I’ve always used since I started with Tumbleweed. I’ll switch to “up”, thanks.

Now You say you use Tumbleweed:
Tumbleweed use zypper dup
Leap use zypper up
for updating your system.

Can you see something more with zypper when you use:

zypper -vvv dup

Also post:

cat /var/log/zypp/history

Maybe its too long, use susepaste:

cat /var/log/zypp/history | susepaste -e 0 

and post URL here.
Also post:

cat /var/log/zypper.log

Also maybe as text file:

cat /var/log/zypper.log | susepaste -e 0

or copy/paste it to:

I’m using 15.3. I meant that I started using SUSE on Tumbleweed.

The -vvv doesn’t tell me much. Using zypper dup always fails on the nvidia upgrade so I’m trying to resolve that directly. Here’s the output of

# zypper -vvv remove nvidia-g*
Verbosity: 3
Non-option program arguments: 'nvidia-g*'
Initializing Target
Reading installed packages...
Force resolution: Yes
Selecting 'nvidia-gfxG05-kmp-default-470.57.02_k5.3.18_57-lp153.43.1.x86_64' for removal.
Selecting 'nvidia-gfxG05-kmp-default-470.63.01_k5.3.18_57-lp153.43.1.x86_64' for removal.
Selecting 'nvidia-gfxG05-kmp-default-470.74_k5.3.18_57-lp153.44.1.x86_64' for removal.
Selecting 'nvidia-glG05-470.63.01-lp153.43.1.x86_64' for removal.
Resolving package dependencies...
Force resolution: Yes

The following 4 packages are going to be REMOVED:
nvidia-gfxG05-kmp-default  470.57.02_k5.3.18_57-lp153.43.1  x86_64  obs://build.suse.de/Proprietary:X11:Drivers
nvidia-gfxG05-kmp-default  470.63.01_k5.3.18_57-lp153.43.1  x86_64  obs://build.suse.de/Proprietary:X11:Drivers
nvidia-gfxG05-kmp-default  470.74_k5.3.18_57-lp153.44.1     x86_64  obs://build.suse.de/Proprietary:X11:Drivers
nvidia-glG05               470.63.01-lp153.43.1             x86_64  obs://build.suse.de/Proprietary:X11:Drivers

4 packages to remove.
After the operation, 406.5 MiB will be freed.
**Continue? [y/n/v/...? shows all options] (y):**
(1/4) Removing nvidia-gfxG05-kmp-default-470.57.02_k5.3.18_57-lp153.43.1.x86_64 ................................................................................<50%>

The logs seem to show a missing directory for nvidia files. What I’d like to do is rollback to a snapshot from a month or two ago and see if I can upgrade normally from that point.

Even after a successful rollback to a snapshot from two months ago, the kernel update failed. I’m not sure what got snafu’d but I reinstalled and am better off now.

Thanks for the suggestions and for the Google results, I had to use the ambit parameter to solve for the ambit error mentioned above and actually rollback.

snapper rollback --ambit classic 2175