NVidia Update Kills Angry Birds!

Hello, SuSE people! Long time no post.

This isn’t an emergency; it’s an annoyance. It appears that an automatic update “improved” my NVidia drivers. Here’s the pertinent info from /var/log/zypp/history, trimmed for better flavor:

2012-05-02 21:36:02|install|nvidia-gfxG02kmp-desktop|295.40_k3.1.0_1.2-14.1|x86_64
2012-05-02 21:36:03|install|nvidia-computeG02|295.40-15.1|x86_64
# 2012-05-02 21:36:08 x11-video-nvidiaG02-295.40-15.1.x86_64.rpm installed ok
2012-05-02 21:36:08|install|x11-video-nvidiaG02|295.40-15.1|x86_64

As you can see, it was just installed a couple of days ago. Everything else seems to be working OK, except for playing Angry Birds under Wine, and desktop effects. Angry Birds under Wine is now so painfully slow that it’s unplayable. My other Wine apps seem to be OK – for example, I can give LTSpice a rather complicated switchmode power supply circuit to model, and it seems to chug along at about the same speed as always. Therefore, I conclude that Wine is OK. (Those of you who run large SPICE simulations know what I’m talking about: they’re VERY processor-intensive.)

The effects, I think, are my clue that the NVidia update may be my issue. When I created a new user this evening to do some tinkering, it took the desktop quite a while to load, and I got a message that “effects had been disabled” because it was “taking too long.” I hadn’t noticed before tonight because I have effects disabled in my primary desktop. I only noticed it when I created that temporary user to try a couple of things.

I’m using an older GeForce 6150SE nForce 430.

Has anyone else had problems with this latest update? How can I roll back to the previous version, and if I do, will it kill anything else?

Thanks for any tips and advice.

(cough) It might help if I also mentioned that I’m running the x64 build of OpenSuSE 12.1, Gnome Desktop, on a nice dual-chip AMD box here at the house. 4 gig of RAM, and that particular graphics card has 256 Meg of RAM installed.

Either downgrade the nvidia driver to version 290.10 (you can still get it here: Index of /opensuse/nvidia/12.1/x86_64), or wait for version 295.49.1 - which fixed this bug - to be available in repo, or install another version of the driver “the hardd way”.
See this thread where this bug - among others - has been discussed: http://forums.opensuse.org/english/get-technical-help-here/hardware/474525-nvidia-driver-295-40-15-1-crashes-my-system-5.html

Ahh. So it IS a bug. Thanks a lot.

I’ll just wait, then. Like I said, it’s not an emergency.

And as proof that I was tired when I wrote that, I said I’m using Gnome. Actually, I’m using KDE 4.7.

Now I shall inhale two (2) cups of coffee, then head to work!!! Thanks again.

The 295.49 is already in the nvidia site download. You might want to try it the hard way.
I tried it last night. I noticed something different with my card, first time it heats up to
70 degrees though.:\

My bad, I replace a ram a couple of days ago
maybe I accidentally move the card wiring
and the fan malfunctioned. I cleaned the card also
and now all is well. Last night in 5 minutes or more after boot
it shoots up to 70 degrees C, now I it is running for about 2 hours and
at 44 degrees.C

I have had a wire stop the fan from running and it does get hot pretty fast I know. So 70c is 158f and hot enough to burn your finger I would guess. While 44c or 111.2f is just right to take a shower with, if it was hot water. I just checked mine and it says it is at 36c or 96.8f and it is a nVIDIA 560. The case I have is a Antec 100 and it has more fans than I have ever had before and it seems to run everything very cool. Anyway, it was interesting to hear about your high temp issue the other day.

Thank You,

Hmm, I have a question. I’m using the 64 bit Kernel:

linux-clmk:~ # uname -a
Linux linux-clmk 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux

See my posting from /var/log/zypp/history, above. NVidia’s Website says that I should be using the 173.xxx series drivers for 64 bit Linux, but the OpenSuse installer chose the 32 bit (the 295.xx series). It’s Saturday, and I’m not doing anything important, so I think I’ll try the 173.xxx install the “hard” way. Only thing is, I vaguely seem to recall that I had problems with that one on an earlier version of OpenSuse (11.1?? Can’t remember).

Interesting. I’ll see what happens. Thanks again for the help.

EDIT: well, I just re-checked at NVidia’s Website, ready to download, and now it’s recommending the 295.xxx series again!!! Go figure, I must have entered something incorrectly. Sheesh …

One thing nVIDIA does is to release a unified driver which encompasses most recent GPU chipset releases. We would need to know what nVIDIA card/GPU you have to determine anything more. But I am happy you determined that the latest will work.

Thank You,