nvidia total memory wrong GTX580

I have a upgraded my system to opensuse leap 42.2.
My graphic card is MSI N580GTX with 3gb memory.
Nvidia-gfx-G04 is installed.
All works perfect only nvidia-settings is showing only 1536 total memory.

wrong memory video card N580GTX how to solve

NVIDIA driver is proprietary thus need to ask NVIDIA. Could be bad memory???

In any case here I have 2Gig on a 630 based card and it shows correctly for what it is worth

No because windows 10 (dual boot system) is showing 3000 mb nvidia video memory.

Ask NVIDIA it is their stuff not oopenSUSE’s

The Nvidia gfxG04 driver is Installed within Yast but I guess you’re right

Still no answer. I also am missing cuda support my main program blender is not recognizing the cuda card anymore it worked fine with leap 42.1.
Followed this install:

  1. Open YaST, then click Software Repositories.
  2. Click Add (in the bottom left), then select Community Repositories.
  3. Select NVIDIA Graphics Drivers, then click OK.
  4. Go back to the YaST Control Center and click Online Update.*
  5. Click Extras in the top bar, then click Install All Matching Recommended Packages.*
  6. Click Accept, then wait for installation to complete.*
  7. Restart your computer.

What happended with nvidia and opensuse support disappointed.

Problem solved got a MSI flash rom which solved the problem.

Sorry to hear that you are disappointed about the support.
if you look at the url of nvidia repository it might say http://download.nvidia.com/opensuse/leap/42.2
openSUSE users are sometimes kind to link to closed software and hope that it work. They do not always have influence of what is put there. Community try to help, but sometimes out of control.
Glad that you found a solution, and thanks for sharing that :good:

Nvidia settings is working and showing cuda cores but blender 2.78 cannot see the gpu for rendering. Has always worked .
Again dissapointed.
Windows 10 is working fine.

Nvidia settings is working and showing cuda cores but blender 2.78 cannot see the gpu for rendering. Has always worked .
Again dissapointed.

Did you install the cuda packages??

My system Opensuse leap 42.2 and blender 2.78 with gpu support was working fine untill update installed packages.

Normally users do not need to install the CUDA toolkit as Blender comes with precompiled kernel.

Update nvidia packages on another workstation with openSUSE leap 42.2
Same problem no gpu choise before the update it all worked fine.
Unfortunately I had to switch to windows 10 to finish a blender project.
No time to spend another weekend on nvidia driver problems.

Downgraded Nvidia G04 to G03 driver. Restarted the system and now it all works perfect.
I guess zypper install-new-recommends was not so smart to do.

Blender has now gpu support for cycles render.
openSUSE Leap 42.2 is back on the road.

Sorrg early cheered after restarting the system gpu support blender dissapeared again.

Sorry early cheered after restarting the system gpu support blender 2.78 dissapeared again.

Solved the problem. Used an old ati card removed all nvidia files update with zypper.
Because Yast still could not find nvidia after adding repositorie.

After restart opensuse gui was working with the ati card. Replaced ati by nvidia n580gtx opensuse gui was working installed with zypper install-new-recommends nvidia drivers and kernel. Restarted and openSUSE leap 42.2 was working again. Also gpu support with blender.