Nvidia stopped working after upgrade

I did an update in yast yesterday, and now my Nvidia drivers don’t seem to be working. To my knowledge, neither the kernel or the Nvidia drivers were updated as part of the update, so I’m perplexed.

Here’s what happens:

  • When I boot the computer, I get a blank screen (the monitor thinks there is no signal and immediately shuts off).
  • If I enter a new session (Ctrl+Alt+F1) and run “init 3” and then do anything to start the gui (IE “sax2 -r”, “startx”, “init 5”) I get the same blank screen and monitor shutdown.
  • If I switch to the generic driver (“sax2 -r -m 0=nv”) I’m able to get back into KDE and everything works fine.

I’ve tried uninstalling/reinstalling the nvidia drivers using both the “easy” and “hard” ways and everything has the same result, including the drivers downloaded from the Nvidia site.

Opensuse 11.1 running on AMD Athlon X2-64
Kernel - 20080210_2.6.27.19_3.2-2.1.6-x86_64
Nvidia driver - 185.18.36-7.1-x86_64
Nvidia kernel module - 185.18.36_2.6.27.29_0.1-6.1-x86_64

Any help or suggestions would be greatly appreciated. I don’t know where logs are stored that might shed info on this, so please let me know and I’ll post them.

Do these match?

That is indeed the problem. I once had the same issue. As long as both do not match it will not work, unless you install the nvidia drivers from the RUN package directly from NVidia. Those will be compiled against your running kernel.

I’m very sorry, but it appears there was a typo in my original post. (I typed them out rather than cut/paste.) Here is the Kernel etc. versions according to Yast:

Kernel -
Nvidia Kernel Module - 185.18.36_2.6.27.29_0.1-6.1-x86_64
Nvidia Driver - 185.18.36-7.1-x86_64

That is indeed the problem. I once had the same issue. As long as both do not match it will not work, unless you install the nvidia drivers from the RUN package directly from NVidia. Those will be compiled against your running kernel.

Thank you, but I did try the downloaded run package (the “hard way”) and it did not improve anything.

If it were me, I would remove the nvidia repos, uninstall the driver. Download the latest driver from nvidia and put it in /home/username*
Also download the beta driver and put it in a folder Eg; /home/username*/nvidia

Follow this guide and try again:

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.
Go to Yast>Software>Software Management
Search for and install if you don’t have these:
Now download the latest Nvidia driver:
Place the file in your /home/username
Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login
Type “root” then enter and then your root password and press enter.
now type
cd /home/username
*Now remember you can use the {TAB} key to auto complete
so type:
and the whole file name should auto complete
eg: sh NVIDIA-Linux-x86-185.18.36-pkg1.run
Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

Thank you for the fast response. I followed the instructions you gave and removed the Nvidia repos. I then tried both the “latest” driver (185.18.36) and the latest “beta” driver (190.32) using your instructions, and neither of them fixed the problem. (Computer still boots to blank screen and monitor immediately shuts off)

When I install the drivers using the Nvidia downloads, they don’t show up in Yast once installed. Is this normal?

Any other suggestions would be appreciated.

I noticed a friend of mine posted guide a day or so ago
NVIDIA latest beta for latest cards ‘the hard way’ - openSUSE Forums

Check it out.

I think the manual driver should show in Yast, but I stand to be corrected.

No, this is not correct.

If a driver from a kmp-package matches a running kernel is not automatically bound to the exact same version.

(And especially for nvidia repo this was very often the case as they do not always refresh/rebuild their kmp-packages.)

Kernel Module Packages - openSUSE

Insufficient information without the respective kernel flavors (or using the full package names).

The package name for my kernel is “kernel-default” and I made sure the Nvidia drivers from the repo were “default” as well.

I removed the Nvidia repo in the last step, so I can’t tell you what the nvidia driver package name is anymore. (Per my previous post, the “manual install” drivers don’t show up in Yast after install for some reason. Is there a way to check what is installed?).

caf4926: Thanks again, I’ll follow those “alternate” instructions and post the results.

Followed these instructions, and the same result occurs (blank screen with monitor shutdown at sax2 command).

However, when I did the init 5 && exit, instead of going blank the whole screen started flashing solid colors. It did this until I hit Ctrl+Alt+F1. It’s something new at least. Any ideas?

Of course they don’t because they were installed manually and not via package management.

If you know which files would be installed by some installer, you can check, if they exist.

This is very difficult here, the best way to find that out is when it works.

That’s why it is only the second best solution to install manually, using the repos and then fixing the problems would have been a lot more prudent IMHO (especially when both methods give you the exact same version), because the drivers are known to work, so it is more likely, you did something wrong.

Without sufficient information (Xorg.*.log, messages/dmesg etc.) one can not really help but only guess, so it’s up to you to provide it.

How’s the monitor connected? VGA cable?
What’s the monitor? Resolution?
What’s the card?
Did you uninstall the nvidia modules through Yast? I’m almost sure there’s remains of them.
Output of ‘glxinfo | grep NVIDIA’ ?


Side note for all “manual install users”.


Rebuilding from src.rpm is certainly cleaner.

-Monitor is connected via DVI.
-Monitor is an ACER X223W at 1680x1050.
-Card is a GeForce 6500.
-I did uninstall the Nvidia modules through Yast prior to removing the repo. Should I add the repo and try installing/uninstalling them again?
-Output of 'glxinfo | grep NVIDIA:

queequeg@ODIN:~> glxinfo | grep NVIDIA
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

Thank you for the response

Sorry for my ignorance, but I don’t know where to find this information. (Xorg.*.log, messages/dmesg etc.) Would you mind guiding me in the right direction?

Having had problems with nvidia, I think this works:

install latest nvidia drivers using either 1-click installer or nvidia repository to download the correct nvidia driver
check what $sax2 -p finds
run $sax2 -r
run $nvidia-xconfig

If you can boot failsafe mode, the GUI application nvidia x-settings will tell you what it can see.

Also check this:

Fixed it!

Weird, but here’s what I did:

  • Added the Nvidia repos again.
  • Using Yast, intentionally added the wrong driver (G01 instead of G02. It obviously didn’t work).
  • Using Yast, removed the wrong driver (G01) and re-added the right one (G02).

Now everything is working fine.

I have no idea why this worked. Maybe temporarily adding the wrong driver helped to clear out some corrupt files so the correct one could be added cleanly again? I’m just glad Compiz is working again. I didn’t realize how much I’d miss it until it was gone.

Thanks to everyone for their responses.

Let’s hope it didn’t stress you too much. A happy ending anyway, well done;)

Update: This post is for anybody looking for information on the same problem I was having (monitor shutdown after initializing driver). If your display completely shuts down, and you don’t even get a blinking cursor, it usually means that your video card has more than one output and Sax is using the wrong one. This is what was happening with my machine, and it happened again (randomly) later.

To fix it I had to specify the monitor output by adding the following line to the “Device” section of xorg.conf:

Option "ConnectedMonitor" "DFP-0"

I’m using a DVI output, so if yours is VGA instead you would use “CRT” in place of “DFP” in the above code.

Hope this helps others who have a black screen but “know” :wink: they have their drivers installed correctly.

Here is a thread that discusses it more in depth.