nvidia-settings no xorg.conf after update no seperate x screen or twinview ?

I have installed openSuse 11.3 i586. update wit Yast latest packages and now I am missing xorg.conf
Something is changed to xorg.conf.d why ?
Installed Nvidia
SDB:NVIDIA drivers - openSUSE

works great but I cannot activate seperate x screen or twinview anymore.
And where should I save the configuration and with what name?
very confusing I am not happy wit this.

Have a read of this graphics guide. In particular, the section titled ‘xorg.conf file and xorg.conf.d directory in Linux’. The legacy /etc/X11/xorg.conf file is not normally required any longer, but is still respected when it is present (for specific configuration of graphics hardware).

The ‘nvidia-xconfig’ utility can be used to generate a working xorg.conf if necessary.

For automatic config with two display devices on a single card you can do

nvidia-xconfig --twinview

Then you can tweak further with the graphical ‘nvidia-settings’ utility. Become root with

su -



Some useful NVIDIA guides:


NVIDIA Accelerated Linux Graphics Driver README and Installation Guide

SDB:Multiple Monitors - openSUSE

Actually I am having two PCI-e graphic cards which I want to use.
Nvidia -settings is seeing them.
But I cannot activate seperate x screen or twinview.
And where should I save the configuration in /etc/X11 named xorg.conf ?

You could check out post#62 here, in case there is anything of use:
openSUSE Graphic Card Practical Theory Guide for Users - Page 2
where that post originates from here:
RandR / Xinerama - how to make work in OSE 11.2

Not really a answer on my question.

Maybe I have to install the originally nvidia driver.
Nvidia-settings worked always fine for me until now.

save to x configuration was never a problem now it opens a browse box?

saved my settings as you described in etc/X11/ name xorg.conf
Then reboot.
Seperate xscreen is working now but only the mouse is showing on a black second screen.
Have to enable Xinerama that is not what I wanted.

solved in gnome it was working perfect now I am trying to make the system multiseat
multiseat second keyboard and mouse help needed

Thanks for reporting on your progress. Well done. :slight_smile:

Glad to read you made some progress. … is the approach you adopted in this "“multiseat second keyboard and mouse help needed”](http://forums.opensuse.org/english/get-technical-help-here/hardware/463877-multiseat-second-keyboard-mouse-help-needed.html) thread what partially worked for you in Gnome ?

No both xscreen are working in Gnome without enabling Xinerama.

Thank you! GEForce GT520 worked beautifully, except that the system thinks my old (CRT) screens are 1024x768 when they are 1600x1200; I guess will have to
tweak xorg.conf by hand for the resolutions…