Nvidia-settings: How to disable panning?

Hi, there!

I have MBPr where I recently installed openSuse 13.2 (as 3rd OS). Unfortunately KDE 4 does not support scaling for Hi-DPI screens like mine (2880x1800), so I decided to use scaled resolution 1920x1200. But when I set it up via nvidia-settings, or directly in xorg.conf, I struggle from panning issue. When I move cursor to right or bottom edge of the screen the screen moves with cursor!!!

When I change resolution with nvidia-settings it writes to xorg.conf:
Option “metamodes” "nvidia-auto-select +0+0 {viewportin=1920x1200};

It works fine until re-login. Once I relogined I have panning issue.

after relogin xrandr reports this:
Screen 0: minimum 8 x 8, current 2880 x 1800, maximum 16384 x 16384
DP-2 connected primary 1920x1200+0+0 (normal left inverted right x axis y axis) 331mm x 207mm panning 2880x1800+0+0 2880x1800 59.99*+

I tried to set panning explicitly with xorg.conf:
Option “metamodes” “2880x1800 @1280x800 +0+0 {viewportin=1280x800}”

but it doesn’t work!

I extensively googled for this and even read documentation on Nvidia metamodes but I totally failed to fix this issue.

I am terribly shocked how difficult to simply decrease resolution in openSuse! Please help!

Thanks in advance,

If you have a view port set at less then your resolution it is going to pan. The nature of the beast.

Set res and view port the same. Should be able to do that in nvidia-settings

And not sure why you think it won’t work with the hi res. You may need to add a modeline to tell the res of the monitor if that is not coming in automatically if the system thinks the monitor has lower res then it does.

hi gogalthorp, thanks for quick reply.

In basic mode in nvidia-settings one can set only the resolution. Once I lower resolution to some value say 2880x1800 -> 1920x1200 and press apply. It works fine as expected, there is no any panning. To keep this change, I save /etc/X11/xorg.conf file. But once I relogin, the resolution is ok, but I get panning.

I tested this issue on my old machine with GTX8800 and display with native resolution 1920x1200 – the same problem. Once I lower resolution I always get panning.

It is easy to reproduce, if you have openSuse 13.2 just try to lower resolution and relogin. And then move mouse to left or right edge of the screen.

Problem is not that KDE4 doesn’t work with my native resolution 2800x1800, in fact it works absolutly fine, but problem is that you can’t see anything on 15.4" display with this resolution! And as far as I know, KDE4 has no mechanism to scale properly all graphical interfaces, because of Qt4 limitation. Of course I can higher dpi in font-settings, in KDE start to look more-less ok. But then if I connect my MBPr to external display with lower native resolution interface will look horribly big!!!

If it is the size of test and thing that stuff is all adjustable and the higher res makes it clear as a spring sky. rotfl!

Change the dots per inch and or the font sizes.

Your problem is you are not reducing the resolution you are creating a view port. It is possible that your supper duper moniotor is reporting only one resolution and the card is just following instruction from there. So maybe again you need a modeline defining the monitor resolution you want to run at. But in any case it should not be needed since all things are scalable. One of the great advantages to vector graphics is the infinite scalability.

Hi resolution and DPI is great, no doubts about it. The problem is that KDE4 is not ready for it. If you change the DPI used in the fonts then you can end up with more or less usable KDE user interface (tho with lot of issues), BUT I have external 23’’ display with native 1920x1200-resolution that I used to use along with my laptop when I am at home. And if everything is set to look acceptable on 15.4’’ monitor at 2880x1800 resolution it looks unacceptably BIG on 23’’ display at 1920x1200 !!! It is serious problem!

Could you please explain me how I can lower display resolution without having panning issue? Because I failed to add new modeline with lower resolution via xrandr…


Try disabling the kscreen 2
then use nvidia-settings

It works! once kscreen 2 service is stopped it works, no panning! can you explain me why kscreen 2 triggers panning?? What is logic of this issue?

I don’t know.:slight_smile:
I only found out in the version 13.1 when I was configuring my nvidia card also.
To tell you it’s buggy is probably a harsh word so I am refraining from saying it.

Thanks a lot!, you really helped me! Probably without this hint I could spend hours maybe days reading all possible manuals how to add new modelines without any practical exhaust…

You’re welcome, glad I was able to help.