nvidia-settings hangs

Hi,

Sometimes, running “nvidia-settings” will cause the whole desktop to freeze for about 5-10 seconds, spike the Xorg CPU usage up to 100%, until the settings appear where everything goes back to normal.

Running “nvidia-settings” from a terminal does not show any output and restarting X does not help. Any ideas how to figure out what is happening, any places to look for log files?

I am using an up-to-date openSUSE 11.3 (64-bit), KDE 4.5.2, an NVIDIA GeForce 9800GT and the proprietary NVIDIA driver 260.19.12, which I installed manually following the instructions from

SDB:NVIDIA the hard way - openSUSE

Thanks for any suggestions.

So I don’t know what the issue might be, but I am using the same driver, but I am not using KDE 4.5.2, but still with KDE 4.4.4. I have changed my nvidia-settings file to be started as root. You could try this to see if it helps at all. I use the command: kdesu nvidia-settings

I might try this to see if permissions are the problem. It also allows you to save your configurations even when logged in as a normal user. Any way, it is just a thought for you to consider.

Thank You,

On Fri, 29 Oct 2010 08:06:02 +0530, jdmcdaniel3
<jdmcdaniel3@no-mx.forums.opensuse.org> wrote:

>
> So I don’t know what the issue might be, but I am using the same driver,
> but I am not using KDE 4.5.2, but still with KDE 4.4.4. I have changed
> my nvidia-settings file to be started as root. You could try this to
> see if it helps at all. I use the command: kdesu nvidia-settings
>
> I might try this to see if permissions are the problem. It also allows
> you to save your configurations even when logged in as a normal user.
> Any way, it is just a thought for you to consider.

i’m also using KDE 4.5.2, and nvidia-settings works without delay, no
matter if i run as root (kdesu) or normal user. i don’t think the reason
is either the KDE version nor root permissions; it’s that darn nvidia
driver trouble many have, and many don’t. but trying via kdesu can’t hurt,
of course.


phani.

My system run’s much smoother after changing to xorg 1.9 and kernel 2.6.36.
Nvidia GTS 250 with 260.19.12 (64bit).

Hans

On Fri, 29 Oct 2010 11:06:02 +0530, kaiserhg
<kaiserhg@no-mx.forums.opensuse.org> wrote:

>
> My system run’s much smoother after changing to xorg 1.9 and kernel
> 2.6.36.
> Nvidia GTS 250 with 260.19.12 (64bit).

my experience is similar: a long time ago i used to have problems with the
11.3 standard kernel & xorg, xorg using up to 100% of one CPU. those
disappeared when i upgraded to the latest kernel from Kernel:/HEAD, and
since then i haven’t had any problems with nvidia proprietary drivers or
xorg (still 1.8 at this time).

but i seem to remember that also users of kernel 2.6.36 are among the
sufferers of this nvidia-trouble with the latest driver, that’s why i
don’t usually recommend upgrading to a later kernel…just don’t know what
causes the trouble with nvidia. suspecting it’s hardware specific, but i
might have something to do with the kernel as well.


phani.

Thank you all for your replies. Unfortunately, running nvidia-settings with kdesu does not make any difference. The kernel I use is 2.6.34. maybe I should consider updating to 2.6.36…

On Fri, 29 Oct 2010 14:06:02 +0530, linuxfever
<linuxfever@no-mx.forums.opensuse.org> wrote:

>
> Thank you all for your replies. Unfortunately, running nvidia-settings
> with kdesu does not make any difference. The kernel I use is 2.6.34.
> maybe I should consider updating to 2.6.36…
>
>

if you know what you’re doing and have a reasonably fast internet
connection, there’s no harm in trying. but if you’re installing the video
driver from the ~.run file, you’ll have to download kernel-source and
kernel-dev as well; quite a few MBs. as far as i’m aware, nobody really
knows what causes these nvidia bugs, and for some people it does work.


phani.

Let’s say I install the new kernel. Will I be able to switch between the current and the new kernel at boot?

On Fri, 29 Oct 2010 15:06:01 +0530, linuxfever
<linuxfever@no-mx.forums.opensuse.org> wrote:

>
> Let’s say I install the new kernel. Will I be able to switch between the
> current and the new kernel at boot?
>
>

if you put “multiversion = provides:multiversion(kernel)” into
/etc/zypp/zypp.conf, yes. (search for ‘multi’ in the file; there’s an
explanation with example in there). after enabling this, you can in yast’s
software manager choose which kernel versions you want to install or
un-install. this is also supposed to update your /boot/grub/menu.lst, but
it’s always a good idea to check that manually before re-booting. this
really is meant for people who know what they’re doing in this regard; if
not, you’re likely to run into trouble.


phani.