nvidia-settings fails to load color correction settings from console

The default color profile is too bright , I’ve lowered the brightness and contrast a bit.

And here’s the problem, if I run nvidia-settings, it opens the gui and applies the settings correctly.
If I use “nvidia-settings --config=~/.nvidia-settings-rc --load-config-only” or “nvidia-settings -l” it fails to apply color correction.

So it seems I must run nvidia-settings gui manually every time I login or the color profile is not loaded.
My temporary workaround for this problem is autostarting nvidia-settings with “sleep 2 && pkill nvidia-settings” line attached.

Is there some other, better way to load the settings? Or this is how it’s supposed to work?
Tried “nvidia-settings -l” as root, it still fails to load color profile.

It appears that these switches and workarounds are no longer necessary.
There was a bug which prevented nvidia-settings from loading the profile correctly.
Fixed in 325.08 version, it loads the correct profile now, just tested it.

I was wondering why I keep losing my settings.

I used to shutdown my computer every night, but now use “Sleep”, and the settings stick.

May try updating to 325.08. May not.