nvidia-settings configuration being lost after reboot (11.4, kde 4.6.0, nvidia proprietary 310.19)

Hi all,

I have a two monitor setup and my problem is that, after installing the NVIDIA drivers, I can configure things as a I like using nvidia-settings after which I write the configuration to xorg.conf. After a reboot, the login appears as normal but when I login as a user, the screen flashes black and the X session starts with the monitors as a clone of each other instead of the twinview setup I configured.

If I login to the X session as root, the screens do not flash black and the screen configuration is as expected…

openSUSE 11.4 2.6.37.6-0.5-desktop
KDE 4.6.0
NVIDIA Quadro FX 2700M
NVIDIA proprietary driver 310.19

I installed the proprietary drivers as recommended:

init 3
rmmod nvidia
sh NVIDIA-Linux-x86_64-310.19.run -q
added nomodeset parameter to end of kernel boot line.
Reboot

After a lot of googling today I have tried the following without success:

Saving the config to /etc/X11/xorg.conf.d/50-monitor.conf
Making xorg.conf read/write for everyone.
With/without the nomodeset parameter.
Without an xorg.conf file.

This worked with older NVIDIA drivers so what do I have to do to get this working again?

Many thanks for your time!

spartan:/etc/X11 # cat xorg.conf

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 310.19 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Thu Nov 8 02:08:55 PST 2012

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from data in “/etc/sysconfig/mouse”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “IMPS/2”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “yes”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Seiko/Epson”
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “Quadro FX 2700M”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-1”
Option “metamodes” “DFP-1: nvidia-auto-select +1920+0, DFP-2: nvidia-auto-select +0+0”
SubSection “Display”
Depth 24
EndSubSection
EndSection

You may need to manually edit xorg.conf layout (Change RightOf to LeftOf depending on your setup)


Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0"
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

  • you’ll need another screen section in 50-screen.conf if you want a different X for each monitor (not sure if that’s what you’re trying to do)

@euromonkey,

Can yoiu please next time you post, make a clear difference between your story andd your copied/pasted computer text by using CODE tags around the latter? Use the # button in the tool bar.