nvidia resolution help

Hi, sorry to add to the nvidia posts, but I did not see anything related. So, here goes:

running opensuse kde 12.3
nvidia 650m graphics

I recently installed opensuse 12.3 on a new laptop. Apparently, the graphics card does not play well with the current kernel (3.7.10.blahblah), so I had to install it in no failsafe mode, and then install the nvidia driver. This works fine, except the kde settings don’t show any resolutions except 19201280. I can switch to pretty much any resolution I want if I go into the nvidia settings directly. However, every resolution except 19201280 has the word (scaled) next to it.

I would like to get the other resolutions available in the kde settings. (Some programs, games really, are not working due to this). I found some links:https://forums.opensuse.org/english/get-technical-help-here/hardware/442406-configuring-graphics-cards-opensuse-11-3-a.html, SDB:NVIDIA troubleshooting - openSUSE, https://en.opensuse.org/SDB:Configuring_graphics_cards.

But they did not help me, or at least not so I could understand. Per one of those links, I installed sax3, but am afraid to use it as I have not found documentation for it.

Did the nvidia stuff get installed incorrectly? What can I do to correct this? Any help is appreciated.

My suggestions is to upgrade the kernel to 3.10, if you have installed the nVIDIA driver the hard way and to use the nvidia-settings program for everything. Further, when you install the driver the hard way, you get a newer version of the settings program that can be used instead of the one loaded by YaST. For more help, look to here:

For newer kernels: openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

Installing the nVIDIA driver the hard way: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

Installing the driver using a bash script: LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3

Installing the driver using run level 3: How to Start openSUSE 12.2 with Grub 2 into Run Level 3 - Blogs - openSUSE Forums

Installing the nVIDIA driver using DKMS if you compile your own kernel: S.A.N.D.I. - SuSE Automated NVIDIA Driver Installer - Version 1.00 - Blogs - openSUSE Forums

And I can come up with a lots more if you need it.

Thank You,


I did the one-click install for nvidia, so I don’t believe I have the new version. As for the 3.10 kernel, I installed that, and it gave me a max resolution of 640*480. When I tried to run the nvidia settings program, it told me I was not running nvidia (no surprise) and that I should run a command (was it nvidia-config maybe?, sorry, don’t remember). On restart, this made it where I could not log in, so I obviously reverted back to the old kernel. (the nvidia-config thing apparently added a etc/x11/xorg.conf file. Via a live cd, I was able to delete this.)

I at some point was led to believe that it would be a good idea to “blacklist” neavou (spellng?) before all this other stuff. It did not seem to make a difference at the time, but now I am wondering if that was a mistake. Unfortunately, I do not know how to undo this.

From what I have read, the gt650m is not supported yet in the kernels, hence the problems. I also saw that you have suggested elsewhere the “bumblebee” project. Should I do this? It seems that it helps with power consumption, but I am not sure it would help in my problem.

The gt650m is optimus capable, however it’s up to the laptop maker to enable it or not, an easy check is to run the following command and post the output here:

/sbin/lspci | grep VGA

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 650M] (rev a1)

At least your laptop is not Optimus enabled, so forget about bumblebee.
Why use a one-click installer, go for the repo way, add the Nvidia repo and let it take care of everything, including blacklisting nouveau!

Yes, I have already done the one-click install. Using the nvidia driver was the only way I was able to install opensuse in the first place. I had to run the live cd in failsafe mode just to get it to run. So now, with nvidia running, I only have one resolution available: 1920*1080. This is true in the kde monitor settings as well as the nvidia settings. Am I misunderstanding you?

As a side note, I cannot get the 64bit version to boot at all. I assume it is related, but I don’t really know.

I strongly advice to not use any “one-click-installer”, there are many of them and there’s no way we can know what they really do.
Then this sentence “Using the nvidia driver was the only way I was able to install opensuse in the first place.”
This is simply impossible, you can only install the driver once you have an installed system.
About that resolution issue, obviously you can run nvidia-settings, what nvidia driver version does it report?
And besides, if your displays physical resolution is 1920*1080 then there’s no problem, never change that, if fonts and icons look to small use your desktops settings manager to adjust fonts and icons size to your liking.
About the 64-bit issue, no it’s not related, did you run an md5sum check on the iso.
If your system has 4 or +4 GB of memory you should definitly go for 64-bit anyway, and did you try using the kernelcommand “nomodeset” at install, when you select the install option booting the DVD you get a commandline at the bottom of the page, try “nomodeset” there, it might help.

Okay, thanks for the help. There is a lot of info here, so let me try and tackle them piece by piece.

  1. Using the live cd, I was able to boot via “safemode” kernel into a live environment. The live environment had a really bad, low resolution. Nevertheless, I was able to install the system from the live environment. The install reboots the system ONCE to finish the install. I found out the hard way that this is the ONLY opportunity I have to install the nvidia driver. If I restart before I install the nvidia stuff, I will never be able to boot again (at least not with my know how).

  2. Yep, nvidia-settings reports version number 319.32.

  3. The 64 bit OS live cds (I have tried with multiple different downloads, multiple distros too) gives a “kernel panic” error and then hangs when trying to boot. This is the same error I get if I try to boot normally from an x86 live cd. If I boot via kernel safemode, then it boots (albeit, awful resolution). Booting the 64 bit live OSes in safemode still gets the kernel panic. This is why I assume it is related. Perhaps not?

  4. I do not recall seeing a “nomodeset” option. I will try again and look for it. I notice that you refer to using the dvd vs the cd download. Is this something that you would recommend?

  5. I will take your advice and not use the one-click button next time.

Okay. I think I understand. There is a place that you can type into – never noticed it before. If this is what you are referring to, then no, it did not work.

Well, then I really don’t know, surely your system must be 64-bit compatible.
Anyway, your system seems to be working and the 319.32 driver is the latest from the Nvidia repo. what remains is that you can’t change resolution, is that a problem, I would guess that your displays native resolution is 1920x1080? Is that a problem, use your desktop settings to change fontsize and iconsize. Even my 134 year old eyes can handle 1920x1080 on my 23" desktop display.

Yes, it is 64bit compatible. Very frustrating. I will email the manufacturers and see if they can help me with that one.

As for the resolution, perhaps you are right. 19201080 is the native for the machine, and it is not too small for me. In fact I love it. I just feel like I have something built on a deck of cards here. I know that this is not the correct behavior. As I said earlier, when I tried the newer kernel (3.10.something) the results were worse, with a 640480 resolution. So, I would like someway to rectify the situation if need be. Perhaps there is not one? Or at least yet? I am assuming that support for this gpu will get better in the future kernels.

At any rate, I am not sure what to do besides reinstalling the OS and crossing my fingers. I am not keen on that (especially since I cannot install a 64bit system for some reason). As you said, I have a working machine.

I had to manually modify the /etc/X11/xorg.conf file to add additional resolutions to show up in KDE. You might look there

Run nvidia-settings as root may also do it. It will create/save a xorg.conf

Thanks for the suggestion. Actually, nvidia only shows the one resolution as well (WHen I started this post, it was showing something different. Not sure what changed). So, I don’t believe taht would accomplish anything. Perhaps that means that somehow the driver was installed incorrectly?

The suggestion to modify the xorg.conf file is actually what I had expected when I originally started the post. However, I don’t have a xorg.conf file. They apparently use multiple files in etc/X11/xorg.conf.d, with all sorts of warnings about using other files to do things. I tried creating an xorg.conf file anyway, and then added a modeline from the cvt output. This did not go well, and I was only able to recover the system by logging in with a usb stick and removing the file.

However, I am sure it can be done, I assume I just did something wrong and don’t know what I am doing. Any suggestions would be welcome.

I have since discovered that opensuse is not correctly reading my battery state, as seen by others https://forums.opensuse.org/english/get-technical-help-here/laptop/487698-battery-monitor-does-not-work-2.html . Not sure if this is a kernel issue or a yast issue as they seem to think in the other post. So, reluctantly, I am to the point that I don’t believe opensuse will work for this machine (which frustrates me because I really like opensuse). So, now I am back to distro hopping with the dread that I may have to go back to kubuntu (which seems to work fine). Oddly, I can get no 64 bit distro that is rpm based to boot on this machine. (the one exception has been pclinuxos, but that only booted to a text login. I assume if I figured out how to install the nvidia driver that way it would work, but I am not going to bang my head against a wall trying to do that.)

So, here is a question. I noticed that I have the following nvidia drivers installed:


Does my computer need all of these, or just one? I have the pae kernel installed, so perhaps I should just keep the nvidia pae version?

Thanks again.

I would remove these two unless you actually have those kernels loaded. Only kernel-desktop should be used by most users.


Thank You,

No, if you only use the pae kernel you also only need nvidia-gfxG03-kmp-pae and can uninstall the others.
You could also use the desktop kernel instead, this also has the pae extensions enabled but is better finetuned for desktop usage.
Then you would have to keep nvidia-gfxG03-kmp-desktop of course.

Which kernels have you actually installed right now?

rpm -qa | grep kernel

There probably is more than one, since the nvidia-gfxG03-kmp-* packages require the appropriate kernel as well. You should uninstall the other kernel packages as well then.

Regarding your resolution problem, you can create an xorg.conf yourself, even if you don’t already have one. It will be used if it exists.
You can use nvidia-settings to create one for you and then edit it if needed.

And have you deleted the files sax3 did create in /etc/X11/xorg.conf.d? (it creates three files beginning with “99-” but I don’t know right now how they are called exactly).
They might cause your problem… (I’m not quite sure if you did run sax3 or not, after reading all of this)

And another thing to note, since you mentioned you blacklisted nouveau: As you are using the nvidia rpm packages, you don’t have to blacklist the nouveau driver yourself.
The packages already do that for you.

Okay here is the output to the command:

shawn@linux-550l:~$ rpm -qa | grep kernel

So, I am attempting to remove the two nvidia kernels that jdmcdaniel3 suggested, as well as the corresponding linux kernels (in yast). This is the message that I get when I hit “Accept”:

In addition the the manual selections, the following packages have been changed to resolve depencies:

This doesn’t seem right… So, what should I do (lol, and thanks)

Then you must have some other packages installed that require those kernels (other kernel modules I suppose).
To find out which ones, run:

rpm -q --whatrequires kernel-pae
rpm -q --whatrequires kernel-default

Well, it said no packages for both of them. I guess I don’t really care about extra kernels. They don’t appear to be hurting anything. I just diidn’t realize that the system would invoke the particular nvidia driver depending on the kernel version is booted (uses nvidia pae for kernel pae). I was worried that it was trying to use multiple things at the same time, and thought that might be effecting the resolution stuff. Thank you BOTH for the help, I really appreciate it.

At this point, the battery issue is the bigger issue from the other thread ( https://forums.opensuse.org/english/get-technical-help-here/laptop/487698-battery-monitor-does-not-work-2.html ).