NVIDIA repository seems broken

Trying to refresh my repositories today I get the following error from the NVIDIA community repository:

Timeout exceeded when accessing 'https://download.nvidia.com/opensuse/leap/15.0/media.1/media'.
Abort, retry, ignore? [a/r/i] (r): 

Trying this in a web browser reveals that it’s a 504 Gateway Timeout error, which suggests something’s missing or mis-configured on the server. Neither the specific file (media) nor the directory (media.1) seem to be accessible. No problems a couple of days ago.

I couldn’t find a more appropriate place to report this - any suggestions?

Can you check the output from;

zypper lr -d

In the type is it rpm-md? If so change to yast2 with zypper mr -m <type>

Hi Malcolm - yes, it is rpm-md. However, it seems not to be possible to change that using zypper - the ‘-m’ option only selects repositories of that type, and doesn’t allow changing it. Even when adding a new repository, the documentation states that the -t option is ignored and that the type is automatically determined by examining the repository.

I tried deleting the repository and adding it back again manually in the hope that it would pick up a new format, but it just hangs in a similar fashion and the repository is not (re-)created properly. I would guess that zypper still thinks it’s a rpm-md repo from the available data it can see and tries to set it up that way. If it’s actually now a yast2 repo, maybe something is still missing from the repo files. (so now I don’t have the repository at all…)

I do think it’s a bit odd that the error manifests as a 504 Gateway Timeout, and not 404 page not found…

As an experiment, I tried adding that repo – note that I do not have nvidia hardware, so this was just for testing.

I used Yast Software Repositories. I clicked “Add” then checked the box for “Community repositories”. On the next screen, I checked the box for the Nvidia repo.

I got a timeout. On the choice “Retry, Abort, Skip”, I clicked “Retry”. I got another timeout.

So I clicked “abort”. Apparently “abort” has some strange meaning that I don’t know, because it went ahead and added the repo. And, in Yast Software Management, I was then able to see the packages in that repo.

Oh, and it set the repo type to “rpm-md”.

I have since disabled the repo, since I don’t actually need it.

Since this morning I’m getting the same Nvidia repo error, and now an error with the google-chrome-beta repo is popping up. I’ve been using these repos since 15.0 was released, so, I’m going to wait till tomorrow before making any changes. I’ve never had a problem with updates with Leap since installation, prudent just to wait a day.

Thanks to the OP for the post.

This trouble has been reported elsewhere:

The problem, whatever it was, seems to have been fixed now. :smile:
I’ve re-added and refreshed the repository successfully.