NVIDIA Proprietary Drive install lost resolution

I will do “the hard way”. But, can I just start from where my system is now or do I need to delete the current drivers or some other setup procedure?

thanks for help. I’ll see if this works after I hear response to proceed as is.

tom kosvic

I have download the nvidia 460 .run file to Downloads.

Instructions look clear except:

""Once the installation is complete, you might need to run:


How do you know you might need to run above? Do you always run mkinitrd


Never hurts to run mkinitrd This simply configures the boot image

I deleted old nvidia files (4) with zypper. as *.run install required they be removed. Then ran install of downloaded nvidia *.run from level 3 - nomodeset
It built a kernel then kept asking about signature. I had no idea what file to point it to. I tried “no signature” and it wouldn’t continue because of efi and secureboot enabled.

System is back as before in low resolution but working. No nvidia G05 files installed per yast software.

I need to reinstall through yast again, or else

find a signature file somewhere and use the downloaded *.run file.

Another alternative is to get back to the original install display files somehow. I had 1920x1080 running fine but thought nvidia drivers would give faster drawing for some graphing

Please advise best way to proceed.

tom kosvic

No, don’t use nomodeset! :wink: Boot opensuse, rather than opensuse-secureboot, (or just disable sercure boot in YaST2 Bootloader) at grub press e to edit and put a 3 at the end of the linuxefi line, or open a console, switch to root user and run;

systemctl set-default multi-user.target

Reboot the system, login as root user and re-install the driver;

./NVIDIA-Linux-x86_64-460.27.04.run -aq
systemctl set-default graphical.target
systemctl reboot

I used nomodeset because “hard way” instructions said to.

“Boot opensuse, rather than opensuse-secureboot”, I dont know what that means. Are these boot options in grub?

If you think I should get out of secureboot. Only way I know of is in bios. I am unaware of yast option to remove secureboot. I will look at that.

Other commands look clear, except, what is “-aq” at end of *.run.

sorry but I need specific step-by-steps.

I will ask later what the commands are about.

thanks, tom kosvic

The -aq is just to accept the license, be quiet and install the driver and tell me when you are finished :wink:

In YaST it’s on the first tab “Boot Code Options” uncheck the box “Enable Secure Boot Support”, reboot and enter your BIOS to turn off secure boot.

My system is now hosed. It wont enter grub. It says security violation or something like that.

I disabed secureboot in yast. I rebooted to level3 by modifying grub. I ran the *.run file with the -aq. It ,again, would not complete the install due to secureboot violations.

I rebooted and couldn’t get to grub.

Think, I’m in for a reinstall.

tom kosvic

Did you disable in the BIOS as well? If not go turn it back on again. In the system boot menu (eg F12) can you select and efi file to boot from?

Whenever I have an Nvidia install go other than as intended, I pull out my original install iso and, instead of install, click on “update.” When I’m asked, I make sure I keep all my repos activated. When reinstall that way, it seems to ferret out whatever needs correcting and corrects/installs whatever is needed. Then I reboot and it seems to work as intended.

A few days ago, while installing on an older laptop I have (while very tired and a bit irritated after I just had a power supply failure on my desktop), I inadvertently installed the wrong Nvidia driver. Bad news. Wouldn’t boot. But… Good old update figured out the right driver, got rid of several files, updated some others, and installed the correct driver. Reboot and I’m good to go.

Maybe I’ve just been lucky, but it has worked so far.

I did not disable secureboot in bios only in yast. That is still enabled. I checked.
I do not get into grub anymore.

A red box comes up in place of grub that says:

“Invalid Signature detected”.
“Check Secure boot policy in Setup”

I dont know if setup refers to bios. But I cant get to cant linux setup
There is only an ok button on the red box.
Pressing the OK starts windows. At least that works.

I have no idea on how to proceed. Disable Secureboot in bios to try to get past the red box???

Any ideas?

thanks, tom

Yes, you need to disable in the BIOS, as indicated :wink:

I’m not sure I can take the chance of killing windows by doing that. then i have a brick.

any idea if windows would croak? I will look that up.


Windows will still work with secure-boot disabled.

As an alternative, run the command (as root):

mokutil --disable-validation

This asks for a password, which you will need on the next boot. You won’t need that password again.

With that change, you can leave secure-boot enabled in the BIOS, but shim will stop checking signatures in openSUSE.


I have no grub, no terminal, in linux. Only the red box indicating Invalid Signature etc.
I have nothing to type the mokutil command into.

Do you know how to get past this red box window and to a terminal?


So as asked, on the system boot menu NOT grub, is there an option to boot from an efi file, for example on my HP laptops I can press F9 and get top the boot menu and select a disk or file to boot from, if so browse to the disk and find the opensuse folder and select the shim.efi file.

Again, disable in the BIOS secure boot, boot to openSUSE and re-enable secure boot, but windows will boot fine in non-secure mode.

I only have 5 boot choices in the bios, no efi file. The bios selects the boot order. It does not allow browsing to a disk to look for a file that I can find.

I do not know of any system boot options other than in the bios as you described that is on my computer. I have asus x99 mobo on a computer I assembled myself from pieces. I couldnt find such an option on their website. Press DEL or F2 key gets into bios. I know of no means to browse a disk for efi files.

Perhaps HP is unique in this.

As I see it now, unless I can get past the red “invalid signature” my system is locked as far as linux is concerned.

I did not yet disable secureboot in bios. I wanted to find path ahead before doing so. Do you think disabling secureboot will open more bios option, e.g., to find an efi file?

I could try booting into a portable linux on a dvd or usb to get to a file on my hard drive. I could probably delete, edit, or create a file this way. Would that get the job done?

thanks, tom

To get openSUSE to boot you need to disable secure boot in the BIOS. Boot to openSUSE, reboot and boot int Windows and see how it goes.

If you are convinced that disabling secureboot will get opensuse past “invalid signature” issue and not corrupt windows, I will give it a try. Can’t get to it til tomorrow morning. Approx 12 hrs from now.

I did look at windows and like opensuse there is a disable secureboot in windows OS. Should I disable that as well as the BIOS secureboot? Right now Yast has secureboot disabled.

I really dont wish to reinstall windows, opensuse, or both and I need to keep one of them running.

thanks again, tom kosvic

No, just disable in the BIOS and boot to openSUSE first.