NVIDIA Problem

I’m using an NVIDIA GeForce 9500m GS on an ASUS laptop.

Ok, I installed openSuse early last week and everything worked perfectly. However, I was unable to enable desktop effects even though my laptop is pretty new and the graphics card is supposed to be excellent. I did what I think now was a kinda dumb thing to do which was try to alter the settings in order for desktop effects to work.

I performed the NVIDIA driver installation from the opensuse web site and ran the command

#sudo nvidia-xconfig

Upon doing so, I restarted X and lo and behold, X fails to start. I apparently couldn’t load the NVIDIA kernal module. I booted the failsafe and it worked just fine and I followed some various topics on the subject but to no avail.

All I would like to do at this point is set my Xserver configuration back to its default.

Sorry 'bout bugging you guys about that, I just fixed it by adding

acpi=off noapic

to the boot options.

If memory servesme right then you should run sax2 -r -m 0=nvidia (as root and init 3) and not nvidia-xconfig. Though you can always combine some stuff from nvidia-xconfig and apply it to your settings. nvidia-xconfig is only there for distros that have no tool designed to configure the graphic card, suse got that so there is no need for nvidia-xconfg.

the way I install my GeForce7000m is just by going to nvidias website and downloading the bin file. I never use the ones provided by suse because most of the time its for another kernel version.

Its easy, just exit X and login into the console as root and run the bin file, it compiles a driver for your kernel version and writes to the appropriate config files. Its all automated, and it never fails. You just gotta have the kernel sources installed.