Nvidia optimus on Leap with bbswitch

Hello, Is there any working tutoria for optimus laptops for Leap? How to make this fully working with bbswitch?
With suse-prime, cards are changing but Nvidia is all time ON in background which make it overheating. With package suse-prime-bbswitch … its not working at all.
Same problem with Leap 15.1 and 15.2 Beta.
Nvidia MX150 + drivers 440


Hello, this is what you’re looking for (only for LEAP 15.1):

It works flawlessly on my Lenovo T480 with NVidia MX150 on LEAP 15.1

There is also an issue that bumblebee does not have an active maintainer for OpenSUSE right now (https://lists.opensuse.org/opensuse-factory/2020-04/msg00091.html), so it is unlikely to be developed for LEAP 15.2 unless the situation changes hopefully soon.

Thanks but Im not a fan of bumblebee. :frowning: Its old and buggy.

I would like to use “suse-prime-bbswitch” package but its not working at all. Official guide on suse its outdated and commands are not working. This sucks since for example similard thng to it works out of box in Ubuntu or is super easy to instal in Arch Linux but its rocket sience in openSUSE lol.

Have you worked through the steps here: https://github.com/openSUSE/SUSEPrime

There is a discussion on the development list about bumblebee but has morphed into suse-prime: https://lists.opensuse.org/opensuse-factory/2020-04/msg00091.html

In a lot of cases it’s lack of hardware by developers/maintainers so the more folks with the hardware to test etc is of long term benefit…

Yes, I got stuck with
test -s /etc/modprobe.d/09-nvidia-modprobe-pm-G05.conf ||
cp 09-nvidia-modprobe-pm-G05.conf /etc/modprobe.d
if ! -s /etc/dracut.conf.d/90-nvidia-dracut-G05.conf ]; then
cp 90-nvidia-dracut-G05.conf /etc/dracut.conf.d/ && dracut -f
test -s /etc/udev/rules.d/90-nvidia-udev-pm-G05.rules ||
cp 90-nvidia-udev-pm-G05.rules /etc/udev/rules.d/"

Errors that file dont exists etc.

Did you download the file(s) in question from the repo?


No. In this instruction there is nothing about downloading any extra files.
What should I do with them?

You should download them then go to the directory where you’ve downloaded them then run the commands:

test -s /etc/modprobe.d/09-nvidia-modprobe-pm-G05.conf || \
cp 09-nvidia-modprobe-pm-G05.conf /etc/modprobe.d
if  ! -s /etc/dracut.conf.d/90-nvidia-dracut-G05.conf ]; then
cp 90-nvidia-dracut-G05.conf /etc/dracut.conf.d/ && dracut -f
test -s /etc/udev/rules.d/90-nvidia-udev-pm-G05.rules || \
cp 90-nvidia-udev-pm-G05.rules /etc/udev/rules.d/"

as superuser (su or root).

In fact, you should really download all of the components from git using git clone, and go through the instructions from thed directory where git has been cloned to.

Just tested it on my old gaming laptop with geforce 760M. I downloaded all files and commands passed with no errors.
But sadly its not working. Video cards are changing while use prime-select but Nvidia is all time ON and make laptop overheating due it.
How to disable nvidia card while im usinig Intel?

Did you also go through the section NVIDIA power off support since 390.xxx driver (G04/G05 driver packages)in https://github.com/openSUSE/SUSEPrime

Yes, I have just uninstalled 440 drivers and put 390 and got stuck with:
if ! -s /etc/modprobe.d/09-nvidia-modprobe-bbswitch-G04.conf ]; then
cp 09-nvidia-modprobe-bbswitch-G04.conf /etc/modprobe.d && dracut -f

No such file or catalog.


Tried one more time and… its working! Woo :smiley:

Maybe later I will try it on my primary ultrabook.


I’m glad to hear that.

I will switch to prime-bbswitch myself… eventually. I’m just worried because some of my laptops have its USB 3.1 ported through Nvidia and VGA ported through Intel integrated and this is a known issue that hasn’t been really fixed (https://github.com/openSUSE/SUSEPrime/issues/47). For now, I am hanging onto bumblebee