Nvidia + opensuse 11.3 periodically freeze

Hi folks,

i have a strange Problem with my laptop, which has a nvidia geforce 9650M GT with current driver from repo, 256.53-16.1-i586

after booting, the display freezes every 10-20 seconds for some seconds, input while freezing works [most times?!] so i assume its a graphic driver problem.
also, the cpu load is much higher than normal (but not from any userspace process)
now the best: when i do a suspend-to-ram, and then wake it up, everything works as expected, low cpu load, no freezes…

problem is always reproducible and has first occured after my opensuse 11.3 upgrade and simultaneous nvidia driver upgrade

has anybody an idea what this can be? where to write a bug report?

ps. this thread
opensuse - Tracking down periodic system freezes?
is about the same issue, but i hate mailing lists, im even not able to get the mail adress of this mailing list>:)
yes i have googled, http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=opensuse-gernal+mailing+list



So I am not having any issues with hangs in openSUSE. I am using KDE 4.4.4 & I have upgraded my kernel to 2.6.35. I also have the same nVidia driver loaded, the hard way. I am using 64 bit and not 32 bit. I would ask did you add the nomodeset command to your kernel load options in your Grub menu.lst file located in the /boot/grub folder? You must be root to add this command and when you edit this file, you will notice that the failsafe kernel load lines also have nomodeset set there as well. Did you set the NO_KMS_IN_INITRD=Yes in the YaST /etc/sysconfig/system/kernel/NO_KMS_IN_INITRD section?

You may also want to check your multimedia setup here:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

You may want to look into doing a kernel upgrade here:

S.A.K.C - SuSE Automated Kernel Compiler

If you have upgraded your KDE version to 4.5.2, you may want to consider a reinstall to get back to KDE 4.4.4. If you use Gnome, my other suggestions can be used, but I am no expert on this desktop version.

Thank You,

i’ve already tried nomodeset, and NO_KMS_IN_INITRD=Yes is already set… im using kde 4.4.4, but had the same prob with former kde versions
any other ideas?, but i would like to avoid recompiling kernel

UPDATE: with nomodeset the cpus get a much less load and only with nomodeset the workaround with going into suspend-to-ram works

Did you already try to reinstall the driver? I bet you have. Sometimes an update of xorg-x11-server “spoils” the installed driver, i.e. a link to the driver is replaced by a real file from the xorg-x11-server package.
So, you say you have had the problem before, wih previous openSUSE versions as well? How did you upgrade from 11.2? Does the file /etc/X11/xorg.conf exist?

okay… i’m not sure what exactly happend, but after one complete re-install (with following nvidia-xconfig cmd), which did not improve anything, i removed some nvidia-related packages(texture tools, control library), then it works perfectly:), but its still working after i’ve installed them again… ( i have made a complete reboot between each install/uninstall process to ensure everything is reset completely)

so,…thanks for the help