Nvidia on openSuse 11.0

Anyone had success using the installation at the nvidia repo on opensuse 11?

After I install it i can get X to start, running sax2 again and looking at the log theres an error that the module couldny load.
Right now ive fallen back to nv.

Pickle236 wrote:

> Anyone had success using the installation at the nvidia repo on opensuse
> 11?
> After I install it i can get X to start, running sax2 again and looking
> at the log theres an error that the module couldny load.
> Right now ive fallen back to nv.
you really are better off compiling them from the Nvidia dl page
http://www.nvidia.com/Download/Find.aspx?lang=en-us, just follow the
instructions given and make sure you have the c compiler and kernel headers

Suse 11.0 x64, Kde 3.5.9, Gnome 2.20, Opera 9.x weekly

It worked for me, but I’m afraid the latest driver may be a little buggy, since I got a freeze this morning :frowning:

for me the the opensuse default nvidia driver is not working at all, there is a known bug in them that causes X start to fail on certain (and ofcourse mine) cards.

These are fixed in the new 172.14.09 driver which works perfectly for me. but manually installed.

I also had a lot of freezes but for me this was not due to nvidia but more regarding a bug of opensuse with REISERFS installs. reiserfs and beagle combined make opensuse11 freeze. workarounds are disabling beagle and changing the fstab reiserfs parameters to noatime,noacl (which makes it faster as well) and then no more freezes, at least for me.


Worked for me on an Acer Aspire 7720G with an NVIDIA 8400M GS. Even though those drivers are still crappy.

Any of You had luck detecting Your card after compiling the driver from Nvidia?? I can’t detect correctly my video card with sax2 no matter what i’ll do. I just want to see that i have my card (8800GT) and not some Vesa (3d acceleration works better than with Nvidia repository driver.

Yeah that may be my next try, its just nice to use the prebuilt ones when the kernel updates happen, all you need is the updated package to match the kernel update.

Did You run nvidia-xconfig ? (with su privileges of course)

No maybe I should give that a try. I only tried to rerun sax2, which came up with the error that the module couldnt be loaded.

Anyone gotten this to work on an 8800GT with full 3d effects (Compiz, etc).

Ubuntu won’t work for my card, I’m switching to the 1st distro that does ;).

I Have it working with 8800GT with no problems at all except invisible inactive window. I don’t know what fault it is but just after manual compiling of the newest driver i got everything fine except that sax2 can’t recognize exactly my card saying all the time VESA and not 8800GT but that’s it.

I have the same card with you and Compiz/everything works like a charm. Just install the nvidia package, go to runlevel 3, run SaX and let it do its magic :cool:. Then reboot or modprobe the nvidia module and when X comes up you should be able to enjoy Compiz.

Let me know if you need more help.

Which version??!! 5.10 ??!!
Ubuntu is the easiest distro i have ever encountered if it goes about compatibility!! Although in my opinion openSUSE is sort of “more professional”.

Yeah! Compiled manually and the driver is running great. AIGLX and all.
I just love the that little compiz drop down selection.
All I can say Ubuntu who?

Easy, now. The poster probably wasn’t aware of the unwritten all-purpose forum rule that says “thou aren’t allowed to post anything negative about Ubuntu without expecting retribution”. Don’t worry, they’ll learn.

We all realize Ubuntu is linux perfection, I’m not even sure why we waste our time on other distros. Surely we’ll all come around to our senses soon enough, just give us time.

On a side note, though, I’m curious. Since the nVidia 8800GT support requires the nVidia driver, which is irrespective of any particular distro version, how is it possible that Ubuntu manages to handle it better than openSUSE?

Or, could it be possible, and this is just a long shot, that the issue may not be related to a particular distro?

I was under the impression the poster was surprised that Ubuntu didn’t support it - not angry that someone questioned Ubuntu’s compatibility. He wasn’t pushing Ubuntu as the end all of linux either, he referred to Suse as “More Professional.” You’re right in stating it has nothing to do with distribution, it all lies with the driver, but I think it is a little to far to think the poster was angry for someone questioning Ubuntu.

It’s late, I may be reading everything incorrectly, but it isn’t exactly healthy to assume that every time Ubuntu is mentioned, it is done in a fashion that condescends on other distributions.

Anyway, regarding the topic at hand. I’m running an nVidia GeForce 8400GS, and the nvidia repository installed just fine and I had 3D after running nvidia-xconfig.

I was surprised not angry although i lose my temper when people for example install Linux (I don’t mean any particular distribution), don’t know what to do next and then say to everyone else this and that without using at least google to solve problems. Nowadays i must admit that every distro has something “special”, no, it isn’t Windows :smiley: And every day everythings is handled better and better. Why i think openSUSE is “more professional”, it looks like someone thought about it and build it with a plan ( i started with Ubuntu, no please don’t bash me :smiley: ), and I must say openSUSE is the way for me (must learn new things from beginning oh jesus), Ubuntu looks to me like someone took some packages, glued it together and voila!! We have Ubuntu. Of course i also have some positive experience with Ubuntu there is no denying of that. No matter, I’m openSUSE lover now :slight_smile: LINUX RULEZ!!! (or at least anything that is against Microsoft:D )


Or, could it be possible, and this is just a long shot, that the issue may not be related to a particular distro?

Well it is at least with the openSUSE driver ok :smiley: No one is perfect that’s ok. No, seriously, i have nothing against openSUSE except that it’s really professional product for free :smiley: Pray to the god for that, about the issue, hmm for long time with RC and Beta versions there were problems with compiling Nvidia driver, it is possible that it hasn’t been completely resolved and the driver has been made just “to be” so that no one complains that openSUSE has no support or it may be just me that I cannot pinpoint the issue with the driver. No matter, enjoy people :slight_smile:
P.S. On second thought it’s openSUSE’s problems :slight_smile:
P.S.2 I must admit that you have much more “control” over the system comparing to Ubuntu.

Yep, 8800 GT works with the nvidia-repository and this xconfig thing…

erde@sonne:~> su - 
sonne:~ # nvidia-xconfig --composite 
sonne:~ # nvidia-xconfig --render-accel 
sonne:~ # nvidia-xconfig --add-argb-glx-visuals -d 24

It’s not working for me. Interestingly, when I try to force sax2 to use it:
“sudo /usr/sbin/sax2 -r -m 0=nvidia”
… it fails. Reviewing dmesg, i see this mess:

nvidia: module license 'NVIDIA' taints kernel.
NVRM: The NVIDIA probe routine was not called for 1 device(s).
NVRM: This can occur when a driver such as rivafb, nvidiafb or
NVRM: rivatv was loaded and obtained ownership of the NVIDIA
NVRM: device(s).
NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
NVRM: support), then try loading the NVIDIA kernel module again.
NVRM: No NVIDIA graphics adapter probed!

I have no such framebuffer modules loaded (and /proc/config.gz shows they are modules).

Something is not right. This worked in 10.3…

Any ideas? I would rather not compile it myself as I don’t trust their installer/uninstaller. I’ve been bitten by it before.