NVIDIA- Leap 15.6

I had to fresh install on my laptop. Something ‘glitched’ during the upgrade dup process. Most menus not on the desktop were very small and hard to read.

When doing an update, I see NVIDIA in the list where repos show up, but there is no NVIDIA repo in YaST list.
Do I need to install the NVIDIA g05 to get it as my graphic drivers?

In the four installs I’ve done so far, Nvidia appears listed in the “Service” tab in Yast Softare Management. In all of them the Nvidia driver (G06) was installed without a problem. In all cases the driver was detected automatically.

i see nvidia service check, but the foloowing search does not indicate nvidia drivers installed.

localhost:~ # zypper se nvidia
Refreshing service ‘NVIDIA’.
Refreshing service ‘openSUSE’.
Loading repository data…
Reading installed packages…

S | Name | Summary | Type
–±--------------------------------------------±---------------------------------------------------±-------
i | kernel-firmware-nvidia | Kernel firmware files for Nvidia Tegra and graph-> | package
| kernel-firmware-nvidia-gsp-G06 | Kernel firmware file for open NVIDIA kernel modu-> | package
| kernel-firmware-nvidia-gspx-G06 | Kernel firmware file for open NVIDIA kernel modu-> | package
| libnvidia-container-devel | NVIDIA container runtime library (development fi-> | package
| libnvidia-container-static | NVIDIA container runtime library (static library) | package
| libnvidia-container-tools | NVIDIA container runtime library (command-line t-> | package
| libnvidia-container1 | NVIDIA container runtime library | package
| libnvidia-egl-wayland-devel | Development package for libnvidia-egl-wayland | package
| libnvidia-egl-wayland1 | The EGLStream-based Wayland external platform | package
| nvidia-compute-G06 | NVIDIA driver for computing with GPGPU | package
| nvidia-compute-G06-32bit | 32bit NVIDIA driver for computing with GPGPU | package
| nvidia-compute-utils-G06 | NVIDIA driver tools for computing with GPGPU | package
| nvidia-computeG05 | NVIDIA driver for computing with GPGPU | package
| nvidia-computeG05-32bit | 32bit NVIDIA driver for computing with GPGPU | package
| nvidia-container-runtime | NVIDIA Container Runtime | package
| nvidia-container-toolkit | NVIDIA Container Toolkit | package
| nvidia-driver-G06-kmp-default | NVIDIA graphics driver kernel module for GeForce-> | package
| nvidia-drivers-G06 | Meta package for full installations (X, GL, etc.) | package
| nvidia-drivers-minimal-G06 | Meta package for compute only installations | package
| nvidia-gfxG05-kmp-default | NVIDIA graphics driver kernel module for GeForce-> | package
| nvidia-gl-G06 | NVIDIA OpenGL libraries for OpenGL acceleration | package
| nvidia-gl-G06-32bit | 32bit NVIDIA OpenGL libraries for OpenGL acceler-> | package
| nvidia-glG05 | NVIDIA OpenGL libraries for OpenGL acceleration | package
| nvidia-glG05-32bit | 32bit NVIDIA OpenGL libraries for OpenGL acceler-> | package
| nvidia-open-driver-G06-signed-azure-devel | Devel Package to nvidia-open-driver-G06-signed | package
| nvidia-open-driver-G06-signed-default-devel | Devel Package to nvidia-open-driver-G06-signed | package
| nvidia-open-driver-G06-signed-kmp-azure | NVIDIA open kernel module driver for GeForce RTX-> | package
| nvidia-open-driver-G06-signed-kmp-default | NVIDIA open kernel module driver for GeForce RTX-> | package
| nvidia-texture-tools | NVIDIA Texture Tools | package
| nvidia-utils-G06 | NVIDIA driver tools | package
| nvidia-video-G06 | NVIDIA graphics driver for GeForce 700 series an-> | package
| nvidia-video-G06-32bit | 32bit NVIDIA graphics driver for GeForce 700 ser-> | package
i | openSUSE-repos-Leap-NVIDIA | openSUSE NVIDIA repository definitions | package
| pcp-pmda-nvidia-gpu | Performance Co-Pilot (PCP) metrics for the Nvidi-> | package
| x11-video-nvidiaG05 | NVIDIA graphics driver for GeForce 600 series an-> | package
| x11-video-nvidiaG05-32bit | 32bit NVIDIA graphics driver for GeForce 600 ser-> | package

SO maybe I need to add in the G05 drivers?

If you want to use the proprietary drivers you need to install them. If you don’t install them you can’t use them. As with every other package too…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.