Nvidia kernel module not found

Today I have updated the kernel and it no longer finds the nvidia kernel module
tried modprobe nvidia it says it doesn’t exists
please help


I also have a problem with nvidia.
We already discussed this topic in a closed topic prime-select can't switch to nvidia
It was temporarily solved.

I can’t express how annoying is to deal with these kind of problem after every update. There is no a fixed list of steps I could follow manually to make it work again, because the steps worked a month ago, doesn’t work at the next time.
It is a constant problem to use an external monitor.

I am not sticked to the nvidia driver, I would happily use the nouveau driver as well. I just want to use my laptop with an external monitor.

cat /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-6.9.3-1-default root=UUID=cb41fad0-7a8c-41fa-adc7-31cfe277c5ad nvidia_drm.modeset=1 splash=silent resume=/dev/disk/by-uuid/7
7a4e360-6ed6-416b-ae52-f65f1569e315 quiet security=apparmor nosimplefb=1 mitigations=auto

sudo /usr/sbin/prime-select log-view

[ 15:01:15 ] Boot: setting-up  card
[ 15:01:15 ] HotSwitch: completed!
[ 15:07:57 ] Boot: forcing booting with nvidia, boot preference ignored
[ 15:08:05 ] ERROR: cannot load nvidia modules [timed out]
[ 15:08:05 ] PCI BusID of NVIDIA card could not be detected!
[ 15:08:05 ] Configuration failed

lsmod | grep --ignore-case nvidia

lsmod | grep --ignore-case nouveau

zypper search --details --installed-only nvidia

i+ | nvidia-compute-G06             | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-compute-G06-32bit       | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-compute-utils-G06       | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-driver-G06-kmp-default  | 550.90.07_k6.9.3_1-23.1 | x86_64 | NVIDIA
i+ | nvidia-drivers-G06             | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-gl-G06                  | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-gl-G06-32bit            | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-utils-G06               | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-video-G06               | 550.90.07-23.1          | x86_64 | NVIDIA
i  | nvidia-video-G06-32bit         | 550.90.07-23.1          | x86_64 | NVIDIA

sudo hwinfo --gfxcard | grep Model

Model: "nVidia TU117M [GeForce GTX 1650 Ti Mobile]"
Model: "Intel CometLake-H GT2 [UHD Graphics]"

@balazsmanus Hi, perhaps some more detail, what desktop environment, Xorg or Wayland? What graphics card(s) and driver in use.

Using gnome 46 with xorg. Also RTX 3050 with G06 drivers

@balazsmanus can you show the output from inxi -GSaz

inxi -GSaz

  Kernel: 6.9.3-1-default arch: x86_64 bits: 64 compiler: gcc v: 13.3.0
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.9.3-1-default
    root=UUID=cb41fad0-7a8c-41fa-adc7-31cfe277c5ad nvidia_drm.modeset=1
    resume=/dev/disk/by-uuid/77a4e360-6ed6-416b-ae52-f65f1569e315 quiet
    security=apparmor nosimplefb=1 mitigations=auto
  Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
    wm: kwin_x11 tools: avail: i3lock,xscreensaver vt: 2 dm: SDDM
    Distro: openSUSE Tumbleweed 20240607
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:9bc4
    class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK
    driver: N/A alternate: nouveau non-free: 550.xx+ status: current (as of
    2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
    built: 2018-2022 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f95 class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:3 chip-ID: 13d3:56a2
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.12 with: Xwayland v: 24.1.0
    compositor: kwin_x11 driver: X: loaded: intel
    unloaded: fbdev,modesetting,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x8294 built: 2020
    res: 1920x1080 hz: 144 dpi: 128 gamma: 1.2 size: 380x220mm (14.96x8.66")
    diag: 438mm (17.3") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris x11: drv: iris
    inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.8 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
    device-ID: 8086:9bc4 memory: 30.45 GiB unified: yes
  API: Vulkan v: 1.3.283 layers: 6 device: 0 type: integrated-gpu name: Intel
    UHD Graphics (CML GT2) driver: N/A device-ID: 8086:9bc4 surfaces: N/A
Kernel: 6.9.3-1-default arch: x86_64 bits: 64 compiler: gcc v: 13.3.0 clocksource: tsc
avail: acpi_pm parameters: BOOT_IMAGE=/boot/vmlinuz-6.9.3-1-default root=UUID=bef30ac7-b146-46f2-9e36-23f19e050bda splash=silent quiet security=apparmor mitigations=auto
Console: tty 2 DM: 1: GDM v: 46.2 2: LightDM v: 1.32.0 Distro: openSUSE Tumbleweed 20240607
Device-1: NVIDIA GA106 [Geforce RTX 3050] vendor: ASUSTeK driver: N/A alternate: noveau
non-free: 55.xx+ status: current (as of 2024-04; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 bus-ID: 0000:01:00.0 chip-ID: 10de:2507 class-ID: 0300
Display: server: X.org v: with: Xwayland v: 24.1.0 driver: X: loaded: N/A
alternate: nvidia gpu: N/A in console modes: 1024x768
API: OpenGL Message: GL data unavaiable in console for root.
API: EGL Message: EGL data unavaiable in console, eglinfo missing.

can’t startx or start wayland

Got x working on a super low resolution and prime-select doesn’t find nvidia-drm module

× prime-select.service - SUSEPrime systemd service
     Loaded: loaded (/usr/lib/systemd/system/prime-select.service; enabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2024-06-08 16:10:49 CEST; 3min 1s ago
    Process: 1222 ExecStart=/usr/sbin/prime-select systemd_call (code=exited, status=1/FAILURE)
   Main PID: 1222 (code=exited, status=1/FAILURE)
        CPU: 7.850s

jún 08 16:10:41 chameleon prime-select[1401]: modprobe: FATAL: Module nvidia_drm not found in directory /usr/l>
jún 08 16:10:49 chameleon suse-prime[1983]: ERROR: cannot load nvidia modules [timed out]
jún 08 16:10:49 chameleon prime-select[1985]: ERROR: Unable to query GPU information
jún 08 16:10:49 chameleon suse-prime[1991]: PCI BusID of NVIDIA card could not be detected!
jún 08 16:10:49 chameleon prime-select[1222]: Configuration failed
jún 08 16:10:49 chameleon suse-prime[1995]: Configuration failed
jún 08 16:10:49 chameleon systemd[1]: prime-select.service: Main process exited, code=exited, status=1/FAILURE
jún 08 16:10:49 chameleon systemd[1]: prime-select.service: Failed with result 'exit-code'.
jún 08 16:10:49 chameleon systemd[1]: Failed to start SUSEPrime systemd service.
jún 08 16:10:49 chameleon systemd[1]: prime-select.service: Consumed 7.850s CPU time

@balazsmanus and there in lies the issue… suse-prime, it only works with Xorg, desktops are defaulting to wayland these days. It also doesn’t seem to play well with RTX cards.

Have a read of the following two threads about using switcheroo-control, now this is assuming you do have integrated Intel GPU (igpu) and the Nvidia card is a dGPU?

Ref 1. https://forums.opensuse.org/t/atomic-modeset-error-22-after-latest-nvidia-update-on-tumbleweed/175455

Ref 2. https://forums.opensuse.org/t/how-to-switch-to-the-nvidia-dgpu-in-tumbleweed/175576

I don’t have iGPU (Intel F cpu) only discrete.
Semms that reinstalling nvidia drivers with the .run installer fixed the issue.
Some GNOME apps don’t start because of some drm/dri, probably playing with options may fix this issue too.

@balazsmanus you could just force the reinstall of the kmp as this will force a rebuild of the kernel module for the running kernel. If it’s not added to the boot options addfbdev=1 nvidia_drm.modeset=1 via YaST Bootloader, it may also be worthwhile enabling the GSP firmware via the following file;


##Enable NVIDIA GSP Firmware
options nvidia NVreg_EnableGpuFirmware=1
Sat Jun  8 10:18:58 2024       
| NVIDIA-SMI 555.52.04              Driver Version: 555.52.04      CUDA Version: 12.5     |
| GPU  Name                 Persistence-M | Bus-Id          Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |           Memory-Usage | GPU-Util  Compute M. |
|                                         |                        |               MIG M. |
|   0  Quadro K620                    Off |   00000000:02:00.0 Off |                  N/A |
| 34%   36C    P8              1W /   30W |       9MiB /   2048MiB |      0%      Default |
|                                         |                        |                  N/A |
|   1  NVIDIA T400                    Off |   00000000:03:00.0  On |                  N/A |
| 38%   45C    P8             N/A /   31W |    1029MiB /   2048MiB |     13%      Default |
|                                         |                        |                  N/A |

nvidia-smi -q | grep "Firmware Version"

    GSP Firmware Version                  : N/A
    GSP Firmware Version                  : 555.52.04

The K620 is an older arch…

At least gnome opens propertly as it should. Games dead vulkan doesn’t find the gpu, haven’t tried opengl yet.
Hopefully they fix the update issue in suse

OP has only one GPU, while you have two. That makes your problem different from OP’s. Please use a new thread or ask mods to reopen yours.

1 Like

@Sweetchuck yes a new thread, else look at the links I provided here: https://forums.opensuse.org/t/nvidia-kernel-module-not-found/175600/9.

1 Like

Thank You, I will check those topics.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.