Nvidia + Kernel 6.3.1

I did a zypper dup today and it updated the kernel to 6.3.1 but my system would then not boot. Booted using the previous kernel.

I am using the nvidia driver from:

https://download.nvidia.com/opensuse/tumbleweed/x86_64/

Is it a case of waiting for the nvidia driver to be updated?

Thanks

Without a more detailed description of what happens I assume it is difficult for many to understand what goes wrong.

Sorry for not being clear.

Booting after the kernel has been updated to 6.3.1 stops at a konsole screen no x (using plasma kde 5.27.4)

A wise penguin could have done this on his own :wink:

I opened a bugreport:
https://bugzilla.opensuse.org/show_bug.cgi?id=1211115

1 Like

Yeaaahhh! Bug report! A general recipe for success…

https://bugzilla.opensuse.org/show_bug.cgi?id=1209197

:smiley:

Thanks for posting.

I have carried out a bit more research on this issue. I have done a zypper dup on another p/c that has a similiar setup - tumbleweed latest update and using the same nvidia repo (the only real difference being that it uses suse-prime). Same problem with no ‘x’.

Has anyone updated to the latest kernel (with tumbleweed snapshot 03052023) and uses the nvidia driver repo and can boot to the desktop normally?

One other factor which might be relevant is that I did not add any data to the MOK screen which comes up before the first boot when kernel changes, as I never have. Although I am familiar with this system from a P/C that runs KDE Neon.

Thanks again.

NVIDIA driver fails to compile every second kernel version. If you cannot handle it, you should not use NVIDIA with Tumbleweed.

Wait until driver is fixed and new package is published.

Plain wrong and simply FUD.

There was no sign that the TO couldn’t handle it, he was only the first one who asked in the forum regarding this topic. And as you can see at my bugreport, the TO is not the only one who is affected. So anything useful from your side regarding this topic?

Yes:
Nvidia RTX 3080 Ti with nvidia-video-G06-525.116.03-7.1 and kernel-default-6.3.1-1.1 boots just fine

No:
Nvidia GTX 550 Ti with nvidia-video-G04-390.157-23.1 and kernel-default-6.3.1-1.1 no X
Nvidia GTX 1060 with nvidia-video-G05-470.182-03-51.1 and kernel-default-6.3.1-1.1 no X

From NVIDIA G4 RPM changelog

buildfix against Kernel 6.2
buildfix against Kernel 6.0
fixes build against kernel 5.18
fixes build against kernel 5.14
...

I trust you can check it yourself.

Yes. And your bug report shows that NVIDIA driver fails to compile. So, what exactly is your point?

Besides answering the original question “Is it a case of waiting for the nvidia driver to be updated?”?

I just tried to remind that it is not exception and that anyone using Tumbleweed should be prepared to see it very often.

To add to the list: My Lenovo Ideapad 5 Pro laptop has Nvidia GTX 1650 as its discrete GPU (configured for offload use using suse-prime), and uses the integrated AMD GPU for the display. After upgrading to kernel 6.3.1-1 the Nvidia GPU can no longer be found (but I can of course still boot to X, because I use the AMD iGPU for that). This is using nvidia-video-G06-32bit-525.116.03-7.1.

This are fixes before the problem even shows up on most tumbleweed machines and before distribution of the package … So nice collection from your side.

Still wrong. It is rare that this happens. 3 machines with Nvidias here (G04, G05, G06) and the last problem was snapshot-12022022 with upgrade to kernel 5.16.8…over 1 year ago…

Thanks for the posts.

Interesting hui to see that your RTX 3080 Ti boots OK with the new kernel for you. My graphic card is not too dis-similiar to yours, a RTX 3060 Ti.

Arvidjaar thanks for the word of caution with tumbleweed. I must have been using it for 15 years now and you do get the odd issue - which is tha nature of the rolling basis. You become quite experienced in dealing with these issues, for example I have just altered grub to boot the previous kernel on a temporary basis…

Thanks very much.

I’m also a long time Tumbleweed user, and everything became much easier when snapper appeared and you could just boot to the previous snapshot and rollback. (Which is what I did this morning after noticing the Nvidia issue.)

From Stefan (maintainer):

Just fixed in the source packages. https://build.opensuse.org/package/show/X11:Drivers:Video/nvidia-gfxG05 https://build.opensuse.org/package/show/X11:Drivers:Video/nvidia-gfxG04 An update of the repository on nvidia’s server is planned for next week.
For now use older kernel or snapshot.

1 Like

Thanks for the update hui.

I have tried and it works.You can use wkazubski’s repository https://download.opensuse.org/repositories/home:/wkazubski:/G03/openSUSE_Tumbleweed/ or just use this rpm https://download.opensuse.org/repositories/home:/wkazubski:/G03/openSUSE_Tumbleweed/x86_64/nvidia-gfxG04-kmp-default-390.157_k6.3.1_1-44.2.x86_64.rpm

This issue seems to be a kernel lock-down problem.

As my p/c boots fine with ‘secure boot’ switched off, with kernel 6.3.1 (with the nvidia driver G06-525.116-53).

Did you import certificate used to sign NVIDIA modules after their installation?

Did you import certificate used to sign NVIDIA modules after their installation?

No I never have with Tumbleweed. Although I do register the MOK with my KDE Neon p/c.

It seems that kernel 6.3 (hopefully, accidentally) requires signed modules.