Nvidia issues after recent update

I am a bit of a noob to Linux, so excuse the noobie-ness. More of an informational post than anything (and my first forum post). After the recent kernel update I performed yesterday, my system booted directly into console. I am running opensuse 11.0 KDE 4.1 on an AMD Sempron +2800 processor with a gig of ram and an nvidia Geforce 6200 graphics card. Trying to run startx gave me an nvidia driver error.

I have seen a few other people have similar problems after an update so I thought I would relate what I did. Simply, I made sure I was running in level 3 buy running init 3. I then removed the nividia mod in case it was loaded by typing rmmod nvidia. I then ran sax2 -r 0=vesa to reset the sax2 module to run in low graphics. This allowed me to then run startx, get a gui up and uninstall the nividia drivers through YaST. reboot, and the system works, without effects of course since I am now running the standard graphics.

Just today I installed the nvidia beta drivers (version 177.70) from the console using the nvidia installer. My system is back to the way it was before the update.

Mostly, just wanted to relay the information in case others like me are pulling their hair out because of the latest updates.

And again, first post, thanks for listening. I am a total convert from Windows and hope to eventually be as adept at linux as I was on the other side.

This is quite normal, after a kernel update,you normally have to re-run the nvidia setup. I normally go to runlevel 3 ( which you did ) & run

sax2 -r -m 0=nvidia 

saves having to re-install the driver or run

sh NVIDIA-Linux-x86-1.0-7174-pkg1.run --kernel-name='KERNEL_NAME' 

replacing kernel-name with your kernel ( uname -r from a console )


And welcome to openSUSE and the forums :slight_smile:

This is normal after a kernel update any modules compiled with the
running kernel eg vbox, vmware, nvidia etc need to re-run their setups.

I use the proprietary one (pre-downloaded and in root users home
directory) and usually do the following after a kernel update;

vi /etc/inittab and set the run level to 3 in the following section;

The default runlevel is defined here


You could also just modify your xorg.conf file and change nvidia to
nv, but then you need to re edit.

Reboot the system then when it restarts, login and su - to root

sh NVIDIA-Linux-<rest of name> -q
init 5 && exit
(press ctrl+alt+F1 to get back to the console)
(press ctrl+alt+F7 to get back to your GUI)

No need to re run sax as it’s already using your current xorg.conf, if
all is well re-edit the /etc/inittab.

Some people even copy the existing /boot/grub/menu.lst before the
kernel update is run as well.

On my SLED system I have a spare boot partition and dd the current
boot directory over before a kernel update.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 23:59, 2 users, load average: 0.41, 0.30, 0.19
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Thanks guys! Not having gone through a kernel update yet I wasn’t aware I had to go through all that. I’ll definitely keep this page saved to make it easier to get through the next one.

I’m in the same boat, and am king noob and admit even the solution in this post has me lost. Could someone be kind enough to express the solution in a step-by-step manner? I would try it myself, but don’t want to risk breaking something as it just took me 18 hours straight of trying and retrying and retrying to install SUSE in the first place (yes, I checked the MD5 and I checked the install media, tried more than one download source and burned as slow as I could on a brand name disk, never mind it’s magic and as long as I don’t have to do that again I’m ok).
I’m not a stranger to a text interface, but brand new fresh to Linux, I’ve been all PC for 20 years. I just started checking out SUSE on an old PC(an old P-III with a Geforce card in it, hence the attempt at installing the Nvidia drivers).
I planned on doing all my learning of Linux through the very same machine, this plea for help is being pounded out on a backup system. I’ve tried searching around a bit on this specific problem and this looked like the closest thing to a solution I could follow.

Maybe I should elaborate…
I tried editing the /etc/inittab as described, then logged in, but sax2 was not recognised still unless I became a superuser. So I did and when I run sax2 I get an error and when I look in the SaX log I see the following:
FATAL: Module nvidia not found
So obviously I’m missing some steps.

So I will try to guess the exact details grosporina, please correct me if I get anything wrong.

You lost your desktop after a kernel update?

And you are stuck in text mode now?

And you installed your Nvidia drivers using the “one-click” method?

Assuming these questions are all true, here is one possible way. You’ll need an “always on” internet connection because you are going to use Yast to update your video drivers:

1.) boot up to the blinking cursor and log in as root.

2.) type the following command:


3.) Yast should start up, but you will not have a mouse, so move around with the tab key to go into Software Management, and then search for “nvidia”.

4.) two files should come up (X11 and G01). Select both files and tab over to “update”.

5.) Exit Yast and when you get back to the terminal type:


6.) when you start up, your desktop should be back. If not, log in as root and type:

sax2 -r -m 0=nvidia

7.) Save your settings and when you exit type:


This should work and won’t take very long to try, and there’s no chance of messing anything up.

If you just want your desktop back at any time, from text mode (while logged in as root) type:

sax2 -r -m 0=nv

Then type


Thanks so much foresthill, making the changes in yast did the trick. I have my desktop back and the Nvidia card is doing it’s thing. yast insisted on not installing the latest driver (173.blah) and keeping the previous version (96.blah), which is fine by me as it seems to work.
I’ll have to remember that I can use yast from the console, it seems a lot faster that way.
I think I’ll do some more reading before I try my next system configuration change.
Again, thanks. I’m in a bit of weird mindset after so many hours swearing at this thing but SUSE and KDE just got a stay of execution thanks to your help.(Probably saved the PC some physical abuse as well).

Ref NVIDIA - openSUSE - section “The Hard Way”

Yes, that’s where I had got the “one click” approach from and I hadn’t recognised anything there that would have helped me post-install, though I see now that it mentions yast from the console and also hidden in there is how to change my runlevel without editing /etc/inittab.
I assume that next time I use yast to install a calculator app or something similar I won’t have the same issues as they shouldn’t touch the kernel.


Glad to hear it worked for you!

The reason it installed the 96.xx driver is that there are two versions of the Nvidia proprietary driver. the latest one (173.xx) which works on Nvidia cards from around GeForce4 or 5 onward, and the “legacy driver” (96.xx) which is designed to work on older cards.

I seem to remember you saying you were running an older P-3 system, so I imagine the video card is of a similar vintage.

It’s great to be able to keep older hardware alive by installing Linux, I have a ton of computers laying around that I try to keep running. There’s no way any of those machines could ever run Vista with the the processors and amount of RAM they have, and plus there is no way I’d ever shell out $200 each just for an OS.

I don’t follow. All modules in the repo’s are sync’d with the kernel. It’s only those installed separately which require compiling to match the kernel - which is to say, aside from a few corner cases, only the ATI and nvidia proprietary graphics drivers.

My Linux ignorance shows itself again. Noted thanks.