Nvidia GTX 960 - problem with proprietary drivers

Hi, I have a desktop PC with Gigabyte GV-N960G1 GAMING-2GD graphics card and I have problems with the proprietary drivers installation. Can you help me please?

I started with a fresh installation of OpenSUSE 13.2.

Then I installed the nvidia proprietary drivers using the “easy way” described here: https://en.opensuse.org/SDB:NVIDIA_drivers.

After the reboot I get white/grey screen with a sad smiley and “Oh no! Something has gone wrong. A problem has occurred and the system can’t recover. Please log out and try again.”

I tried to reboot several times (it was mentioned in other threads on the forums) but it didn’t help.

I can switch to console and log in as root. lsmod shows that nvidia, nvidia_uvm and drm modules are loaded, nouveau is not. I wanted to check the log but there is nothing like /var/log/Xorg.0.log.

I also tried to reinstall the driver packages.

I have these relevant packages installed:

$ rpm -qa | grep nvidia

Any ideas? Feel free to ask me for any additional info you might need.

The log should be in /var/log/gdm/ I think. Can you please post it? It should show what’s wrong.

I have these relevant packages installed:

$ rpm -qa | grep nvidia

Looks ok.
And what kernel are you actually using?

uname -a

But the Xorg log would show this as well.

The /var/log/gdm directory is unfortunately empty.

Kernel version is 3.16.7-24

I will be happy to provide any further information but I’m not sure what is relevant. Please let me know.

Thank you.

Hm, can you please switch to xdm for one boot, then /var/log/Xorg.0.log should be created.
Edit /etc/sysconfig/displaymanager and set DISPLAYMANAGER=“xdm”.
You can set it back to “gdm” afterwards.

Kernel version is 3.16.7-24

Ok, but what flavor?
desktop? default?

With xdm the pc boots into a grey login screen. After logging in the “Oh no” screen appears again.

Xorg.0.log is the following: http://pastebin.com/RgMD1E25

‘uname -a’ shows linux-gbdc 3.16.7-24-desktop

Yes, that’s to be expected.
It’s how xdm looks like, maybe I should have mentioned this… :wink:

Xorg.0.log is the following: http://pastebin.com/RgMD1E25

Hm, that looks ok, actually.

I suppose you should file a bugreport upstream either at nvidia or GNOME then.

Does another X session work?
I.e. set DEFAULT_WM=“icewm” in /etc/sysconfig/windowmanager .

I suppose you don’t want to install KDE for a test… :wink:

I will try today.

I tried it and KDE with NVIDIA drivers from the NVIDIA repository works just fine. Except for the max resolution which stucks on 1024x768 which cannot be changed to any higher. Xorg log says “DFP-0 does not have an EDID, or its EDID does not contain a maximum image size; cannot compute DPI from DFP-0’s EDID” so I suppose this is simply wrongly recognized resolution.

Sometimes the X stack does not see the monitor to hand shake

run the nvidia setting program (should be in the menu now) it may resolve the problem or mod the xorg.conf.d files to reflect the resolutions you want and be sure that the KDE Configure desktop setting is right

The nvidia settings GUI utility didn’t offer the native resolution either. However after some playing with xorg.conf and xrandr I was able to use the native resolution in KDE.

I have tried to install the newest drivers from Nvidia website (352.55) using the “hard” way described here:

Before, I switched to IceWM (as opposed to Gnome) in the login screen (while still using the nouveau driver). Then I installed the Nvidia 352.55 drivers and after similar changes as with KDE I now can boot to IceWM with the native resolution. However I’m not able to start Gnome. In fact, I can’t even log out from IceWM. Once I managed to log out and got the “Oh no!” screen again. Now I’m not even able to log out (the log out option in IceWM menu only closes my applications and does nothing else).

Any ideas?

EDIT: I also tried drivers version 349.16 but the situation seems to be the same.
How do I switch to gnome again? /etc/sysconfig/windowmanager contains DEFAULT_WM=“gnome” and /etc/sysconfig/displaymanager contains DISPLAYMANAGER=“gdm” but I still boot into IceWM. Thanks.

I disabled autologin in /etc/sysconfig/displaymanager and now it boots to the “Oh no! Something has gone wrong.” screen. It seems to be a problem with GDM maybe.

Ok here is what happens with Gnome. Gnomes absolutely refuses to run without openGL support. NVIDIA drivers modify the mesa program in the X stack and if it fails to run then no other driver can run openGL thus Gnome fails to boot with the uninformative “oops” message. Most any other Desktop will still work though even without openGL.

Installing the NVIDIA driver the hard way and then installing from the repos without removing the hardway version can leave an odd problem with the mesa files in that the hardway saves the old mesa files then then the repo version save them again so removing the repo version brings back the hardways files. (note the are the same files just stacking up) So if you thrash around installing hard and repo it leaves a mess with the mesa files.

If you installed with the full DVD not one of the live ones then you could do a upgrade (yes 13.2 to 13.2), first removing any NVIDA stuff you installed. This should straighten things out. Then just get the driver from the repo. The latest driver is in the repo and it should work with your card.

Note if you run a Intel CPU it almost certainly has its own GPU turn this off in the BIOS just to not confuse things.

Now I was messing with various versions of the driver but originally I installed the repo version first and it didn’t work so the problem shouldn’t be caused by one version being replaced with another if that’s what you’re suggesting. My first attempt (and I tried that a few times) was to install the repo drivers on a clean installation of opensuse. Or do I miss something in your post?

I’m not sure what you mean by “the live ones” (AFAIK there is a DVD and a network one) but I use the DVD version to install.

Yes, I have Intel CPU and the integrated card is disabled in the BIOS.

We will need to see the logs then. The fact the gnome won’t run with the opps message indicates that the NVIDIA is installed but not running

I think maybe Gnome keeps its own logs ( I run KDE) but for everyone else it should be /var/log/xorg.0.log

there should be no problem with that card and the G04 driver (note that all packages must have GO4 init and the two for the kernel must match you kernel normally desktop. There are 5 packages making up the driver)