Nvidia Graphics Driver Resolution Issues

OS: OpenSuse 10.3
Graphics: 128MB Nvidia Quadro NVS 135M
Laptop: Dell D630

I am having some issues with the Nvidia Drivers for my dell laptop. I have already read many posts about the issues I am having and have followed most of the fixes.

First, I have followed the instructions using 1-Click on the NVIDIA - openSUSE website. After installing the new Nvidia driver I did noticed an increase in the quality of images on my screen, but still no change in my resolution. As some posts mention, I can not simply right click on the desktop and configure my graphics because of a RandR issue.

I have tried running krandrtray to change my resolution, but the value is maxed out at 1280 x 800. I know for a fact that my screen is a WXGA (1440 x 900) screen.

I then followed other instructions about running “sax2 -r”, but to no avail. Using the program I was able to change the monitor type to an LCD with 1440 x 900 at 60Hz, and correspondingly the resolution to 1440 x 900. Once I chose to test the output, it showed in the test window that the resolution was still 1280 x 800.

Finally I even tried to add a new mode to xorg.conf, but even after adding the new mode nothing changed.

After all of these tries, I am still stuck with a resolution of 1280 x 800 even though my laptop is definitely a max 1440 x 900 screen.

Any help would be greatly appreciated and thanks ahead of time.

In a console type su then root password then nvidia-settings in the control panel you can change the resolution

I am having a very similar problem with my Dell Latitude, but running the NVidia settings doesn’t provide anyway of changing the resolution? This is running the legacy drivers as instructed in other posts…

To the OP, I think the command “sax2 -r” only works with ATI drivers.

When you go to Nvidia Settings, does it say you are using the “nvidia” driver? If you are still using the generic “nv” driver try this.

Switch to superuser (enter “su” in terminal) and exit the xserver (enter “init 3”) log in as root and enter this command:

sax2 -r -m 0=nvidia

Assuming the Nvidia driver is properly installed, this should switch you over from the generic driver to the Nvidia one. When you exit Yast, enter “reboot” in the terminal. Good luck.

Geoffro - I tried the nvidia-settings option and the settings application ran, but I will still stuck with a native resolution of 1280 x 800. I know for a fact that this is not true. Given that native resolution, the nvidia settings program would not allow me to raise the resolution. I even tried to change the display type (LCD), but there was only one option that was there to select.

Foresthill - I am sorry for not mentioning it, but I did try the sax2 -r -m 0=nvidia. During my research into the problem, I found a few sites that mentioned that solution, but it still did not fix my problem. Primarily because some websites explain that the 0=nvidia option is not needed anymore.

Each time I attempt sax2 or nvidia-settings, I am always stuck with a max resolution of 1280 x 800. I am constantly running as root, so I shouldn’t have any permissions problems. I am also doing this on two laptops and have tried the 1-click method and the manual method for installing Nvidia. Regardless of the method, both installs are identical and all attempts on either laptop have been in vain. Thanks for the help and keep up the suggestions. I will try anything and hopefully will get somewhere on a solution.

Micky - are you having any other issues with your driver. Lets definitely use this post to get a solid answer for how to fix this problem since it seems like a persistent one for others.

Have you tried the beta driver from the nvidia site?

Either the 169.04 or 100.14.23 for the NVS mobile?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 19:43, 1 user, load average: 0.00, 0.13, 0.20
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12