Nvidia graphics card isn't working properly

I have an Asus A73S running 11.4 and with Nvidia Geforce 610m graphics card and a chipset i915 graphics card. Whenever I try to boot into the “regular” 11.4 option in grub the computer hangs during boot and just shows a black screen and the far right third has some vertical lines on it. I hit the escape key and watched what the kernel is doing when it boots and I saw that the problem occurs while its trying to load the drivers. The computer boots into failsafe mode ok, but its a lower resolution than normal. I started messing around with grub options and if I boot using the x11failsafe option I still see the same screen but it goes away after a few seconds and goes to a normal login screen. If I boot using x11failsafe and nomodeset I don’t see the error screen but when it boots the resolution is low. I installed the proprietary Nvidia driver, version 295.53 for 64-bit linux, but that doesn’t seem to help. I’ve also tried running nvidia-xconfig but that doesn’t help either.
Any help would be appreciated!

You noted when you boot using x11failsafe and nomodeset you obtain a low resolution. Do you need both at the same time when booting, or can you boot with just ‘nomodeset’ ?

Those two commands do different things, so it is useful if we understand if either succeed (getting a desktop) or if both are needed.

Now when you boot with ‘nomodeset’ with nvidia hardware, it will take you to either the ‘nv’ driver or the ‘fbdev’ driver. Using nomodeset disables kernel mode setting which is different than what happens with ‘x11failsafe’. But if you boot with only ‘x11failsafe’ it should only use the ‘fbdev’ driver.

Can you boot with ‘nomodeset’ and that after a successful boot to the desktop, open the /var/log/Xorg.0.log file with a text editor, copy its content, and paste it on the paste site SUSE Paste and press create and post here the web-address/url where that content is located (it will tell you where). That way our graphic guru’s (of which I am not one) can look at that log file and possibly figure out what is happening technically.

When I boot with:
x11failsafe - It boots into 11.4, but it still displays the error screen while booting so I can’t see the progress bar. And certain programs complain that the hardware doesn’t support GLX
nomodeset - It appears to boot fine, but when it goes to the login screen it brings up a shell the same as if I booted to run level 3
nomodeset and x11failsafe - It works the same as failsafe. It boots up just fine, but the resolution is low.

I posted the log file and its at SUSE Paste

The only real problem with the x11failsafe is that GLX doesn’t work. I can live without desktop effects and such.

That shows the FBDEV driver loading. That is a low performance driver.

What would be useful is to see the output of the ‘nomodeset’ boot code.

Please do this:

a. reboot using only ‘nomodeset’ boot code (and not the ‘x11failsafe’ ). In your case that will take you to the same shell as if you booted to run level 3. Login as a regular user, and restart with (root permissions) with ‘shutdown -r now’ command.

b. this time when rebooting, use only the ‘x11failsafe’ command. Once at the desktop, with a text editor open the file /var/log/Xorg.0.log.old. Copy and paste the content to SUSE Paste and press create and post here the web address/URL you are provided. That Xorg.0.log.old should be the log file with the ‘nomodeset’ boot code failing (ie the log from the previous failed boot).

Have you tried the proprietary nvidia graphic driver ?

Ok, the new log is at SUSE Paste

Actually I have the proprietary nvidia driver installed right now. Version 295.53. I was surprised when installing it didn’t fix the problem.

I believe this is an Optimus system, hybrid in other words. Post the output of ‘/sbin/lspci | grep VGA’.

That command outputs:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 105a (rev a1)

Yes that’s an Optimus, and this means that xorg is running on the Intel chip. Have a look in the BIOS setup if there’s an option to toggle the graphics mode, if there isn’t Bumblebee is your best option, there’s a HOWTO here:http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/469419-opensuse-12-1-optimus-laptop.html

There’s nothing in the BIOS. I’ll see if I can get Bumblebee to work.

Btw I noted this entry

  1. 22.359] (==) Using config file: "/etc/X11/xorg.conf"

in your last paste, remove that file and don’t use nomodeset for the Intel chip before starting with Bumblebee.

Installed bumblebee and I’m able to get my laptop to boot without any extra kernel options, but I can’t get optirun to work. Whenever I try to run a program using optirun it says it can’t start the x server.

I don’t use Bumblebee myself so I’m not of much help there, but did you add your user to the bumblebee group? You’ll have to logout and login for that to take effect?

Yes I added myself to the group.

In your first post you mentioned the 295.53 Nvidia driver, that’s the downloadable driver, the latest in the repo is 295.40. Note that those two methods install stuff in different locations, the Howto is written for the driver installed from the repo, which is the preferred way to avoid conflicts between xorg files and Nvidia files. Might this be helpful?

I added the nvidia repo and installed the driver, and with a bit of tinkering everything seems to be working now. Its odd that the downloadable driver installs differently than the one in the repo. I’ve only ever used the downloadable driver because I have a few computers that don’t have internet connections.
But anyways, I’m glad its finally working!