Nvidia GPU on New Install Not Functioning Properly

I have just installed Tumbleweed on a brand new computer. The GPU does not seem to be working and I’m wondering if I even got the correct drivers, and how to troubleshoot. Information follows:


Brand new Lenovo ThinkPad P1 Generation 4 P/N 20Y3004HUS
GPU: Nvidia GeForce RTX 3070 with Max-Q 8GB DDR6
CPU: Intel i7-11850H 11th Generation


OpenSUSE Tumbleweed, UEFI with secure boot enabled, AppArmor, SELinux enforcing

> lsmod | grep nvidia
nvidia_drm             69632  1nvidia_modeset       1204224  1 nvidia_drm
nvidia_uvm           2531328  0
nvidia              35373056  2 nvidia_uvm,nvidia_modeset
drm_kms_helper        319488  2 nvidia_drm,i915
drm                   634880  18 drm_kms_helper,nvidia,nvidia_drm,i915,ttm
> rpm -qa nvidia*

What I tried

I initially installed the Nvidia drivers using the script from their website. I disabled the nouveau driver by booting with nomodeset and adding a blacklist file for the kernel module. I then signed the module created by the nvidia installer and rebooted. X did not come up, I was stuck at a bash prompt, so I reinstalled.

My current install started with the nvidia-glG04 drivers but they didn’t seem to do anything. I don’t know which package I need. Currently nouveau is not loaded and I’m running the nvidia drivers successfully. However, I don’t know that they work.


First, when I use nvidia-smi, I get output showing the memory usage of the GPU (6Mib / 7982MiB), temperature, power usage (11W or 12W depending), utilization (always 0), and processes (always none listed). This doesn’t change regardless of what I run. The only game I have installed is Minecraft and running it until it lags with shaders doesn’t change this output one bit.

Second, running nvidia-settings as root just gives an error: “ERROR: Unable to load info from any available system.” I expected this to work.

Here’s dmesg output:

> sudo dmesg | grep nvidia
  124.747449] nvidia: loading out-of-tree module taints kernel.
  124.747471] nvidia: module license 'NVIDIA' taints kernel.
  124.759657] nvidia: module verification failed: signature and/or required key missing - tainting kernel
  124.779052] nvidia-nvlink: Nvlink Core is being initialized, major device number 235
  125.816869] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
  125.817183] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
  125.936360] nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.
  125.948555] nvidia-uvm: Loaded the UVM driver, major device number 511.
  126.011976] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  470.86  Tue Oct 26 21:46:51 UTC 2021
  126.016522] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
  128.012052] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1

The output of glxinfo is here: https://pastebin.com/PDaYg4d9

So, are my drivers installed and actually running? How come nothing runs on the GPU, especially Minecraft (1.17.1 running on OpenJDK 16 using MultiMC with Forge and OptiFine, loading RedHat shaders)?

Bonus problems include 3 hour battery life and crazy heat even at idle, which I expect to be related but which I can’t prove.

Thank you!

Intel IGP + NVidia GPU = Optimus = special/extra driver complications.

Are bumblebee or suse-prime installed? Do you know how to use them, or why?



/sbin/lspci -nnk | grep -EiA3 'display|3d|vga'

@mrmazda No, I did not know anything about them or that they existed. Heard of Optimus but didn’t think it applied to me. It does.

I played with the settings a bit and got my nvidia GPU selected and working. My keyboard is hot now and my battery won’t really charge but Minecraft is hauling at 400-500fps and around 60fps with shaders at full quality settings. I think this laptop is just bound to be a power hog.

I also seem to be affected by a bug going around that causes lightdm to display black. I can still enter my password to log in, so it’s fine. nvidia-settings also works now, too. Thank you very much!

PS: For people who look at this years from now, here’s the output of the command from Sauerland:

> /sbin/lspci -nnk | grep -EiA3 'display|3d|vga'
00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-H GT1 [UHD Graphics] [8086:9a60] (rev 01)
        Subsystem: Lenovo Device [17aa:22e4]
        Kernel driver in use: i915
        Kernel modules: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA104M [GeForce RTX 3070 Mobile / Max-Q] [10de:249d] (rev a1)
        Subsystem: Lenovo Device [17aa:22e4]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

Another helpful link:
Installing the drivers