NVIDIA GPU not supported - boot falls into TTY


About a month or more desktop system fails to boot into KDE, thankfully it still boots into TTY with normal resolution. I’ve been waiting for two-three updates to resolve the problem during vacation, but problem still exists by the time of 20230315.
I have this in journalctl:

Mar 17 17:12:35 dieselmachine kernel: NVRM: The NVIDIA GPU 0000:09:00.0 (PCI ID: 10de:13c0)
                                      NVRM: installed in this system is not supported by open
                                      NVRM: nvidia.ko because it does not include the required GPU
                                      NVRM: System Processor (GSP).
                                      NVRM: Please see the 'Open Linux Kernel Modules' and 'GSP
                                      NVRM: Firmware' sections in the driver README, available on
                                      NVRM: the Linux graphics driver download page at
                                      NVRM: www.nvidia.com.
Mar 17 17:12:35 dieselmachine kernel: nvidia: probe of 0000:09:00.0 failed with error -1
Mar 17 17:12:35 dieselmachine kernel: NVRM: The NVIDIA probe routine failed for 1 device(s).
Mar 17 17:12:35 dieselmachine kernel: NVRM: None of the NVIDIA devices were initialized.

With -nomodeset option system boots properly.
I assume this is the widely reported problem with 6.2 kernel and unsigned modules. I spent a lot of time reading topics about it, and tried to do the most recommended: disabled the Secure Boot option in UEFI. This gave my system no relief.
So, is there some summary or FAQ on this topic, which shows some quick-fix for this issue, until the problem will be solved? Or maybe next update with disabled SB will automatically resolve it?

Thanks for your attention.

You didn’t follow the ML and forum threads. It is not related to kernel 6.2
As the error message tells you, you have the wrong nvidia driver installed. You have nvidia-open-gfxG06-kmp-default installed which is incompatible with your card. Uninstall the open driver, taboo it, install the right proprietary nvidia driver, fixed.

This is a really old problem:Latest updates killed my GUI (4th week of Jan'23) - Kernel 6.8.1?

Thank you for your reply, but I’ve never used proprietary drivers, I’ve used nouveau since install. So would you please point me how to use open drivers?

Please read the linked thread. Also nouveau users where affected. You can use yast-software and check if nvidia-open-driver-G06-signed-kmp-default is installed on your system. If it is installed, uninstall it as this driver is not compatible with your card. Reboot after that. If your system boots fine, go to yast-software again and taboo nvidia-open-driver-G06-signed-kmp-default so that it wont get installed again.