nvidia GF8400GS HDMI resolution

Dear Forum,

I have a GAINWARD 9900 GF 8400GS 512MB DDR2 PCI-E video card on an openSUSE 11.0 x86-64, AMD Phenom 9550, 3G Ram environment. My LCD is a Samsung Syncmaster 2333HD. It would be driven via HDMI. I’ve downloaded and installed successfully the latest nvidia driver, NVIDIA_…195…run from nvidia. It sets the native 1920x1080@60Hz resolution but I have very large icons and large texts written on each other. So, the screen is almost unusable. I could not find any solution in the configuration program that was set up by the nvidia driver. If I use VGA port instead of HDMI to drive the LCD, everything looks and works fine. In fail safe boot it works fine from HDMI also.
I did take a try with the rpm type drivers from ftp://download.nvidia.com/opensuse/11.0/x86_64/ also, but they work the same.

Does anyone can help?

Sometimes the /etc/X11/xorg.conf can be the cause for strange fonts. What did you use to create the xorg.conf file for the proprietary graphic driver? Did you use Sax2 or did you sue the proprietary nvidia-xconfig program ? If you have only tried one, why not move your existing /etc/X11/xorg.conf to a backup and then run the other to create a brand new (not influenced by the other) xorg.conf? Note you must execute both of these programs from run level 3 and not in an X window terminal.

I do not use HDMI so I can not provide any specific help, … only such philosophical type questions.

Also pay attention to the arguments you use when running those programs so that you utilize the most optimal argument values.

Again, this is only general suggestion as I do not have HDMI and have no specific experience there.

I made a backup. The interesting thing is as I copy it back, it does not influence X. Is it possible that the driver decide itself how to set up X? init 3, cp…, init 5 and X starts thame way. I tried both sax2 and the driver itself. As I run the driver install package it asks whether I want to modify xorg.conf or not. I replied yes, I want. sax2 does not see nvidia at all. It sees only the Radeon 1200 on-board video but unable to set it up.The start of the story was that I could not set up ATI Radeon X1200 with the newest Catalyst driver to work in 1080p mode, so I bought the nvidia.

I don’t understand this post. What is “driver install package”? I’ve never heard of an application by that name.

Note sax2 is depreciated. It was reduced in scope in 11.2 (not included in YaST), it is further being reduced in scope in 11.3 (not included in liveCD). And you presumeably know that the sax2 version with openSUSE-11.0 likely does not handle perfectly the various HDMI available from different graphic cards. The effort to maintain sax2 was too much for Novell/SusE-GmbH which is one reason why it is being descoped. The newer (openSUSE-11.2 and even better in 11.3) Xorg automatically configure’s one graphics for most hardware (albeit this is still far from perfect).

Sorry for the inconvenience. NVIDIA-Linux-x86_64-195.36.24-pkg2.run installs a control application GUI. I meant that I can’t manage to set up the screen with it via HDMI.

Sorry that I can not help as I have no HDMI device easily accessible.