NVIDIA GeForce driver, hardware acceleration (direct rendering), LG W2442

Low performance of video on system with OpenSUSE 13.1 x86_64 with LG Electronics W2442PA.
Discovered this:

    38.436] (**) NVIDIA(0): Enabling 2D acceleration
    39.035] (II) NVIDIA(0): Display (LG Electronics W2442 (DFP-0)) does not support NVIDIA

xorg.conf:


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.79  (buildmeister@swio-display-x86-rhel47-09)  Sun May 18 00:42:05 PDT 2014

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.79  (buildmeister@swio-display-x86-rhel47-09)  Sun May 18 00:41:48 PDT 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/mouse"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "IMPS/2"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "yes"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2442"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTS 450"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1920x1080_60 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Xorg.0.log

Some screens of nvidia-settings:
https://img.bi/#/6jNWFvK!xINXmGI935F2Cw5sVdS3j565QMdOKHVeW2WwtEeH
https://img.bi/#/AXWsOoK!I4wN7vJ0vpD6o6ijyfBB3zNgLwMNk60Anpg8JENT
https://img.bi/#/YPwDUhP!dqwLcRRD9JPh99BCKJuZu1MMwMY6X1907dhVpxgm

Is there any way to beat the problem?

Not a problem at all.
The actual message is:

    39.035] (II) NVIDIA(0): Display (LG Electronics W2442 (DFP-0)) does not support NVIDIA
    39.035] (II) NVIDIA(0):     3D Vision stereo.


which means that this is no 3D display, i.e. one where you could have “real” 3D with 3D-glasses.

xorg.conf:

You should not need an xorg.conf at all, so just try to remove it.

Xorg.0.log

I see no problem in there. The driver is loaded and appears to be working.

Is there any way to beat the problem?

Could you please describe your actual problem in more details?
What exactly do you mean with “low performance”?

And which Desktop Environment are you using?
If it’s KDE, have a look into “Configure Desktop”->Desktop Effects.
In “Advanced”: Composite type should be set to “OpenGL” (2.0 or 3.1), Qt graphics system should be set to “Raster”.

First of all thank you very much for the quick answer.

When I talk about low performance I mean slow image rendering when scrolling web pages in Firefox or noticeable defects during watching video.

I deleted the xorg.conf. Nothing changed. OpenGL was set to 3.1 from 2.0. Qt were and is raster.
Video is getting much better. Page scrolling remains bad (riffled).

Lost images if they help:
screen1
screen2
screen3

The pain for me is slow image rendering.

Hm.
You might try different settings for “Tearing Prevention”.

Is it better when you disable desktop effects completely? (press Shift+Alt+F12 for temporarily disabling them)

Install the package “Mesa-demo-x” and post the output of this to see whether direct rendering is working for your user:

glxinfo | grep render

No. I can’t reach any images via those links.