NVidia GeForce 9400M not working after upgrade to Leap 15.2


I’ve been running OpenSUSE Leap on my old MacBook Pro since 15.0. Here’s the video card.

# lspci | grep -i vga
02:00.0 VGA compatible controller: NVIDIA Corporation C79 [GeForce 9400M] (rev b1)

Under Leap 15.1 this card worked perfectly with the x11-video-nvidiaG03 driver from the NVidia repositories.

After upgrading to 15.2, I was surprised to notice that this driver wasn’t available anymore. There were only the G04 and the G05 versions available.

So I looked on the NVidia site, downloaded the appropriate NVIDIA-Linux-x86_64-340.108.run, blacklisted the nouveau driver, installed the necessary build dependencies and ran it.

The driver built fine, but after a reboot, running systemctl isolate graphical.target results in a freeze.

Which leaves me clueless.

Any suggestions ?


This driver is obsolete and will not developed any more. It als does not build with Kernel 5.3 from Leap 15.2.
So delete them and use nouveau.

The 340 driver does also not build in Leap 15.2 without patching and is also obsolete and will not developed any more.

Thanks for the heads-up.

Is there some short documentation about reverting to the free nouveau driver ? Which packages to install and what to configure ? I’ve written a detailed blog article about migrating from nouveau to nvidia, but before haphazardly trying to do things, I prefer to ask.

I have done nothing else as to install the Nvidia driver (here just the run file).

So if you want back to nouveau:
You have to deinstall the driver, look if ther is any nomodeset in the grub-commandline and delete, look if ther is no blacklist file in /etc/modprobe.d, which blacklists the nouveau.
Here I have an file:

grep -i 'blacklist nouveau' /etc/modprobe.d/*
/etc/modprobe.d/nvidia-installer-disable-nouveau.conf:blacklist nouveau

That must also deleted when you want the nouveau back.

And hopfully nothing of nouveau deleted when you have installed the nvidia driver…

I just tried the nouveau driver but unfortunately half of my preferred desktop effects won’t work.

Just out of curiosity, how would I go about using the NVidia driver with patching? I couldn’t find any instructions online.


Experimented some more with this setup. Turns out I had to install the Mesa-dri-nouveau package.

Everything works perfectly now with the free nouveau driver, including advanced desktop effects.

Cheers from the sunny South of France.

I recommend visiting https://forums.opensuse.org/showthread.php/541438-AMD-Intel-amp-NVidia-X-graphics-driver-primer before considering it complete. It’s not a simple proprietary vs. nouveau choice with NVidia GPUs - there’s a third choice for X driver.