NVIDIA GeForce 7100GS boots to console

Hey all, I’m pretty new to openSUSE and Linux in general and I can’t figure out for the life of me how to install the drivers for my new NVIDIA GeForce 7100GS 128MB video card and get openSUSE 11 to boot past the console.


I built a new HTPC rig two weeks ago and decided to make the foray into Linux. Besides putting Ubuntu on some old PCs for web browsing (which doesn’t really count as ‘experience with Linux’), I’m brand new. The openSUSE 11 desktop (Xorg, I believe) ran very slow on the cheapo onboard graphics I was using - the screen would bug out and have strange ‘rips’ and ‘tears’ - hence the 7100GS. On the cheapo onboard graphics I could atleast get to the desktop versus my current console predicament.

Try this to get you a display and login GUI

If graphics driver gets messed up, type 3 in the grub boot line to get runlevel 3 - login as root

sax2 -r -m 0=vesa

this should enable a display using vesa

Now you need the Nvidia repo adding, one click is probably easiest:

If you can’t get a GUI with vesa let us know

I receive the following error:

-bash: sax2: command not found

I googled “sax2” and from what I gathered there I suppose that I should take out my video card and install sax using yum, right?


Try what I said

sax should already be installed. no need to reinstall it.have a look at my how-to ( personal reminder really. Might help you Stuntmanandys openSUSE/SuSE forum • View topic - Installing Nvidia drivers off-line


have you tried choosing the failsafe option in the boot menu? that should automatically use vesa for the graphics. From there you should be able to open up yast and install the official nvidia drivers from the repository. Easier than messing with sax2.

Alrighty then.

I tried entering the follow command at the console:

sax2 -r -m 0=vesa

What returned was this:

bash: sax2: -command not found

Then I tried booting in failsafe mode. This did not initialize vesa graphics, however, and booted me into the console just as before.

I removed my video card and searched yast for “nvidia.” This led me to the nouveua nVIDIA drivers, which I installed. I put my video card back in and openSUSE still boots to console.

What should I try next?

Make sure you log in as root before running sax.