Nvidia Geforce 6600 strange problem with graphics openSUSE 12.3

Hi, I have a problem with NVIDIA drivers (downloaded from ftp://download.nvidia.com/opensuse/12.3/), the effect is as follows:

In the games - no buildings or surrounding objects. I can only see the ground at which I move, very low fps between of 20 to 30 (on suse 12.2 had a permanent 120) games that I tested Word of Padman, Open Arena, Sauerbraten.

I have a similar problem with google earth

I checked both 32 and 64 bit opensuse 12.3 for both versions is the same problem, drivers installation proceeds normally without problems.

system - openSUSE 12.3 64bit (fresh installation)

my graphics - GeForce 6600

installed drivers - 304.64_k3.7.9_1.1-26.3 nvidia-gfxG02-kmp-desktop - (NVIDIA graphics driver kernel module for GeForce 6xxx and newer GPUs)


I noticed that “Direct rendering” seems to be off, how to turn it on?


A wild speculative idea … (with the emphasis on ‘speculative’ ) … I noted in another thread a user (with different nvidia hardware) added their user to the ‘video’ group, and after a reboot had openGL acceleration working.

Now on my PC my user by default is in group ‘video’ … and I have no idea why this would not be the nominal case.

So you could check that. As I note - this is a wild speculative idea that your user may not be part of that group.

Adding users to different group can be done in YaST > Security and Users > User and Group Mangement > Users > Edit [note it is likely your user is already in group video].

I have NO more ideas other than that.

Adding myself to the video group worked for me. I’ve never had to do this before and was puzzled by it.

A later entry, by user promeneur, to the post you are thinking of adds this:

it is not normal to put a user in “video” group.

today with edev you belong or not to a group dynamically just during the time you must. it’s a kind of security feature.

to belong statically to “video” group is a workaround.

i assume there is a bug around udev and user rights

i am going to fill a bug report

I noted that when I was in the users and groups management module there were no ticks in any of the boxes and am in complete agreement that this is not a fix - just a temp workaround.
But we do get our nvidia cards to work.


I had the same Problem, i was suspecting also inssuficient rights cause when i tried to run the Valley Benchmark it showed me an permission issue…I didn’t added my user to the video group…it just didn’t come to mind that this could solve the problem.
After I did it the Problem is fixed.

Thank you!

It works, thank you very much for your help!