Nvidia Geforce 6600 driver not installing in openSUSE 12.3

Hi, I have been trying to install the Nvidia drivers on openSUSE 12.3 I have tried the (one click) method and the (repository way) etc. Reboot-

Then the system freezes (ctrl-alt-f1 gets me to prompt) I login and I end up not being able to start Gnome 3.4… with startx. I enter Command (zypper se nvidia) to notice that 3… compute…x11.desktop…G02 drivers are installed.

Geforce 6600
Autodetected http://en.opensuse.org/images/thumb/4/4f/Icon-checked.png/22px-Icon-checked.png](http://en.opensuse.org/File:Icon-checked.png) - 3D Support http://en.opensuse.org/images/thumb/4/4f/Icon-checked.png/22px-Icon-checked.png](http://en.opensuse.org/File:Icon-checked.png)
XGL not dectect, use force enable
SUSE Linux Release(s): 10.0, 10.1, 10.2, 10.3

Do I need to somehow enable XGL? How can I do this?

Do I need to try to install the Nvidia drivers (the hard way) ?

There is a thread here on the 3.7 kernel (which is in 12.3) and the proprietary driver: https://forums.opensuse.org/english/get-technical-help-here/tumbleweed/481744-nvidia-kernel-3-7-problem.html I also blogged about a patch needed for different nvidia hardware here: https://forums.opensuse.org/blogs/oldcpu/nvidia-173-14-36-graphic-driver-nvidia-nv34-fx5200-graphics-device-3-7-x-newer-kernels-125/ and a comment to that blog entry might be relevant.

I don’t know if the patch is inside the 1-click rpm install method that you are trying.

Did you try this repo for nvidia?
Index of /repositories/home:/Lord_LT:/drivers/openSUSE_12.3

Thank you for your prompt response the blog and the link to the repos. My question is should I be looking at (G02) I found 5 desktop .rpm packages in the repo link caf4926 sent. Stick with trying the desktop and (G02) ones correct since the card is a (Geforce 6600) ? I know the card is old I appreciate all your help.

If you have the default nvidia repo and driver installed, remove the driver (that can be fun)
Reboot and you should be on nouveau
add the repo I gave you and open software management

It should auto add the correct driver
then just accept

This is going pretty good I am working with the blog that oldcpu created plus I am learning something.

This worked for me (Compaq F700 with GeForce 7000M / nForce 610M). Thank you!

Bjmsam did you use the G02 driver type setup from the Lord_LT repos? I just added the Lord_LT repos selected the G02 nvidia option. installed rebooted then got a prompt.

Zypper se nvidia shows the 3 installed.

You can try the latest from the nvidia site
NVIDIA DRIVERS 304.84Certified

From the link it support your card and this was release on March 4, 2013

GeForce 6 series:
6800 XT, 6800 XE, 6800 Ultra, 6800 Series GPU, 6800 LE, 6800 GT, 6800 GS/XT, 6800 GS, 6800, 6700 XL, 6610 XL, 6600 VE, 6600 LE, 6600 GT, 6600, 6500, 6250, 6200 TurboCache, 6200SE TurboCache, 6200 LE, 6200 A-LE, 6200, 6150SE nForce 430, 6150LE / Quadro NVS 210S, 6150 LE, 6150, 6100 nForce 420, 6100 nForce 405, 6100 nForce 400, 6100

Paul, how did you arrive at 12.3, was it a new install or upgrade (from?)
Have you tried completely removing any nvidia drivers? And then doing as I suggest earlier?

rpm -qa | grep nvidia

so we can see what you have

Hi, I arrived at 12.3 through a fresh install.

command:

rpm -qa | grep nvidia

yields the following.

nvidia-gfxG02-kmp-default-304.64_k3.7.10_1.1-13.2.i586
nvidia-computeG02-304.64-14.1.i586
x11-video-nvidiaG02-304.64-14.1.i586

Thank You,

And just to be sure also

uname -a

And just to be sure also

Command:

uname-a

yields:

Linux linux-nokn.site 3.7.10-1.1-default #1 SMP Thu Feb 28 15:06:29 UTC 2013 (82d3f21) i686 i686 i386 GNU/Linux

Are you using the nvidia repo, not the LT repo I listed earlier?

I am using the LT repo you listed earlier.

I have tried the Nvidia repos by creating a custom.run nvidia driver that also failed.

So a few more questions.

You can login, but only by going to console login and startx?
Then gnome works ok?
Have you tested a new user login?
Have you tried login with IceWM?
Have you tried switching from kernel-default to kernel-desktop? (this can be fiddly)

When I start my pc now I get a prompt login.

When I login via prompt and enter command (startx) it fails,gives errors (xinit failed) and reverts back to prompt.

I can’t login with IceWM cause startx won’t run?

I have tried switching from kernal default to kernal desktop no change at all.

When you first installed. Did it boot to a desktop? (you are using gnome right?)
If it did. What happens now if you remove nvidia drivers completely?
Would you consider a new install?

Yes, initially with the fresh install the pc boots right into Gnome 3 desktop after I login.

Uninstalling the Nvidia drivers right now…

With the command (zypper se nvidia) all are uninstalled

upon rebooting…

Automatically pull up Grub2 automatically and then Login screen comes up but it’s frozen (mouse works).

I would be willing to do another new fresh install yes.

If you have a xorg.conf
rename it and reboot