nvidia geforce 6500 le problem

Hi. after installation of milestone 4 , at reboot yast is unable to configure a geforce 6500 le with samsung display.all I get is a black screen and I’m not even able to switch to console
I tried to boot with init=5 or init=3 option but everytime suse tries to stat gdm and I get the same problem. Any idea how to get over it?

Tried ctrl-alt-F1 at login screen to get to command line?
What driver you’re using nvidia or nv? Do you have 64 bit install or i586?
If you can get to command line, login as root and type

joe /etc/X11/xorg.conf

Carefully edit the file to use nv driver if nvidia driver ain’t working for you.
Or the other way around.
You can save the file with Ctrl-K X

The other way is using sax to configure your display.

sax2 -r -m 0=nvidia
sax2 -r -m 0=nv

By the way, you can always download the latest drivers for your card here
If you’re using 64bit system, download this and if you’re using i586 download this driver.

Save it to your desktop, logout, crtl-alt-F1, login as root and :

init 3
cd /home/user/Desktop
sh NVIDIA-Linux-x86_64-185.18.31-pkg2.run --x-module-path=/usr/lib64/xorg/modules/ -q
sax2 -r -m 0=nvidia

Or… if you’re on i586 :

init 3
cd /home/user/Desktop
sh NVIDIA-Linux-x86-185.18.31-pkg2.run --x-module-path=/usr/lib/xorg/modules/ -q
sax2 -r -m 0=nvidia

unfortunately I cannot get to command line cause everything goes black. I tried to do a init 5 not to start xorg but maybe opensuse has different commands because xorg starts just the same.

I have the same problem, but with ati radeon 9200. After boot the screen goes black. And I can’t switch by ctrl+alt+f1 to console.

Of course it goes black because it’s starting in runlevel 5 (or what is the default). At the boot screen add the option:

runlevel 3

then you’ll get the command line login. Do a root login and reconfigure with

sax2 -r -m 0=nvidia

Good luck.