NVidia GeForce 6100 on OpenSuse 10.3

Edit: I don’t know this got posted as a new thread; I meant it to be a reply in this thread:

nvidiaG02 drivers from repositry - openSUSE Forums

Here’s how I got the NVidia driver to work on OpenSuse 10.3. I want to try this procedure on 11.1 tomorrow and I’ll post my results again. Previous to this, I’ve been stuck with 10.2 because I couldn’t get the NVidia drivers to work under 10.3, 11.0 or 11.1 (again, as discussed in the above thread).

I had installed the driver under 10.2 by adding the Nvidia repository and letting Yast do it. That seemed to work fine. It did NOT work for 10.3. The One Click Installs on the NVidia page didn’t work, either. Following Malcolm’s excellent instructions above, I got “0x0242,” which is the GeForce 6100. Nvidia says that driver 177.82 is the correct choice, and they are WRONG. That driver WILL NOT work.

I found the older driver that had been working with 10.2 (Build #173.14.12) and downloaded it. BEFORE I built the new driver, I carefully ensured, with Sax2, that I had a working (if ugly) 800x600 desktop. (One problem that I’ve had in the past is that Sax will set parameters that are out of range for my monitor.)

Then I built the driver. I rebooted and got into my ugly 800x600 desktop. I DID NOT use Sax2 to configure the NVidia card (that will NOT work). Instead, I started a konsole under KDE, su’d to become root and executed “nvidia-settings.” That’s the trick.

In sum: First, I think NVidia has the wrong driver recommended for some of their cards. That info has been propagated into the Suse RPMs and other material. Second, at least for my NVidia cards, I can’t use Sax2 to configure. I use “nvidia-settings” to get what I really want.

Still no joy on 11.1. I had to stop fooling with it to do some work, but we’re stuck on 10.3 for now.