nVidia GeForce 5200 FX not working (no driver errors seen) .....

Hi All,

I have installed opensuse 12.1 from scratch and configured (as good as I know) the G01 drivers (GeForce FX 5200). But every time I boot the system under Gnome, even the user selection is a big black field and when i manage to log in by just pressing enter and enter the password it is just a screen (the green gecko) and nothing else. I tried it with KDE(4) and there I get the login panel in readable form but a blank (black screen) when logged in …

Below I have the output from the Xorg…log and I cannot see any error or a missing configuration (I’m not THE expert here).

X.Org X Server 1.10.4
Release Date: 2011-08-19
25.962] X Protocol Version 11, Revision 0
25.962] Build Operating System: openSUSE SUSE LINUX
25.962] Current Operating System: Linux linux-ai96 3.1.0-1.2-default #1 SMP Thu Nov 3 14:45:45 UTC 2011 (187dde0) i686

26.391] (==) No Layout section.  Using the first Screen section.
26.391] (**) |-->Screen "SaX3-screen" (0)
26.391] (**) |   |-->Monitor "SaX3-monitor"
26.391] (==) No device specified for screen "SaX3-screen".
Using the first device section listed.
26.392] (**) |   |-->Device "Device"
26.392] (==) Automatically adding devices

26.565]  X.Org Server Extension : 5.0
26.567] (--) PCI:*(0:1:0:0) 10de:0324:1179:ff00 rev 161, Mem @ 0xc1000000/16777216, 0xe0000000/134217728, BIOS @ 0x????????/131072
26.567] (II) Open ACPI successful (/var/run/acpid.socket)
26.567] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
26.567] (WW) "dri2" will not be loaded unless you've specified it to be loaded elsewhere.
26.567] (II) "dbe" will be loaded by default.
26.567] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
26.567] (II) "dri" will be loaded even though the default is to disable it.
26.567] (II) "dri2" will be loaded even though the default is to disable it.
26.567] (II) LoadModule: "glx"
26.605] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
27.794] (II) Module glx: vendor="NVIDIA Corporation"
27.794]  compiled for 4.0.2, module version = 1.0.0
27.794]  Module class: X.Org Server Extension
27.794] (II) NVIDIA GLX Module  173.14.31  Sun Jul 17 22:43:28 PDT 2011
27.794] (II) Loading extension GLX
27.794] (II) LoadModule: "extmod"
27.815] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
27.836] (II) Loading extension MIT-SCREEN-SAVER

27.869]  ABI class: X.Org Server Extension, version 5.0
27.870] (II) Loading extension RECORD
27.870] (II) LoadModule: "nvidia"
27.870] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
28.038] (II) Module nvidia: vendor="NVIDIA Corporation"
28.038]  compiled for 4.0.2, module version = 1.0.0
28.038]  Module class: X.Org Video Driver
28.110] (II) NVIDIA dlloader X Driver  173.14.31  Sun Jul 17 22:20:25 PDT 2011
28.110] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
28.110] (II) NVIDIA X compatibility module for ABI 10.0 built from xorg-server-1.9.99.903
28.110] (++) using VT number 7

28.181] (II) Loading sub module "ramdac"
28.181] (II) LoadModule: "ramdac"
28.181] (II) Module "ramdac" already built-in
28.181] (II) Loading /usr/lib/xorg/modules/updates/drivers/nvidia_drv.so
28.181] (II) Loading /usr/lib/xorg/modules/libwfb.so
28.181] (II) Loading /usr/lib/xorg/modules/libfb.so
28.181] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
28.181] (==) NVIDIA(0): RGB weight 888
28.181] (==) NVIDIA(0): Default visual is TrueColor
28.181] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
28.181] (**) NVIDIA(0): Option "RenderAccel" "1"
28.181] (==) NVIDIA(0): Using HW cursor
28.181] (**) NVIDIA(0): Enabling RENDER acceleration
28.181] (==) NVIDIA(0): Video key set to default value of 0x101fe
28.182] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
28.182] (II) NVIDIA(0):     enabled.
28.774] (II) NVIDIA(0): NVIDIA GPU GeForce FX Go5200 (NV34) at PCI:1:0:0 (GPU-0)
28.774] (--) NVIDIA(0): Memory: 32768 kBytes
28.774] (II) NVIDIA(0): GPU RAM Type: DDR1
28.774] (--) NVIDIA(0): VideoBIOS: 04.34.20.25.a1
28.774] (--) NVIDIA(0): Found 2 CRTCs on board
28.774] (II) NVIDIA(0): Supported display device(s): CRT-0, DFP-0, TV-0
28.774] (II) NVIDIA(0): Bus detected as AGP
28.774] (II) NVIDIA(0): Detected AGP rate: 8X
28.774] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
28.774] (II) NVIDIA(0): 
28.774] (II) NVIDIA(0): Mode timing constraints for  : GeForce FX Go5200
28.774] (II) NVIDIA(0): Maximum mode timing values   :
28.774] (II) NVIDIA(0):     Horizontal Visible Width : 8192

28.775] (II) NVIDIA(0): 
28.775] (--) NVIDIA(0): Connected display device(s) on GeForce FX Go5200 at
28.775] (--) NVIDIA(0):     PCI:1:0:0:
28.775] (--) NVIDIA(0):     Nvidia Default Flat Panel (DFP-0)
28.775] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): 270.0 MHz maximum pixel
28.775] (--) NVIDIA(0):     clock
28.775] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Internal Dual Link LVDS
28.775] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): Native FlatPanel Scaling is
28.775] (--) NVIDIA(0):     not supported
28.775] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): DFP modes are not limited
28.775] (--) NVIDIA(0):     to 60 Hz refresh rate
28.775] (--) NVIDIA(0): Nvidia Default Flat Panel (DFP-0): DFP is internal to
28.775] (--) NVIDIA(0): 
28.775] (--) NVIDIA(0): --- EDID for Nvidia Default Flat Panel (DFP-0) ---
28.775] (--) NVIDIA(0): EDID Version                 : 1.3
28.775] (--) NVIDIA(0): Manufacturer                 : NVD
28.775] (--) NVIDIA(0): Monitor Name                 : Nvidia Default Flat Panel
28.775] (--) NVIDIA(0): Product ID                   : 2304
28.775] (--) NVIDIA(0): 32-bit Serial Number         : 0
28.775] (--) NVIDIA(0): Serial Number String         : 
28.775] (--) NVIDIA(0): Manufacture Date             : 2002, week 45
28.775] (--) NVIDIA(0): DPMS Capabilities            : Standby Suspend Active Off

28.776] (--) NVIDIA(0): 
28.776] (II) NVIDIA(0): Frequency information for Nvidia Default Flat Panel (DFP-0):
28.776] (II) NVIDIA(0):   HorizSync   : 29.000-55.000 kHz
28.776] (II) NVIDIA(0):   VertRefresh : 0.000-61.000 Hz
28.776] (II) NVIDIA(0):     (HorizSync from EDID)
28.776] (II) NVIDIA(0):     (VertRefresh from EDID)
28.776] (II) NVIDIA(0): 
28.776] (II) NVIDIA(0): --- Building ModePool for Nvidia Default Flat Panel (DFP-0)
28.776] (II) NVIDIA(0):     ---
28.776] (II) NVIDIA(0):   Validating Mode "1440x900":
28.776] (II) NVIDIA(0):     1440 x 900 @ 60 Hz
28.776] (II) NVIDIA(0):     For use as DFP backend.
28.776] (II) NVIDIA(0):     Mode Source: EDID
28.776] (II) NVIDIA(0):       Pixel Clock      : 96.21 MHz
28.776] (II) NVIDIA(0):       HRes, HSyncStart : 1440, 1504
28.776] (II) NVIDIA(0):       HSyncEnd, HTotal : 1536, 1760
28.777] (II) NVIDIA(0):       VRes, VSyncStart :  900,  903
28.777] (II) NVIDIA(0):       VSyncEnd, VTotal :  906,  912
28.777] (II) NVIDIA(0):       H/V Polarity     : -/-
28.777] (II) NVIDIA(0):     Mode is valid.

<-----> snipped many lines (blocks as the one above)

28.813] (II) NVIDIA(0): 
28.813] (II) NVIDIA(0): --- Done building ModePool for Nvidia Default Flat Panel
28.813] (II) NVIDIA(0):     (DFP-0) ---
28.813] (II) NVIDIA(0): 
28.813] (II) NVIDIA(0): 
28.813] (II) NVIDIA(0): --- Modes in ModePool for Nvidia Default Flat Panel (DFP-0) ---
28.813] (II) NVIDIA(0): "nvidia-auto-select" : 1440 x  900 @  59.9 Hz  (from: EDID)
28.813] (II) NVIDIA(0): "1440x900"           : 1440 x  900 @  59.9 Hz  (from: EDID)
28.813] (II) NVIDIA(0): "1440x900_60.00"     : 1440 x  900 @  54.1 Hz  (from: X Configuration file ModeLine)
28.813] (II) NVIDIA(0): "1440x900_60"        : 1440 x  900 @  59.9 Hz  (from: EDID)
28.813] (II) NVIDIA(0): "1440x900_54"        : 1440 x  900 @  54.1 Hz  (from: X Configuration file ModeLine)
28.813] (II) NVIDIA(0): "1024x768"           : 1024 x  768 @  60.0 Hz  (from: X Server, VESA)


28.813] (II) NVIDIA(0): --- End of ModePool for Nvidia Default Flat Panel (DFP-0): ---
28.813] (II) NVIDIA(0): 
28.813] (II) NVIDIA(0): Assigned Display Device: DFP-0
28.813] (II) NVIDIA(0): Requested modes:
28.813] (II) NVIDIA(0):     "1440x900_60.00"
28.813] (II) NVIDIA(0): Validated modes:
28.813] (II) NVIDIA(0): MetaMode "1440x900_60.00":
28.813] (II) NVIDIA(0):     Bounding Box: [0, 0, 1440, 900]
28.814] (II) NVIDIA(0):     Nvidia Default Flat Panel (DFP-0): "1440x900_60.00"
28.814] (II) NVIDIA(0):         Size          : 1440 x 900
28.814] (II) NVIDIA(0):         Offset        : +0 +0
28.814] (II) NVIDIA(0):         Panning Domain: @ 1440 x 900
28.814] (II) NVIDIA(0):         Position      : [0, 0, 1440, 900]
28.814] (II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
28.814] (II) NVIDIA(0): 
28.814] (II) NVIDIA(0): Implicitly adding the following modes to X Screen 0 (these
28.814] (II) NVIDIA(0):     will be available via XRandR and XF86VidMode):
28.814] (II) NVIDIA(0): 
28.814] (II) NVIDIA(0): "nvidia-auto-select" : 1440 x  900 @  59.9 Hz 
28.814] (II) NVIDIA(0): "1024x768"           : 1024 x  768 @  60.0 Hz 
28.814] (II) NVIDIA(0): "800x600"            :  800 x  600 @  60.3 Hz 
28.814] (II) NVIDIA(0): "800x600_56"         :  800 x  600 @  56.2 Hz 

28.814] (II) NVIDIA(0): 
28.814] (II) NVIDIA(0): Computing DPI using physical size from Nvidia Default Flat
28.814] (II) NVIDIA(0):     Panel (DFP-0)'s EDID and first mode to be programmed on
28.814] (II) NVIDIA(0):     Nvidia Default Flat Panel (DFP-0):
28.814] (II) NVIDIA(0):   width  : 1440 pixels  320  mm (DPI: 114)
28.814] (II) NVIDIA(0):   height : 900  pixels  200  mm (DPI: 114)
28.814] (--) NVIDIA(0): DPI set to (114, 114); computed from "UseEdidDpi" X config
28.814] (--) NVIDIA(0):     option
28.814] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
28.814] (--) Depth 24 pixmap format is 32 bpp
28.817] (II) NVIDIA(0): Initialized AGP GART.
28.819] (II) NVIDIA(0): kernel module enabled successfully
28.819] (II) NVIDIA(0): GPU initialized
28.819] (II) NVIDIA(0): AC state file path: /proc/acpi/ac_adapter/ACAD/state
28.820] (II) NVIDIA(0): ACPI: System is running on AC power
28.820] (II) NVIDIA(0): Created acpid client socket 16.
28.820] (WW) NVIDIA(0): Failed to determine docking state of the system : Unable to
28.820] (WW) NVIDIA(0):     find /sys/devices/platform/dock.*/docked file. Kernel
28.820] (WW) NVIDIA(0):     version may be less than 2.6.20 or dock.ko driver may not
28.820] (WW) NVIDIA(0):     be present
28.820] (II) NVIDIA(0): Registered for mobile display change hotkey events.
28.820] (II) NVIDIA(0): Setting mode "1440x900_60.00"
28.836] (II) NVIDIA(0): First mode initialized
28.838] (II) NVIDIA(0): Using built-in logo image.
28.838] (II) NVIDIA(0): Logo is 744x537 with depth 24.
28.982] (II) Loading extension NV-GLX
28.996] (II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
28.996] (II) NVIDIA(0): Visuals set up
28.996] (II) NVIDIA(0): Pixmap depths set up
28.996] (II) NVIDIA(0): GLX visuals set up
28.996] (II) NVIDIA(0): Framebuffer set up
28.997] (II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture

28.997] (==) NVIDIA(0): DPMS enabled
28.997] (II) Loading extension NV-CONTROL
28.998] (II) NVIDIA(0): Screen initialization complete
28.998] (==) RandR enabled
28.998] (II) Initializing built-in extension Generic Event Extension
28.998] (II) Initializing built-in extension SHAPE
28.998] (II) Initializing built-in extension MIT-SHM
28.998] (II) Initializing built-in extension XInputExtension
28.998] (II) Initializing built-in extension XTEST

28.998] (II) Initializing built-in extension DAMAGE
28.998] (II) Initializing extension GLX
29.544] (II) XKB: Reusing cached keymap
29.558] (II) config/udev: Adding input device Power Button (/dev/input/event6)
29.558] (**) Power Button: Applying InputClass "evdev keyboard catchall"
29.558] (**) Power Button: Applying InputClass "evdev keyboard catchall"
29.558] (**) Power Button: Applying InputClass "LocalKeyboard"
29.558] (II) LoadModule: "evdev"

< ---- snipped some lines —>

29.698] (II) No input driver/identifier specified (ignoring)
34.127] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
43.208] (II) NVIDIA(0): received ACPI buf battery BAT1 00000081 00000001
43.208] (II) NVIDIA(0):   ACPI event: battery BAT1 81 1
48.189] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
48.227] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
48.872] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.

196.622] (II) Open ACPI successful (/var/run/acpid.socket)
196.766] (II) NVIDIA(0): Setting mode “1440x900_60.00”
196.979] (II) NVIDIA(0): AC state file path: /proc/acpi/ac_adapter/ACAD/state
196.980] (II) NVIDIA(0): ACPI: System is running on AC power
196.980] (WW) NVIDIA(0): Failed to determine docking state of the system : Unable to
196.980] (WW) NVIDIA(0): find /sys/devices/platform/dock.*/docked file. Kernel
196.980] (WW) NVIDIA(0): version may be less than 2.6.20 or dock.ko driver may not
196.980] (WW) NVIDIA(0): be present
196.998] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.
197.013] (**) Option “Device” “/dev/input/event2”
197.013] (–) synaptics: AlpsPS/2 ALPS GlidePoint: touchpad found
376.119] Warning: Xalloc: requesting unpleasantly large amount of memory: 0 bytes.

Anyone sees a problem?
Kind regards
Andy

The nvidia driver is buggy. I tested it with a GeForce FX 5500 under Ubuntu and openSUSE and described the problem in this thread: http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/468146-nvidia-drivers-hangs-opensuse-12-1-a-3.html#post2409891

Under KDE, you should disable desktop effects.
For Gnome, you should enforce fallback mode. Iit doesn’t switch automatically because the driver is capable of 3D rendering. So, Gnome thinks it will be fine. But in fact in doesn’t work.
Or you can use Xfce or LXDE on this machine.

My Sandbox PC has an AGP FX5200 nvidia card. The nouveau driver in openSUSE-12.1 does not work for me with that card.

I needed to boot with the nomodeset boot code.

Then later I successfully installed (using the manual method) the proprietary nvidia 173.14.31 driver. (I had to black list the nouveau in the 50-blacklist.conf file and also disable modesetting in the kernel via the appropriate YaST menu selection).

I use the LXDE desktop on that PC.

Thanks to all who replied. I added gnome.fallback=1 to the boot parameters and changed KMS_IN_INITRD set to “no” and now it works fine!

Kind regards
Andy

LXDE is fine. The failing extension affects only compositing.

@fuegi1

Copy this text to the end of /etc/X11/xorg.conf

Section "Extensions"
        Option "Composite" "off"
EndSection

It won’t solve the driver issue, but disabling compositing will prevent gnome-shell to start and force Gnome to start in fallback mode.
There are several ways to enforce fallback. It’s just the most simple, I guess.

  • You were faster. :wink:
    Glad you solved it.