Nvidia failure after the upgrade to Leap 15.2

Hello, after the recent upgrade from 15.1 to 15.2, I found that I could only boot to the 4.xx kernel fine.
I was only prompted to login with a text based screen when booting to kernel 5.3.

I think it’s probably due to the propriety Nvidia driver after I did some research for the error in

journalctl -b -p err 
failed to read display number from pipe

Also I did the upgrade with the https://download.nvidia.com/opensuse/leap/${releasever} enabled.

I’m thinking to force re-installing nvidia driver but can’t be sure.

Hi
Check your enabled repository URLs;


zypper lr -d

The Nvida one should be pointing at Index of /opensuse/leap/15.2/x86_64 if not, fix and update, assuming your card supports G04 or G05, no more G03 support…

Hello, it has been pointing to https://download.nvidia.com/opensuse/leap/15.2/
Now if I add “x86_64” to the end as you suggested, Yast says the url is not correct.
Also it shows “repodata” directory is at “https://download.nvidia.com/opensuse/leap/15.2/”, so x86_64 should not be appended to the url?

Hi
No That’s correct for the URL, so is this a normal nvidia setup?


/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

$: /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
09:00.0 **VGA** compatible controller [0300]: NVIDIA Corporation GP104 [GeForce GTX 1070] [10de:1b81] (rev a1)
        Subsystem: Device [7377:0000]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia


But I’m in kernel 4.12 so I’m not sure if the command should be run under kernel 5.3 when the system is broken.

Hi
I install the hard way here on a GT710 and the 450.57 driver is working fine… You didn’t use nomodeset to upgrade at all?


grep GRUB_CMDLINE_LINUX_DEFAULT /etc/default/grub

Can you try booting to the 5.3.18 kernel and install the nvidia rpms from the command line and reboot, maybe even run mkinitrd before you reboot to ensure nouveau is blacklisted.

What desktop are you using?

Thank you for the tips about “nomodeset”.

I did pretty much a dirty upgrade with Nvidia repo enabled and without nomodeset in a normal session.

Just now I boot into kernel 4.12 with the nomodeset option, switched to tty1, forced install the nvidia package, and “mkinitrd” in the end.

Now kernel 5.3 can boot fine.

Much thanks!:good:

Hi
Can you check that nomodset has been removed?

Yes it is. Shouldn’t the grub edit during boot be automatically reverted after reboot?

Hi
OK, so you can run nvidia-smi or nvidia-settings and all is good?

Yes. But I confirmed that it’s working fine by running some heavy 3-D game which had zero issue.

Hi
OK, just wasn’t sure, enjoy :slight_smile: