NVidia Dual Graphics card issue

Ok all I have read through all the posts on the subject and none have exactly met my issue and none have fixed it.
I just did a fresh Suse 11 install KDE 3.5 because last time was KDE 4.0 and I wanted to make sure that was not the issue.
Hardware 2X Nvidia 8800 GTX video cards, and 2X Samsung 245BW Displays.
After install no GUI sax2 -r from root login dies stating Died at init.pl line 653, same thing it was doing on KDE 4.0 but on that I did get Xserver to start and run GUI but sax2 never would run and only one card was set right and only one monitor would work. And I did have Suse 10.3 setup on this hardware and working good, and even ran EVE on it. So I have not done a hole lot on htis install, yast2 starts from console but the graphics portion crashes and I cannot configure it. Any Ideas. I am not exactly new to Linux but I don’t use it a whole lot on this kind of hardware.

Thanks for any help.

Hey there, I’m having pretty much the same problem, Also running a similar system intel q6600 quad, dual 9800, dual display. compiz doesnt work when second monitor is enabled no effects what so ever to be specific. I used nvidia config application to enable the second monitor and had to rewrite the xorg.conf

Can you posty a copy of your xorg.conf so I can see what it is supose to look like. I have re installed Suse 11 again, so now I have now GUI at the moment, I am getting ready to download the NVidia drivers and try again.

Below is what I have working. As others have stated, be sure not to use Sax. Just install the Nvidia driver via init 3, and accept all of the defaults. Then use a modified xorg.conf something like this.


nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder58) Thu Jul 17 18:39:00 PDT 2008

Xorg configuration created by system-config-display

Section “ServerLayout”

Screen “Screen[1]” LeftOf “Screen[0]”

Option “Xinerama” “off”

Option “Clone” “off”

Identifier     "Multihead layout"
Screen         "Screen[0]" 0 0
InputDevice    "Mouse[0]" "CorePointer"
InputDevice    "Keyboard[0]" "CoreKeyboard"

EndSection

Section “Files”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
EndSection

Section “Module”
Load “dbe”
Load “type1”
Load “freetype”
Load “extmod”
Load “glx”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
EndSection

Section “InputDevice”
Identifier “Keyboard[0]”
Driver “kbd”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Identifier “Mouse[0]”
Driver “mouse”
Option “Protocol” “IMPS/2”
Option “Device” “/dev/input/mice”
Option “ZAxisMapping” “4 5”
Option “Emulate3Buttons” “yes”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[1]”
EndSection

Section “Monitor”
Identifier “Monitor[0]”
VendorName “NEC”
ModelName “FE700”
UseModes “Modes[0]”
DisplaySize 345 259
HorizSync 31.0 - 70.0
VertRefresh 55.0 - 120.0
Option “CalcAlgorithm” “XServerPool”
Option “DPMS”
EndSection

Section “Monitor”
Identifier “Monitor[1]”
VendorName “Optiquest”
ModelName “Q71”
UseModes “Modes[1]”
DisplaySize 345 259
HorizSync 30.0 - 115.0
VertRefresh 50.0 - 160.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device[0]”
Driver “nvidia”
VendorName “NVidia”
BoardName “GeForce FX 5200 (0x0322)”
BusID “AGP:01:00:0”
Screen 0
EndSection

Section “Device”
Identifier “Device[1]”
Driver “nvidia”
VendorName “NVidia”
BoardName “GeForce FX 5200 (0x0322)”
BusID “AGP:01:00:0”
Screen 1
EndSection

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 16
Option “TwinView”
Option “MetaModes” “1280x1024,1280x1024; 1280x1024; 1024x768,1024x768; 1024x768; 800x600,800x600; 800x600”
Option “TwinViewOrientation” “LeftOf”
Option “SecondMonitorHorzSync” “UseEdidFreqs”
Option “SecondMonitorVertRefresh” “UseEdidFreqs”
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
EndSection

Section “Screen”
Identifier “Screen[1]”
Device “Device[1]”
Monitor “Monitor[1]”
DefaultDepth 16
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
EndSection