nvidia drivers

I have recently installed SUSE 11.1, and am trying to install the nvidia drivers.
I tried to add the repository as follows:

Protocol: HTTP
Server Name: : download.nvidia.com
Directory on Server: /opensuse/11.1

When I hit next, I receive the following error:

Download (curl) error for ‘http://download.nvidia.com/opensuse/11.1/repo/repoindex.xml’:
Error code:
Error message: Couldn’t resolve host ‘download.nvidia.com

Any ideas?


In Yast Software Management choose Configuration from menu bar. Then choose Repositories, click the Add button and choose Community Repos from the list.
Nvidia is in there just waiting to be picked.

When I try that, I receive the helpful message:
Adding repository NVIDIA Repository failed”

Start the Software Installer, ignore errors, Pick Configuration, Repositories, and remove the faulty Nvidia repository. Now, click Add, Community…, pick Nvidia repo from list, OK, OK, OK. Back in Software installer the proper packages should be preselected for you.

I did remove the bad repository. I just tried it again. Same result.


Do this if haven’t already:
Disable IPv6 - openSUSE Forums

Try again. Sometimes there can be downtime on the nvidia repo IIRC.

Hello there ! Try with this repo

Index of /update/11.1

See u !

Thanks caf4926. That worked.

Good to know.:wink:

One question. How you upgraded to Kernel 2.6.29??? I am not using SuSE 11.1 since its original its too old to run nice with my very new laptop with backlight screen and so.

Please start a new thread. This way the subject is going to be misleading.