nvidia drivers won't start

NVIDIA - openSUSE

When I run nvidia server setting, I get this message:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

I’v tried using “sax2 -r” and nvidia config, but the server still won’t start at bootup. Yast->hardware-> graphics card and monitor show just VESA graphics.

nvidia 9800gt video card

lv

What installation method did you use? Have you tried this method?

nVidia 3d Problems !!! - openSUSE Forums

Hi try this
open up a terminal window (Konsole),type “su”, enter password and then type “nvidia-xconfig”. that should fix things for you.

I used the suse 11-64 dvd. Also, I had problems with no internet and no sound. I managed to fix no internet(just after I posted, I figured it out).

nvidia-config didn’t work.

Using X configuration file: “/etc/X11/xorg.conf”.
Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.backup’
New X configuration file written to ‘/etc/X11/xorg.conf’

Some message says I can’t edit the above message. ARG! -“it made a backup copy”

nvidia-xconfig: exits xserver.
nvidia-xconfig: same message
sa2 -r
no change.

So the one click install doesn’t work? I’v done it manually many times. That won’t be a problem.

Booting into runlevel 3, at the command line as root, did you do?

sax2 -r -m 0=nvidia

And if you do:

more /etc/X11/xorg.conf

What is the driver name in the Device section?

When you do:

lsmod | grep nv

Does “nvidia” appear in the list?

I uninstalled the existing nvidia drivers. I did a manual install(this usually works; installed gcc, make, and kernel source). It compiled, installed the kernel module, and I ran sax.

SaX: initializing please wait...
SaX: your current configuration will not be read in

SaX: access to your display has been granted
SPP: prepare device [0] profile: Depth24
SPP: prepare device [0] profile: NVidia
SPP: calling device [0] profile script: NVidia
SPP: prepare device [0] profile: NoModelines
SPP: prepare device [0] profile: Composite
SPP: including prepared profile(s)...

SaX: startup
SaX: X-Server: :0.0 -> grant
SaX: using cache data...
more /etc/X11/xorg.conf
# /.../
# SaX generated X11 config file
# Created on: 2008-11-29T14:03:28-0800.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Microsoft Wheel Mouse Optical"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  305 230
  HorizSync    31-48
  Identifier   "Monitor[0]"
  ModelName    "1024X768@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> VESA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "Framebuffer Graphics"
  BusID        "2:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "VESA"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "on"
EndSection

What is the driver name in the Device section?

lsmod | grep nv

Does “nvidia” appear in the list?

nvidia               7831720  26
i2c_core               45344  2 nvidia,i2c_nforce2
sata_nv                46860  6
libata                195232  2 pata_amd,sata_nv

I have 1400x900 lcd monitor. No nvidia flash screen appears on bootup.

lv

Your xorg.conf file seems to have a strange mix. I suggest you try generating a fresh one. Boot into runlevel 3, switch to root, and do:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup
sax2 -r -m 0=nvidia

Then reboot. Any help?

nvidia               7831720  26
i2c_core               45344  2 nvidia,i2c_nforce2
sata_nv                46860  6
libata                195232  2 pata_amd,sata_nv
linux-lt33:/ # mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup
linux-lt33:/ # sax2 -r -m 0=nvidia
SaX: initializing please wait...
SaX: access to your display has been granted
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
SPP: prepare device [0] profile: Depth24
SPP: prepare device [0] profile: NVidia
SPP: calling device [0] profile script: NVidia
SPP: prepare device [0] profile: NoModelines
SPP: prepare device [0] profile: Composite
SPP: including prepared profile(s)...

SaX: startup
SaX: X-Server: :0.0 -> grant
SaX: using cache data...

No effect. sax2 still doesn’t register video card. On previous versions of suse, manual install would work.

lv

Post back the new xorg.conf file . . .

I wonder if his dependencies are up to date. A kernel update may have rendered them obsolete.

console> more /etc/X11/xorg.conf
# /.../
# SaX generated X11 config file
# Created on: 2008-11-29T14:57:09-0800.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "us"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Microsoft Wheel Mouse Optical"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  305 230
  HorizSync    31-48
  Identifier   "Monitor[0]"
  ModelName    "1024X768@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> VESA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" "1024x600" "800x600" "768x576" "640x480"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "Framebuffer Graphics"
  BusID        "2:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "VESA"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "on"
EndSection


If try to change to 1400x900(ws), “not supported”. No newer software updates.

NVIDIA-Linux-x86_64-177.82-pkg2.run

lv

And you are running 64 bit Suse? Because that’s the 64 bit driver.

OK I see from an earlier post you are.

Just to double-check . . . sure it is 1400x900, not 1440x900? And it’s not widescreen (your xorg aspect ratio is only 4:3)?

If try to change to 1400x900(ws), “not supported”. No newer software updates.

Where are you trying to do that? What is producing that error message?

I just remembered something . . . take a look at the monitor dimensions in xorg.conf, the 305x230. That does not match the aspect ratio of 1400x900 (or 1440x900, which btw is what I have). 305x230 is a 4:3 aspect ratio, which matches 1024x768. Do this from the command line:

hwinfo --monitor

My LCD’s EDID incorrectly reports its resolution as 1024x768@75Hz; perhaps yours is doing the same. IIRC I needed to give X the correct monitor dimensions in order for the video driver to deliver the matching aspect ratio resolution. So my monitor (which is 19") has dimensions of 410x260 which matches up to 1440x900. Perhaps that’s what you need to do, too.

Yes, it’s an acer 19’ widescreen. So, it should be 1440x900(ws). sax2 can set without an error now, but sax tells me I have 24bit color, not 32bit color(windows does).

Also, I can tell nvidia driver isn’t running. I get shadow effect when I drag a window. There shouldn’t be one.

33: None 00.0: 10000 Monitor
  [Created at fb.71]
  Unique ID: rdCR.EY_qmtb9YY0
  Hardware Class: monitor
  Model: "Generic Monitor"
  Vendor: "Generic"
  Device: "Monitor"
  Resolution: 1024x768@76Hz
  Driver Info #0:
    Max. Resolution: 1024x768
    Vert. Sync Range: 50-90 Hz
    Hor. Sync Range: 31-61 kHz
  Config Status: cfg=new, avail=yes, need=no, active=unknown


Looks like the nvidia xserver isn’t running and my monitor isn’t being detected.

lv

My experience has been that the NVidia One-Click broke about a month ago and has not been fixed yet. Since that time the only way I’ve been able to get my NVidia drivers working is to install from the NVidia website.

  • From YAST make sure you have installed the ‘make’ and ‘kernel-source’ packages

  • Go to NVidia.com > Drivers > linux (32 or 64 bit) > download package to your desktop

  • Press <ctrl><alt> + <Backspace><Backspace>. This will kill your x session and bring you to a console. You might have to do it more than once.

  • log in then type ‘su’ and login as root.

  • cd /home/<username>/Desktop

  • launch the NVidia installer by typing
    sh NVIDIA-Linux-x86-177.82.pkg1.run (for 32 bit) or
    sh NVIDIA-Linux-x86-177.82.pkg2.run (for 64 bit)

  • follow the installer instructions. It will compile a driver for your specific kernel version

  • When the installer completes run
    sax2 -r -m 0=nvidia

  • Now type ‘exit’ to drop out of root then ‘startx’.

  • Check if composting is enabled. In SuSE 11 this happens automatically once nvidia drivers are installed. In a console as root type

    grep Composite /var/log/Xorg.0.log

Hope this helps.

You are making several incorrect assumptions. The driver is loaded, the monitor is being detected, and the color is correct. Looks like problem is with the configuration.

First, the color: 24-bit is 16.8 million colors. So is 32-bit. The extra 8 bits are optional, AFAIK not used. In any case, the color palette is exactly the same.

Next, the monitor: it is being detected but not at the correct resolution (and it was important btw to distinguish between 1440 and 1400; that throws off the aspect ratio and if not supported - and it’s not - will force drop down to the next resolution). This is not at all uncommon with widescreen LCD. Monitors have an eeprom in which is burned the EDID, the basic monitor characteristics. The Manufacturer may or may not put a DTD within the EDID, which records the timing details. The graphics card must be able to read the EDID and DTD if present to get the correct resolutions. But often the DTD is not present and/or the native resolution does not conform to the standard algorithm (this is the common issue with ws lcd) which results in the card dropping to a default resolution which is arithmetically correct (i.e., per the algorithm). The hwinfo command is just reporting what the card is interpreting from the EDID. My monitor reports exactly the same as yours does. From a X server configuration standpoint, what this means is that sax cannot determine the correct monitor size/resolution either; after all, it can only rely on the card which in your case (and mine, I have an very simlar Samsung monitor and an nvidia 7600GT) cannot obtain an accurate reading. So you (and I) need to provide that data manually.

The nvidia driver is being loaded by the kernel. You saw that with the lsmod command earlier. And the driver is specified in xorg.conf to be loaded by the server. So let me suggest this: I will post here the relevant sections of my xorg.conf modified to your system based on the info you’ve provided so far. Make a backup copy of the current xorg.conf file once again. Then copy paste from my xorg.conf to yours. Then re-start the X server, and we’ll see what you get. Also at that point we will look at the X server log for what the server is seeing and doing. OK?

To make a backup copy of xorg.conf, just open a terminal window, switch to root (the “su” command), and do:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup1130

Now open the xorg.conf file in a text editor as root. Press Alt-F2 to bring up a run dialog box and type in:

kdesu kwrite /etc/X11/xorg.conf

If you are using Gnome (please tell me if you are), IIRC that’s done the same but it’s:

gnomesu /etc/X11/xorg.conf

If Alt-F2 doesn’t work in Gnome, you can run the command from a terminal window.

Now find the the Monitor, Screen, and Device sections. One by one replace each section with the following. Please be very, very careful doing this. I am providing dimensions for a 19" diagonal widescreen lcd with a resolution of 1440x900 and a refresh rate (vertical sync) of 60Hz which very likely is the native for your monitor - if the native refresh is a higher resolution, that’s OK; 60Hz should still work (albeit conceivably at a lower bit rate); it’s only going higher than the device can handle that is risky. We can tweak this later. I’m providing a wide range for the horiz refresh. X will try to choose what it thinks best from within this range.

Find the Monitor Section and replace it with this:

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "Acer"
    ModelName      "1440x900@60Hz"
    UseModes       "Modes[0]"
    DisplaySize     410    260
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 60.0
    Option         "DPMS"
EndSection

Now find the Device Section and replace it with this:

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForce 9800 GT"
    BusID          "2:0:0"
    Screen          0
EndSection

Now find the Screen Section and replace it with this:

Section "Screen"
  Identifier   "Screen[0]"
  Device       "Device[0]"
  Monitor      "Monitor[0]"
  Option       "VertRefresh" "60.0"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
EndSection

The only thing I’m unsure of above is the BusID; that is specific to your machine and there is no way for me to validate that. So I’m just taking that from your current config file.

Save the file. Then end the session which should restart the server. Ctrl-Alt-Backspace twice will also kill the server. Or you may need to reboot. (It depends on how you got to where you are now.) If all went as planned, you’re in the gui at the proper resolution. Run YaST/Hardware/Graphics Card to verify it is seeing the changes - the resolution, 24-bit (again, note that if your monitor’s native refresh rate is 75Hz, then you may see only 16-bit since we set the rate to 60Hz), monitor size. And the 3D Hardware Acceleration box should be checked. Exit without saving. Report back results.

Ok, I did that again(reinstall). I use the opensuse guide with “telinit 3”.

Now type ‘exit’ to drop out of root then ‘startx’.

  • Check if composting is enabled. In SuSE 11 this happens automatically once nvidia drivers are installed. In a console as root type

    grep Composite /var/log/Xorg.0.log

Hope this helps.

console> grep Composite /var/log/Xorg.0.log
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is (no text follows)

I did startx and exited. The nvidia flash screen appears! :slight_smile:

Thanks for the help, just need to reboot to see if it happens twice. Now, I need to fix my sound problems.

lv

You are making several incorrect assumptions.  The driver is loaded, the monitor is being detected, and the color is correct.  Looks like problem is with the configuration.

First, the color:  24-bit is 16.8 million colors.  So is 32-bit.  The extra 8 bits are optional, AFAIK not used.  In any case, the color palette is exactly the same.
Next, the monitor:  it is being detected but not at the correct resolution (and it was important btw to distinguish between 1440 and 1400; that throws off the aspect ratio and if not supported - and it's not - will force drop down to the next resolution).  This is not at all uncommon with widescreen LCD.  Monitors have an eeprom in which is burned the EDID, the basic monitor characteristics.  The Manufacturer may or may not put a DTD within the EDID, which records the timing details. The graphics card must be able to read the EDID and DTD if present to get the correct resolutions.  But often the DTD is not present and/or the native resolution does not conform to the standard algorithm (this is the common issue with ws lcd) which results in the card dropping to a default resolution which is arithmetically correct (i.e., per the algorithm).  The hwinfo command is just reporting what the card is interpreting from the EDID.  My monitor reports exactly the same as yours does.  From a X server configuration standpoint, what this means is that sax cannot determine the correct monitor size/resolution either; after all, it can only rely on the card which in your case (and mine, I have an very simlar Samsung monitor and an nvidia 7600GT) cannot obtain an accurate reading.  So you (and I) need to provide that data manually.

The nvidia driver is being loaded by the kernel.  You saw that with the lsmod command earlier.  And the driver is specified in xorg.conf to be loaded by the server.  So let me suggest this: I will post here the relevant sections of my xorg.conf modified to your system based on the info you've provided so far. Make a backup copy of the current xorg.conf file once again.  Then copy paste from my xorg.conf to yours.  Then re-start the X server, and we'll see what you get.  Also at that point we will look at the X server log for what the server is seeing and doing.  OK?

Thanks make much more sense. My point was this. Before I install the nvidia drivers in msw, I get a shadow when dragging a window. In suse, the nvidia flash screen doesn’t appear and I see the same shadow. I managed to get the flash screen and no shadow on one boot. Now, no flash screen and window drag shadow. So, the nvidia driver is loading. 2D acceleration is clearly off. Bad cfg is the problem.

To make a backup copy of xorg.conf, just open a terminal window, switch to root (the “su” command), and do:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup1130

Now open the xorg.conf file in a text editor as root. Press Alt-F2 to bring up a run dialog box and type in:

kdesu kwrite /etc/X11/xorg.conf

If you are using Gnome (please tell me if you are), IIRC that’s done the same but it’s:

gnomesu /etc/X11/xorg.conf

If Alt-F2 doesn’t work in Gnome, you can run the command from a terminal window.

Now find the the Monitor, Screen, and Device sections. One by one replace each section with the following. Please be very, very careful doing this. I am providing dimensions for a 19" diagonal widescreen lcd with a resolution of 1440x900 and a refresh rate (vertical sync) of 60Hz which very likely is the native for your monitor - if the native refresh is a higher resolution, that’s OK; 60Hz should still work (albeit conceivably at a lower bit rate); it’s only going higher than the device can handle that is risky. We can tweak this later. I’m providing a wide range for the horiz refresh. X will try to choose what it thinks best from within this range.

Find the Monitor Section and replace it with this:

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "Acer"
    ModelName      "1440x900@60Hz"
    UseModes       "Modes[0]"
    DisplaySize     410    260
    HorizSync       30.0 - 80.0
    VertRefresh     50.0 - 60.0
    Option         "DPMS"
EndSection

Now find the Device Section and replace it with this:

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForce 9800 GT"
    BusID          "2:0:0"
    Screen          0
EndSection

Now find the Screen Section and replace it with this:

Section "Screen"
  Identifier   "Screen[0]"
  Device       "Device[0]"
  Monitor      "Monitor[0]"
  Option       "VertRefresh" "60.0"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1440x900" "1280x800" "1024x768" "800x600"
  EndSubSection
EndSection

The only thing I’m unsure of above is the BusID; that is specific to your machine and there is no way for me to validate that. So I’m just taking that from your current config file.

Save the file. Then end the session which should restart the server. Ctrl-Alt-Backspace twice will also kill the server. Or you may need to reboot. (It depends on how you got to where you are now.) If all went as planned, you’re in the gui at the proper resolution. Run YaST/Hardware/Graphics Card to verify it is seeing the changes - the resolution, 24-bit (again, note that if your monitor’s native refresh rate is 75Hz, then you may see only 16-bit since we set the rate to 60Hz), monitor size. And the 3D Hardware Acceleration box should be checked. Exit without saving. Report back results.

(edit)