Nvidia drivers with Tumbleweed

Hello everyone!

I’d like to add my question here concerning NVIDIA drivers and tumbleweed.
I read the post which warned not to use tumbleweed and NVIDIA original drivers together.
Well, we’ve got a lot of old x86 Computers at work which have been running MX Linux lately, which I am fed up with. I’d like to continue using the machines, so I had to install Opensuse Tumbleweed (2 days ago), because I don’t really have a choice, do I? From Leap onwards, there is no x86 version of Opensuse, but there is a tumbleweed one, so I have to use it.

So, I installed the driver, first in an rpm version from the 13.2 repos, but after the compiling process of the driver module, it said “error, the nvidia.ko driver was not created” among a lot of other text which roughly suggested that the kernel and the driver were not compatible. Then I uninstalled that, got the latest .run version from the NVIDIA website, and installed that, but it basically said the same.
Trying to start the machine anyway got me into some trouble and had to chroot into the machine to uninstall it again. Bloody hell.
Now I’m sitting here and I don’t know how to install it.

I have read https://news.opensuse.org/2017/09/20/new-repository-caters-to-tumbleweeds-nvidia-users/ announcing a repository for tumbleweed, but it won’t work, because it is an OLD card, and supports only the legacy driver G01. In the rpos it has only the G04 drivers.

Now, I would say, “to hell with it, use the nouveau driver and xrender”, which does work, but it won’t play videos at all. The sound works, but the pictures don’t change. I’ve tried all the video drivers in the list of smplayer and vlc. None work. But we MUST play videos in order to use the machines correctly.

Is there a way out of this?

As I said: they are x86 desktop computers, the video card is a Nvidia GeForce FX 5200 card.
Maybe the easiest solution is to find a way to use glx with nouveau. But I don’t know how. Please tell me the easiest way to get it working (without buying new stuff, it’s 5 computers!)

Can somebody please help me?



Hi, it’s me again,

I’d like to add the info from the Nvidia website about which version of the driver is supported by my Video card:

It says:

Legacy releases for GeForce 5 series GPUs (*)
Current official release: 173.14.39 (x86 / x86_64)

look here:

Of course a package from the 13.2 repo is NOT going to work on current Tumbleweed.
Assuming that your computers are desktops equipped with Nvidia (old) cards, you should be able to install the G01 driver “the hard way” following this guide https://en.opensuse.org/SDB:NVIDIA_the_hard_way (not so hard really…)
If your machines are laptops with “Optimus” architectures you should install Bumblebee instead.

If you already did that and met with problems, please be more specific about what you did or didn’t, we cannot browse over your shoulder :wink:

Hi, thanks a lot for your reply!

I’ve tried that, but without success. The building of the driver does fail.

Please take a look at the nvidia-installer.log here:


(no bumblebee, only one graphics card, the nvidia)

Thanks for the help! Much appreciated!


The only way (probably unlikely) is to head off to the Nvidia forum and someone may have some patches… replace the cards with intel ones…

Even then it’s unlikely to work… too many changes, even my GT8800 card it no longer supported (x86_64 & 340.104) in Tumbleweed without patching and building the hardway…

Apparently the 173.14.39 driver has not been updated since Dec. 2013, so it is highly unlikely that it will build with a 4.13.x kernel even with some patches and unfortunately the 304.x driver doesn’t support your card.
Maybe other members with greater experience with old HW might help you further, but unfortunately my knowledge stops here.
Good Luck.

Hello everyone!

Thanks a lot for the kind help, even if without success so far !!

I have tried a few times more, but no luck.
So, I will have to say googbye to nvidia.

BUT is there a way of using GLX with the nouveau driver, as I suggested earlier? Does anyone know how to do that?
Searching the web I found posts suggesting it was possible by loading the modules dri and glx in /etc/X11/modprobe.conf (which is deprecated, I thought)

But I don’t have a working version of that file here. Mine was “shredded” in some installation process (even old ones, I’ve checked all of them through), and I don’t see a realistic way of writing it on my own. I tried, however, but it ended up in not loading up X at all, as long as I had it set, so I renamed it again, and haven’t touched it since.

Is there a modern way of telling X / nouveau to use GLX and dri extensions?

Cheers to all the helpers around,


Is Mesa-dri-nouveau installed?

No, should it?

Well from the info;

This package contains nouveau_dri.so, which is necessary for
Nouveau's 3D acceleration to work. It is packaged separately
since it is still experimental.

Oups, I was curious and installed Mesa-dri-nouveau, but on reboot there was no X, and even worse, the console keeps switching between two screens in a way that I can’t log in there also.

Does anyone know about that problem?

Hmm, I will have to deactivate Mesa-dri. I’ll manage that on my own, but is anyone able to help me get it working with mesa-dri ?



Ok, it seems that no one is able to help me.
Just to update everyone, here is how things went:

In the end I uninstalled Mesa-dri-nouveau because there were problems in sddm display manager (text is invisible) and especially in kde plasma desktop, which is next to useless because nothing is rendered correctly. It does warn about incompatibilities with QT apps, so no wonder. I don’t really use kde, but in order to make settings to sddm and any other display manager in opensuse you need to log into kde and make changes there. So I must be able to enter it when necessary.

To work on the xfce4 desktop, which I use, xrender and nouveau is enough for the GUI. Just the videos are a problem.

Here is what I have installed:

S | Name | Zusammenfassung | Typ
| Mesa-dri-nouveau | Mesa DRI plug-in for 3D acceleration via-> | Paket
| Mesa-dri-nouveau-32bit | Mesa DRI plug-in for 3D acceleration via-> | Paket
| libXvMC_nouveau | XVMC state tracker for Nouveau | Paket
| libXvMC_nouveau-32bit | XVMC state tracker for Nouveau | Paket
i+ | libdrm_nouveau2 | Userspace interface for Kernel DRM servi-> | Paket
i+ | libvdpau_nouveau | XVMC state tracker for Nouveau | Paket
i+ | xf86-video-nouveau | Beschleunigter Open-Source-Treiber für n-> | Paket
I found out, however, you can install xf86-video-nouveau, which I think helps, but I’m not expert enough to say where and how.
In the end it worked out for me to play with the va-api (libva), which offers libvdpau for nvidia cards, which is a 3D rendering system. And in the vlc player I use the driver GLX, which uses the GPU, although I can watch the videos in only small window. As soon as I try to make the window bigger it crashes.

Well, it’s nothing to write home about, but at least it sort of works on a minimal scale.
I will “dd” the partition root + home + the MBR onto the other identical machines and hope it works. If not, there is always our friend “chroot” to fix the mess.

Cheers folks!