nVidia Drivers Still Don't Work!

Maybe some of you will remember me. 2 weeks ago, I had problems with my nVidia drivers. I had installed the newest version (180.29) on my openSuSE and my Graphical environment wouldn’t load anymore(wrong kernel module). I just came back from vacation and I decided to give it another try. I have tried and tried and it still won’t work. Reinstalled & updated kernel numerous times, installed many nVidia drivers(180.35,180.5,185.0 <–beta drivers not officially released) and 180.29 of course, but nothing works!!! Has anyone gotten the drivers to work???

Yes, of course. I’m using the nvidia binaries from the 9x. series. Are you followed the instructions in the readme file? Including the last line:


sax2 -r -m 0=nvidia

Hi
This is my canned response for doing it the ‘Hard Way’ :slight_smile:

Have you installed the nvidia driver via 1-click? If not I recommend
the hard way, else follow the easy way here;
Nvidia

If you have installed nvidia rpms via the easy way, I suggest removing
the rpms installed and disabling the nvidia repository first.

You can download the driver for your arch from;
Nvidia Unix Drivers

On the download page, check that your card is supported by the driver
your about to download by using the following command;


echo -n "0x" && /sbin/lspci -nv |grep VGA|cut -f4 -d ":"|cut -f1 -d "("

From the above output use the numbers from the output to look at the
Supported Products List (link on the left) to verify your card is
supported by the driver.

You may wish to ensure your system is up to date. The first command
refreshes the repositories, the second lists any updates, the third
will apply the updates.

 sudo zypper ref
sudo zypper lu
sudo zypper up

NOTE: If the kernel updated, please reboot before continuing :slight_smile:

If you don’t have the kernel source and tools etc installed then


sudo zypper in kernel-source linux-kernel-headers kernel-syms
module-init-tools make gcc

Press ctrl+alt+F1 and login as your user :slight_smile:


su -
init 3

cd to the Nvidia Unix Driver you downloaded


sh NV*.run -q
sax2 -r -m 0=nvidia
init 5 && exit
ctrl+alt+F1
exit
ctrl+alt+F7

The ctrl+alt+F7 gets you back to the GUI (X session).

Now after a kernel update, you don’t need to run the sax2 command, just
the others to get to run level 3, rebuild the driver and exit.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
up 16:12, 1 user, load average: 0.57, 0.45, 0.37
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

As you can see, my system looks a lot like yours. You must be doing something wrong, or forget something. Since the 180.29 driver is the latest stable release i suggest you download that one and follow steps below:
0. Install kernel-source and kernel-syms of running kernel

  1. Hit Ctrl-Alt-F1 simultaneously
  2. Log in as root + rootpassword
  3. type: init 3
  4. cd to folder where driver 180.29 was downloaded
  5. type: sh NVIDIA-Linux-x86_64-180.29-pkg2.run -q
  6. Follow directions and hit Enter when asked a question
  7. Driver is now installed
  8. type: sax2 -r -m0=nvidia
  9. Choose “Change configuration”
  10. You’ll see your NVcard recognized, check Options - NoLogo and RenderAccel (just click them to become blue)
  11. Check your monitor and resolution, if it’s not recognized, pick LCD or VESA with right resolution, or insert Monitor-disk
  12. Click OK
  13. Click Save Configuration
  14. Exit Sax2
  15. type: init 5 and X should start.

If this doesn’t work, you probably have messed up your system with different driver versions. I would do a reinstall, check Software kernel-developpement during install, update when given the opportunity, finish install, install NVidia-driver as described above, and you’re done.

Forgot, just to show you. This is from konqueror sysinfo:/

Weergave-informatie
Leverancier: NVIDIA Corporation
Model: GeForce 9800 GT/PCI/SSE2
Stuurprogramma: 3.0.0 NVIDIA 185.13

See, latest driver works as well