Nvidia Drivers not Working and No Sound either

Finally after the futile attempts of getting my sound working with 10.3 I left it until the new version (11) comes out… n here it is…and still my sound is not working and to top it all off whenever I install Nvidia drivers for my graphics card X does not start and i end up with reinstalling openSUSE.

System Specs:
Processor: Intel Pentium 4, 2.93 Gig (single core)
RAM: 2 Gigs
Sound Card: Onboard Realtek AC97 Audio
Graphics Card: Geforce 7600GT

In previous versions I was able to install whatever Nvidia drivers I needed and it was working straight away once I restarted my computer, but now nothing happens except a blue screen (not BSOD) with a text box telling something is wrong and what do you wanna do blahblahblah.

With my sound basically nothing is heard through my headset. They are connected in with normal 3.5mm Jack’s for Sound n Voice (if needed). I’ve tried Alsa n everything (I even had to install alsaguimixer) but nothing has worked. I’ve tried to configure with YAST but that has also failed miserably.

I’m not a Linux expert at all but more of a casual user. And wish to use it more often. How can I get past these basic problems???

For your sound, (since I do not know at this time with the limited information I that I have as to what is needed to fix your sound, but) try working your way through the audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note if after trying all the steps (as appropriate through the guide guidance), that does not help, then please provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

and also copy and paste the following into a terminal and paste here the output URL that it will provide you after you run it:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

This downloads and executes an audio diagnostic script on your PC.