Nvidia drivers not installing

Hi I seem to be having an issue with installing the drivers fromthe 1 click thingy on the wiki the one for geforce 8 and later - basically it shows this error msg -

Subprocess failed. Error: RPM failed: error: File not found: /var/cache/zypp/packages/nVidia Graphics Drivers/x86_64/nvidia-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64.rpm

I already try’d

sudo rpm --rebuilddb && sudo zypper clean -a && sudo zypper ref

but it didn’t work and yes this is a new/clean install not an upgrade and yes this a Single card not dual i.e it’s just 1 gfx card and yes this is 13.2 with latest updates

Please run this in a terminal window to install the driver, and post error messages you might get:

sudo zypper in nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03

That “file not found” error might point to some filesystem problems though. YaST downloads the file, so it should be there when you don’t get an error before that.
So try to run a filesystem check.

And I hope the G03 driver is the right one, you didn’t specify what graphics card you have… :wink:

PS: I have a suspicion:

File not found: /var/cache/zypp/packages/nVidia Graphics Drivers/x86_64/nvidia-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64.rpm

There’s a space in that file name. I remember reading that YaST/zypper have problems with spaces in the repo name.
Try to rename it.

OK so i did has you asked with a few twists - I opened a termainl has root (open terminal and put in


and then i inputed


to run the GUI file manager has root and copy’ed the folder to my downloads via root file manager and renamed to nVidia_Graphics_Drivers via root GUI/file manager and once i was done i exited and installed one by one although i don’t know if it’s gonna work gonna restart and see

but before i restart i ran su again and ran nvidia-xconfig and it spat it out this error -

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable

is this something to worry about?

also some one on the higher ups should tell nvidia about this error has i had to re-install my system cause i thought i had a faulty system (first thing i try’ed tbh)

Why did you run nvidia-xconfig??? You don’t normally need to do that. Install then reboot. Perhaps you are following some out dated instructions???

I’m going by what i remember from my memories not specfically instructions just stuff i thought would help any way to results

It worked and it’s solved although this makes me question the nvidia repos :open_mouth:

They work great for me and most people

looks like the nvidia package / drivers was the first thing to notice of a buggy system i just try’ed to install gnome codecs and it failed with the same error - my guess is my system is screwed - my guess and it could be wrong :expressionless:

Can you please post your repo list?

zypper lr -d

And there’s nothing wrong with the nvidia repo itself.
The problem seems to be that the repo name on your system contains spaces which apparently doesn’t work at the moment.
IOW, that’s a bug in the package management stack.
Remove all spaces in your repo names, and you shouldn’t have any problems any more. Now you probably added the Packman repo with a space in the name (e.g. “Packman Repository”).

FYI, I can reproduce it here, so it’s not that your system is screwed.
As I mentioned already, I read somewhere about this problem, but cannot find that any more. I think it was a bug report though.

Apparently the problem with installing packages with spaces in the filenames was a bug in rpm, caused by a patch added with the last update.

An update that should fix it was released today, so update your system and the problems should hopefully be gone.

From today’s update’s changelog:

* Thu Jan 08 2015 mls@suse.de

- fix noglob patch, it broke files with spaces [bnc#911228]

Hurray for patches!:slight_smile: you still want my repo list? also sorry it took this long to reply it’s i sleep in for some varying hours some times :expressionless:

Not if everything works now… :wink: