NVIDIA drivers from community repo doesn't work

Hi, I’m on Tumbleweed (snapshot 20201025, the last stable i think) and I’ve used nouveau drivers till now on this computer. Now I’m trying to install Nvidia G05 drivers from the nvidia community repo, but when i reboot, the resolution is very very small and I also can’t log in to my desktop (I write the password, click login, and it ask me for password again). I’ve tried 2 times and obviously i’ve rolled back with snapper.
How can I successfully install the Nvida drivers?


The latest snapshot is 20201123, old kernel, new driver built for later kernel. Update your system or install the nvidia driver the hard way…

Oh, understood, tomorrow i will try with the hard way. Thanks!

It’s not that hard… :wink: just make sure you have kernel-default-devel and libglvnd-devel installed and should be good to go.

Hi! I’ve tried this way but something is gone wrong :smiley:

ERROR: Unable to load the kernel module 'nvidia-uvm.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if another driver, such as nouveau, is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA GPU(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

The log is https://pastebin.com/zBx3fCfT

I’ve alredy disabled nouvead to boot passing nomodeset as boot parameter and blacklisted it in 50-blacklist.conf

Boot to multi-user target and remove the nomodeset, run mkinitrd to add the blacklist. Then you need to disable uvm for that kernel/driver with the --no-unified-memory option.

If you updated to the latest snapshot, there would be nothing to do except a zypper dup…

Honestly I’ve ever been at the last snapshot, but I’ve often noticed small problems (for example few gnome extensions not working, or any small glitches…) so I would like to try to stay at the last snapshot declared stable. In your opinion, is this a good thing to do or not?

All good with --no-unified-memory. I’ve not used it before because i thought that CUDA was important. It is not?

Well for the likes of blender and other applications that can use, cuda is important, but if it works for you without it won’t be a problem :slight_smile:

Not here, but you could get left behind and have major issues if try to update…

What extensions are not working? Gnome is now up to 3.38.1.

The 455.45.01 is building with uvm…

User is on an old kernel and snapshot…

Hi! For example gtile and try icons says many time that i need an update but if i install an update they don’t work. Others as let it snow for example (really not important :D) doesn’t works at all. Other things are, for example, that firefox often have glitches, and my wireless adapter sometimes lost the connection and let me go crazy, especially (but not only) when i suspend the computer. All things are little problems, but i would like to know how it works without these problems. In any case, i think i will come back to the last snapshot in the next weeks, it seems you all don’t agree with this way to go lol!lol!

For the tray icon, I’m assuming that is ‘AppIndicator and KStatusNotifierItem Support’ so are you using the web interface or Tweak Tool when updating? I normally just restart the desktop (alt+F2 enter r [for restart] and press enter) if it shows error. Again, such an old version, hard to say… Overall Tumbleweed is pretty stable, sure some things may fail, but that is expected, it is Tumbleweed, bug reports are needed. My qemu machines stopped working when the 5.9.x series hit, bug report created, took a few cycles but now all fixed (backported) in 5.9.10. The other month had an issue with wicked and my qemu machines, bug report and sorted in a couple of days. Those are the only two I’ve created in awhile and haven’t affected my actual desktop functionality, it’s been rolling along in fact, just like a Tumbleweed… :wink:

Wifi issues are likely kernel/driver/firmware regressions, bug reports are needed for that… openSUSE:Submitting bug reports - openSUSE

Hi! Sorry for late reply… I’m going to follow your advices and come back to the latest snapshot. Which is the right way? I’ve download.opensuse.org-non-oss | Repository principale (NON-OSS) (SNAPSHOT-NUMBER) now in my repository, which is the right way to come back to the latest?

The repository should be the oss one? non-oss if for non free applications or don’t meet spdx licensing. Why are you downloading, or do you mean adding the repository?

Can you show the output from;

zypper lr -dE

Sorry, I’ve indicated NON-OSS as example, because both OSS and NON-OSS has the same (SNAPSHOT) at the end.

zypper lr -dE
#  | Alias                                | Nome                                   | Abilitato | Controllo GPG | Aggiornamento | Priorità | Tipo   | URI                                                                               | Servizio
 1 | download.nvidia.com-tumbleweed       | nVidia Graphics Drivers                | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://download.nvidia.com/opensuse/tumbleweed                                   | 
 2 | google-chrome                        | google-chrome                          | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                               | 
 3 | http-download.opensuse.org-c9e78507  | openSUSE:Factory                       | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                 | 
 4 | https-download.opensuse.org-0a8de055 | utilities                              | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://download.opensuse.org/repositories/utilities/openSUSE_Factory/            | 
 5 | https-download.opensuse.org-6222d9b5 | openSUSE:Factory                       | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Factory/snapshot/            | 
 6 | https-download.opensuse.org-9a34868a | home:Dead_Mozay                        | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://download.opensuse.org/repositories/home:/Dead_Mozay/openSUSE_Tumbleweed/  | 
 7 | https-download.opensuse.org-b7824882 | devel:languages:go                     | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://download.opensuse.org/repositories/devel:/languages:/go/openSUSE_Factory/ | 
 8 | https-download.opensuse.org-f6e8def5 | openSUSE:Tumbleweed                    | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/         | 
10 | packman.inode.at-openSUSE_Tumbleweed | Packman Repository                     | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                 | 
12 | repo-non-oss                         | openSUSE-Tumbleweed-Non-Oss (20201025) | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | http://download.opensuse.org/history/20201025/tumbleweed/repo/non-oss/            | 
13 | repo-oss                             | openSUSE-Tumbleweed-Oss (20201025)     | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | http://download.opensuse.org/history/20201025/tumbleweed/repo/oss/                | 
15 | repo-update                          | openSUSE-Tumbleweed-Update             | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                   | 
16 | teams                                | teams                                  | Sì        | (r ) Sì       | Sì            |   99     | rpm-md | https://packages.microsoft.com/yumrepos/ms-teams                                  | 

Are you using tumbleweed-cli then?

Yes, I’ve used it when i switched to the previous snapshot

Then you should just be able to use that to switch to the next snapshot of choice, or latest with tumbleweed switch.